Sign in to follow this  
SteveFx

Version 2.7

Recommended Posts

The version available for sale from my blog is 2.7.

 

This is identical to 2.6 except that it can now better handle the scenario where FSX Steam Edition (SE) and FSX are installed on the same computer at the same time. With 2.7 the libraries can be switched from one system to another and the correct FSX configuration fileis used.

 

If you have a system with just FSX installed or just Steam Edition installed there is no advantage to 2.7 over 2.6 – they both work equally well.

 

You should receive an update email from the Flight Sim Store shortly

Edited by SteveFx
Update from Adrian at Flight Sim Store

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Steve,

Thanks very much for the update to ver 2.7. I've looked through the manual and Readme, but it is not clear to me how one switches  the Fixer back and forth between FSX and FSX-SE when both sims are installed on the same machine. I guess I was anticipating some type of "button" on the Fixer GUI to help with this, kind of like what there is for going back and forth between DX9 andDX10. So since that is not the case, does one have to essentially go thru the process of uninstalling the Fixer from one sim and then reinstalling it on the other, or is there a more convenient method?

Thx,

Al

Share this post


Link to post
Share on other sites

You need to uninstall the libraries then change the path then install the libraries. So two button presses and a path browse. All settings carry over so you don't need to do anything else.

 

I couldn't devise a better way that didn't complicate things for customers with simple setups.

Share this post


Link to post
Share on other sites

Steve,

That sounds like a pretty convenient process to me -- browsing to the appropriate FSX/FSX-SE location is no problem.

Thanks very much.

Al

Share this post


Link to post
Share on other sites

Welcome back Steve, hope you had a nice holiday, well deserved.  :P

Share this post


Link to post
Share on other sites

Steve,

That sounds like a pretty convenient process to me -- browsing to the appropriate FSX/FSX-SE location is no problem.

Thanks very much.

Al

Its a shame it doesn't remember previous choices - I will see if I can make it a bit slicker in the future

Share this post


Link to post
Share on other sites

Hi Steve,

 

I was testing version 2.7 and I think it's not working the way it suppose to be. That is handling both FSX and FSX SE installations at the same time not needing to uninstall / install the libraries each time I use one Sim or the other one. In the way it is implemented only one Sim at a time works with DX10 Scenery Fixer.

 

Hope I was clear enough.

 

Kind regards.

Share this post


Link to post
Share on other sites

Sorry, but it is working the way I said it would work not the way you hoped it might work!

 

You can use one system at once.

 

( I do understand your point and did consider if there was any simple way to achieve that)

 

When it was written SE didn't exist and thus it operates on and stores the state of a single system.

 

To handle two systems at once it would need two AA buttons, two Install buttons, two paths, track two lots of effect directory timestamps etc etc. Or it would need a switch and to store the states for the two systems in separate files.

 

I didn't want to overcomplicate the GUI when most people have a single system or if they have two installs are using one and migrating data.

 

It takes a few seconds to switch system and it retains all the settings which are common.

 

I am not ruling out changing things in the future but I have to be careful not to create potential support problems.

Share this post


Link to post
Share on other sites

Ok Steve, thanks for the reply, perhaps I underestimated the effort envolved, I didn't think was too difficult to achieve.

 

Bye,

Share this post


Link to post
Share on other sites

Hi Guys !

 

I would know if there is a way to update from 1.x or so to 2.7 ?

Do I need to purchase the whole thing again?

 

Thanks !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this