Sign in to follow this  
Akila

NGX on P3D nothing works - Help :(

Recommended Posts

I just installed P3D on a fresh installed computer on Windows 8.1.

I Installed the latest version and Hotfix of P3Dv2 and the NGX for P3D.

I loaded the plane via the P3D menu and Pressed OK.

two things happened:

1. I was never challenged with the Activation Step nor was I asked to enter my S/N.

2 Probably related to the 1st one, all my displays are black and I can not press any button in the cockpit. not in the MCP, overhead panel, pedestal, etc. nothing

is clickable , at 1st I thought it might be DIrectX (looks like it), I ran the DX setup again, but it did not help. I thought maybe it is the "PMDG_HUD_interface.dll" not loaded properly,

but I have no way of telling rather it was loaded into the SIM or not apart from looking if it appears in the DLL.XML which it does..

I uninstalled and reinstalled with a reboot in between, but nothing....

 

I ran out of ideas.

 

 

2mqlvv5.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 

 


1. I was never challenged with the Activation Step nor was I asked to enter my S/N.

 

This usually occurs without SimConnect, as mentioned by Claude. The location it's in is in the main P3D folder. Google will get you a more detailed result (at work so I can't look on my machine).

 

 

 


on Windows 8.1.

 

...could also be caused by this, though. Win 8 causes a whole bunch of unexpected issues if the sim isn't set up properly.

Share this post


Link to post
Share on other sites

Kyle, PMDG product works surprisingly well on Windows 8.1 once you tweak your OS. The major problem I was having was not PMDG but losing my joystic in SIM when I change focus. FSUIPC took care of that. I heard Win 10 doesn't have that problem.

Share this post


Link to post
Share on other sites

couldn't find anywhere in my P3D directory/Sub-directories a SimConnect Installation.

 

I downloaded the SDK and installed it , but I don't see any simconnect.msi or something similar.

any ideas?

google wasn't that helpful. it was for FSX but not for P3D

Share this post


Link to post
Share on other sites

Try looking in your Prepar3d v2\redist\Interface folder, Simconnect Installers will be there.

 

hope this helps

 

Glen H

Share this post


Link to post
Share on other sites

Under my P3D folder as suggested by you I see number of folders which none of them is for P3D, they all state FSX in them.

which one should I pick?

 

E:\Lockheed Martin Prepar3D v2\redist\Interface

\FSX-RTM

\FSX-RTM-JPN

\FSX-SP1

\FSX-SP1-RUS

\FSX-SP2-XPACK

Share this post


Link to post
Share on other sites

Mine only has a simconnect html file, no msi file to run.  I am having the same issue.

Share this post


Link to post
Share on other sites

Mine only has a simconnect html file, no msi file to run.  I am having the same issue.

 

Make sure you're looking in the correct folder.

 

Full names in the forum, too, please.

Share this post


Link to post
Share on other sites

 

 


Full names in the forum? Sorry, what do you mean?
He means your full name just like his. He is Kyle Rodgers. I am Michael Cubine and our names automatically appear when we make a post because we set it up like this - Left click on your user name in the upper right of this page. On the next page left click on Edit my Profile. On the next page left click on Signature and on the next page in the box under Edit Signature enter your full name and left click on Save Changes. Now your name will be on every post you make.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this