Sign in to follow this  
MarkW

No liveries - Steam Install

Recommended Posts

I just completed uninstalling all traces of the 777 and NGX per the sticky and I reinstalled to both Steam and FSX.  The aircraft work perfectly in both sims.  I have also download and installed some liveries using the Operations Center and they show as installed.  When I go to FSX-SE, I only see PMDG liveries (note that I have check the box that says show all variations).  The liveries are in the Aircraft folder and they are in the aircraft.cfg file.  Any ideas as to why they do not show up in the menu ?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Be sure you have PMDG 777 FSX-SE, for example, selected as the product. It's not hard to select the FSX variant instead of FSX-SE.

 

Look at your OperationsCenter.log file in \USER\AppData\Roaming\PMDG\PMDG Operations Center.  It should have the correct directory string for under Finding FSX:SE.

 

If you can't find anything obvious, please open a ticket at the PMDG Product Support portal.

Share this post


Link to post
Share on other sites

I fixed the problem (or more accurately worked around it).  You need to install the liveries in FSX not FSX:SE for them to show up in the list when running Steam, not sure why it works this way but it works.

Share this post


Link to post
Share on other sites

I fixed the problem (or more accurately worked around it).  You need to install the liveries in FSX not FSX:SE for them to show up in the list when running Steam, not sure why it works this way but it works.

That's not the way it should work; otherwise, we'd see hundreds of posts on this problem.

 

Did you look at the OC log file?  You have a problem that you haven't fixed and unless fixed it is going to bite you.

Share this post


Link to post
Share on other sites

I fixed the problem (or more accurately worked around it).  You need to install the liveries in FSX not FSX:SE for them to show up in the list when running Steam, not sure why it works this way but it works.

 

As Dan mentioned, that's not how it's supposed to work. My bet is that you installed FSX, installed Steam, and then you deleted FSX? If so, this likely caused a registry error where things are pointing to the incorrect location, giving you the issues you're seeing.

Share this post


Link to post
Share on other sites

I did not uninstall FSX, I just installed Steam into another directory (not default).

Share this post


Link to post
Share on other sites

I did not uninstall FSX, I just installed Steam into another directory (not default).

That's why I asked you to look in the log file to confirm that the OC knows where FSXSE is installed. It's really easy to do.

 

Regardless, if you're happy with your configuration then happy contrails.

Share this post


Link to post
Share on other sites

That's why I asked you to look in the log file to confirm that the OC knows where FSXSE is installed. It's really easy to do.

 

Regardless, if you're happy with your configuration then happy contrails.

 

It seems correct, here is the first part of the file.

 

===================== PMDG Operations Center v1.14.3 =====================
10:07:28.542   
10:07:28.542   Starting Ops Center
10:07:28.544   
10:07:28.546   Loading Settings
10:07:28.546   Finding FSX
10:07:28.547   Found FSX installation: F:\Flight Simulator X\
10:07:28.549   Finding FSX:SE
10:07:28.550   Found FSX installation: F:\Steam\steamapps\common\FSX\
10:07:28.552   Finding P3D
10:07:28.553   Failed to read registry value: 2
10:07:28.555   Checking if FSX is in Program Files
10:07:28.556   Nope!
10:07:28.558   Checking if FSXSE is in Program Files
10:07:28.560   Nope!
10:07:28.561   Checking if P3D is in Program Files
10:07:28.563   
10:07:28.565   Loading GDI+
10:07:28.565   
10:07:28.568   Command line: 
10:07:28.568   
10:07:28.570   Initializing
10:07:28.570   
10:07:28.571   Displaying Ops Center
10:07:28.571   
10:07:28.575   Window initializing

Share this post


Link to post
Share on other sites

Thanks Mark, that looks good to me too.... now would you mind opening a trouble ticket and explain how you must install liveries to FSX to see them in FSXSE and attach a copy of above's log file. I expect RSR will want to take a look at this since he loves fixing his code in the Operations Center to make it work with the latest changes Dovetail may have made.  Unless you've had FSX:SE for a couple of months or longer, I'd also mention about how long it's been since you downloaded and installed FSX:SE.

 

The support portal is here: http://support.precisionmanuals.com/Main/Default.aspx

On your first visit, you need to create a support account. Support accounts are separate from sales accounts.

 

I appreciate your time in doing this.

Share this post


Link to post
Share on other sites

Thanks Mark, that looks good to me too.... now would you mind opening a trouble ticket and explain how you must install liveries to FSX to see them in FSXSE and attach a copy of above's log file. I expect RSR will want to take a look at this since he loves fixing his code in the Operations Center to make it work with the latest changes Dovetail may have made.  Unless you've had FSX:SE for a couple of months or longer, I'd also mention about how long it's been since you downloaded and installed FSX:SE.

 

The support portal is here: http://support.precisionmanuals.com/Main/Default.aspx

On your first visit, you need to create a support account. Support accounts are separate from sales accounts.

 

I appreciate your time in doing this.

 

Dan, I am not going to enter a ticket because this issue is not caused by the OC but by the way I have referenced aircraft in my FSX install from my Steam cfg.  Finally figured out why I was having problems.

Share this post


Link to post
Share on other sites

 

 


Finally figured out why I was having problems.

 

Do you mean FSX-SE install and fsx-se.cfg?  It's confusing so our convention is to use FSX for boxed version and FSXSE (or -SE or :SE) for Steam version.  Which configuration file did you modify that changed the location of installed aircraft?

Share this post


Link to post
Share on other sites

In the FSX-SE.cfg I have referenced the simobjects from my FSX install using the full path.  This works for most aircraft and ai aircraft but not for PMDG and one other payware developer.

Share this post


Link to post
Share on other sites

For me when i checked the log, this is what i get.

===================== PMDG Operations Center v1.14.3 =====================
02:25:43.898   
02:25:43.898   Starting Ops Center
02:25:43.898   
02:25:43.898   Loading Settings
02:25:43.898       Finding FSX
02:25:43.898           Failed to open registry key: 2
02:25:43.898       Finding FSX:SE
02:25:43.898           Failed to read registry value: 2
02:25:43.898       Finding P3D
02:25:43.898           Failed to read registry value: 2
02:25:43.898   Checking if FSX is in Program Files
02:25:43.898   Checking if FSXSE is in Program Files
02:25:43.898   Checking if P3D is in Program Files
02:25:43.898   
02:25:43.908   Loading GDI+
02:25:43.908   
02:25:43.908   Command line:
02:25:43.908   
02:25:43.908   Initializing
02:25:43.908   
02:25:43.908   Displaying Ops Center
02:25:43.908   
02:25:43.918   Window initializing
02:25:43.918   
02:25:44.018   Loading Settings Module
02:25:44.018   
02:25:44.018   Loading Module from file: c:\program files (x86)\pmdg operations center\Settings.dat
02:25:44.018   Loading Module
02:25:44.018   
02:25:44.018   Settings - Product Module Loading
02:25:44.018   
02:25:44.018   Settings - Checking product version
02:25:44.018   No GUID found!

 

I had my FSX uninstalled. Currently I am using FSX:SE. I am not able to see the livery manager at operations center.

Anyone can help?

Share this post


Link to post
Share on other sites

In the FSX-SE.cfg I have referenced the simobjects from my FSX install using the full path. This works for most aircraft and ai aircraft but not for PMDG and one other payware developer.

 

 

Hi, Mark,

 

If you are trying to save some space by having only one set of textures for each livery, instead of one set in FSX:MS and another set for FSX:SE, it is POSSIBLE that you can use the texture.cfg file to reference the textures in FSX:MS from FSX:SE.  I THINK the following will work.

 

This assumes you have the PMDG 777 itself installed in both versions of FSX, and that all of your actual addon livery textures are in FSX:MS.  It also assumes that you know how to add livery entries manually in the aircraft.cfg file.

 

All you would need in the FSX:SE aircraft folder would be a folder with the name of the livery, and one small texture.cfg file.

 

Here is the full texture.cfg file for a typical addon:

 

-----------------

[fltsim]

fallback.1=..\texture.vc

fallback.2=..\texture.common200LR

fallback.3=..\..\..\..\Scenery\Global\texture

fallback.4=..\..\..\..\texture

 

-----------------

Here is a modified version that adds a line at the top referencing the texture you want in FSX:MS. 

-----------------

[fltsim]

fallback.1=[FULL PATH TO TEXTURE IN FSX:MS]

fallback.2=..\..\PMDG 777-200LR\texture.vc

fallback.3=..\..\PMDG 777-200LR\texture.common200LR

fallback.4=..\..\..\..\Scenery\Global\texture

fallback.5=..\..\..\..\texture

 

I don't think the OC will be able to handle this sort of aliasing, so you will probably have to ignore it as far as liveries in FSX:SE are concerned.  But it should still work fine for installing new liveries in FSX:MS.

 

Mike

 

 

 

 

I had my FSX uninstalled. Currently I am using FSX:SE. I am not able to see the livery manager at operations center.

 

Anyone can help?

 

Hi, Sunny,

 

It looks to me like there is something missing in the Windows registry.  If you compare your log to Mark's log, above, you will see that his shows that the OC found both versions of FSX and yours did not.

 

Did you install the FSX:SE (Steam) version before you uninstalled the FSX:MS (Boxed) version?  If so the OC may be confused because it is looking for the FSX:MS version.  Also, how did you uninstall FSX:MS?  

 

Mike

Share this post


Link to post
Share on other sites

 

 


In the FSX-SE.cfg I have referenced the simobjects from my FSX install using the full path. This works for most aircraft and ai aircraft but not for PMDG and one other payware developer.

 

Hi, Mark,

 

The following works, referencing a texture N701DN in FSX:MS on my C: Drive from a texture folder inside the PMDG 777 folder in SIMOBJECTS/AIRPLANES on my D: Drive.

 

Note that I had to put in "..\..\..." enough to get to the top level of D:, and then add the path to the texture on C:

 

I also copied the thumbnail.jpg from the full texture file in FSX:MS to the "dummy" one in FSX:SE.

 

This aircraft does show up in the OC under FSX:SE, BTW.  But it obviously cannot be installed using the OC.

 

I haven't tested this in flight so I don't know if it will affect performance.

-------------------------

[fltsim]

fallback.1=..\..\..\..\..\..\..\C:\Flight Simulation Programs\Flight Simulator X\SimObjects\Airplanes\PMDG 777-200LR\Texture.N701DN
fallback.2=..\texture.vc
fallback.3=..\texture.common200LR
fallback.4=..\..\..\..\Scenery\Global\texture
fallback.5=..\..\..\..\texture
-------------------------

 

Mike

Share this post


Link to post
Share on other sites

Hi, Mark,

 

If you are trying to save some space by having only one set of textures for each livery, instead of one set in FSX:MS and another set for FSX:SE, it is POSSIBLE that you can use the texture.cfg file to reference the textures in FSX:MS from FSX:SE.  I THINK the following will work.

 

This assumes you have the PMDG 777 itself installed in both versions of FSX, and that all of your actual addon livery textures are in FSX:MS.  It also assumes that you know how to add livery entries manually in the aircraft.cfg file.

 

All you would need in the FSX:SE aircraft folder would be a folder with the name of the livery, and one small texture.cfg file.

 

Here is the full texture.cfg file for a typical addon:

 

-----------------

[fltsim]

fallback.1=..\texture.vc

fallback.2=..\texture.common200LR

fallback.3=..\..\..\..\Scenery\Global\texture

fallback.4=..\..\..\..\texture

 

-----------------

Here is a modified version that adds a line at the top referencing the texture you want in FSX:MS. 

-----------------

[fltsim]

fallback.1=[FULL PATH TO TEXTURE IN FSX:MS]

fallback.2=..\..\PMDG 777-200LR\texture.vc

fallback.3=..\..\PMDG 777-200LR\texture.common200LR

fallback.4=..\..\..\..\Scenery\Global\texture

fallback.5=..\..\..\..\texture

 

I don't think the OC will be able to handle this sort of aliasing, so you will probably have to ignore it as far as liveries in FSX:SE are concerned.  But it should still work fine for installing new liveries in FSX:MS.

 

Mike

 

 

 

Hi, Sunny,

 

It looks to me like there is something missing in the Windows registry.  If you compare your log to Mark's log, above, you will see that his shows that the OC found both versions of FSX and yours did not.

 

Did you install the FSX:SE (Steam) version before you uninstalled the FSX:MS (Boxed) version?  If so the OC may be confused because it is looking for the FSX:MS version.  Also, how did you uninstall FSX:MS?  

 

Mike

Hi Mike,

 

Yes i first installed the FSX:SE after using the FSX:MS for sometime. And when the issue started I decided to uninstalled the FSX:MS version hoping it would solve the problem. I uninstalled using Windows7 under control panel -> Programs and Features.

 

so what is the next action plan?

Many thanks for your prompt reply

 

 

sunny

Share this post


Link to post
Share on other sites

 

 


so what is the next action plan?

Many thanks for your prompt reply

 

Hi, Sunny,

 

It sounds like you uninstalled FSX:MS in the proper manner.

 

One question that occurs to me:  Are you using the most recent version of the 777, which would include an OC that can recognize both versions of FSX?  The most recent version is 1.10.6492.  If the OC isn't showing it, look at the top of the aircraft.cfg file found in FSX/Simobjects/airplanes/pmdg 777-200LR.  It should look like this:

/////////////////////////////////////////////////////////
//
//
//            PMDG 777-200LR
//        
// Current with Build: 1.10.6492
///////////////////////////////////////////////////////
 

If you have the correct version, then read on:

 

I am not an expert on the registry but there are many threads on registry cleaners/fixers on Avsim.  However this is a tricky area and one must be very careful when editing the registry. 

 

Why don't you try starting a new thread in the PMDG General forum with the topic something like "OC not finding FSX in Registry".  You can post your OC Log in your opening post.  The discussion here is kind of buried in a long thread on a somewhat different issue.  Be sure to explain that you first installed  FSX:MS, then FSX:SE, then you uninstalled FSX:MS using Windows uninstaller.

 

Mike

 

PS: One other thought -- this may or may not help you with the current issue.  But eventually you might want to completely uninstall and reinstall FSX:SE, since it will then name certain important folders the same as for FSX:MS.  The PMDG 777 and NGX can deal with the different FSX:SE folder names, but some other addons cannot.

Share this post


Link to post
Share on other sites

Hi, Sunny,

 

It sounds like you uninstalled FSX:MS in the proper manner.

 

One question that occurs to me:  Are you using the most recent version of the 777, which would include an OC that can recognize both versions of FSX?  The most recent version is 1.10.6492.  If the OC isn't showing it, look at the top of the aircraft.cfg file found in FSX/Simobjects/airplanes/pmdg 777-200LR.  It should look like this:

/////////////////////////////////////////////////////////

//

//

//            PMDG 777-200LR

//        

// Current with Build: 1.10.6492

///////////////////////////////////////////////////////

 

If you have the correct version, then read on:

 

I am not an expert on the registry but there are many threads on registry cleaners/fixers on Avsim.  However this is a tricky area and one must be very careful when editing the registry. 

 

Why don't you try starting a new thread in the PMDG General forum with the topic something like "OC not finding FSX in Registry".  You can post your OC Log in your opening post.  The discussion here is kind of buried in a long thread on a somewhat different issue.  Be sure to explain that you first installed  FSX:MS, then FSX:SE, then you uninstalled FSX:MS using Windows uninstaller.

 

Mike

 

PS: One other thought -- this may or may not help you with the current issue.  But eventually you might want to completely uninstall and reinstall FSX:SE, since it will then name certain important folders the same as for FSX:MS.  The PMDG 777 and NGX can deal with the different FSX:SE folder names, but some other addons cannot.

 

Hi Mike

 

Here is the current version which i downloaded from pmdg website. It's the latest if not wrong but the version is different than yours. Maybe because i am using the base package unlike the previous FSX:MS service package SP1d.

 

/////////////////////////////////////////////////////////

//

//

//            PMDG 777-200LR

//        

// Current with Build: 1.10.6320

///////////////////////////////////////////////////////

 

regards

Sunny

Share this post


Link to post
Share on other sites

 

 


Here is the current version which i downloaded from pmdg website. It's the latest if not wrong but the version is different than yours. Maybe because i am using the base package unlike the previous FSX:MS service package SP1d.

 

Hi, Sunny,

 

You definitely have the wrong version installed.  If you purchased the 777 from the PMDG web site, you need to go to PMDG, log onto your account, and download a new, complete installer.  Note that this is not a patch, it is a new, full install.  The file name may look the same, but if you download the full install from your account, you will get a complete install of the newest version.

 

If you have the boxed version of the 777, you need to go to the Aerosoft web site and download the new version through your account there.

 

For reinstallation, take a look at the following threads:

 

http://forum.avsim.net/topic/463861-installing-fsx-and-fsxse-updates/

 

http://forum.avsim.net/topic/471487-install-patch-1d/

 

Mike

Share this post


Link to post
Share on other sites

Hi, Sunny,

 

You definitely have the wrong version installed.  If you purchased the 777 from the PMDG web site, you need to go to PMDG, log onto your account, and download a new, complete installer.  Note that this is not a patch, it is a new, full install.  The file name may look the same, but if you download the full install from your account, you will get a complete install of the newest version.

 

If you have the boxed version of the 777, you need to go to the Aerosoft web site and download the new version through your account there.

 

For reinstallation, take a look at the following threads:

 

http://forum.avsim.net/topic/463861-installing-fsx-and-fsxse-updates/

 

http://forum.avsim.net/topic/471487-install-patch-1d/

 

Mike

Hi Mike,

 

You are right about the version. I went into the pmdg account logged in and re-downloaded the package and this time the version is correct. But unfortunately, it still doesn't solve the issue. I guess worst come to worst, i really do need to uninstall FSX:SE and re-install back again. I also run the registry mechanics from pmdg. That too didn't help.

 

Sunny

Share this post


Link to post
Share on other sites

 

 


You are right about the version. I went into the pmdg account logged in and re-downloaded the package and this time the version is correct. But unfortunately, it still doesn't solve the issue. I guess worst come to worst, i really do need to uninstall FSX:SE and re-install back again. I also run the registry mechanics from pmdg. That too didn't help.

 

Hi, Sunny,

 

Did you completely uninstall the previous version (after running the OC to keep the liveries, if possible)?  If not, try that before going any further.

 

Before you uninstall/reinstall FSX:SE, it would be a good idea to file a ticket with PMDG.

 

Mike

Share this post


Link to post
Share on other sites

Hi, Sunny,

 

Did you completely uninstall the previous version (after running the OC to keep the liveries, if possible)?  If not, try that before going any further.

 

Before you uninstall/reinstall FSX:SE, it would be a good idea to file a ticket with PMDG.

 

Mike

Hi Mike,

 

Yes I did uninstalled the old version completely and even deleted whatever folders regarding pmdg plus cleaned up my registry. I should have saved the liveries from FSX:MS so i can copy manually the files into FSX:SE which i found it worked but then it is not the right way of doing it right.

 

Anyway i have already submitted a ticket to PMDG and pending for their reply. Hope there is a solution..

 

sunny

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this