Sign in to follow this  
kiwiflyer45

Piston (Reciprocating) Engines Won't Run in FSX-SE

Recommended Posts

I started using FSX-SE a week ago and at first it worked flawlessly. But since doing some of the fixes listed in this forum I now have an odd problem. Jets and turboprops work normally but as soon as I try to fly an aircraft with piston engines, it dies instantly and can't be restarted. The"fixes" involved installing the SimConn legacy files, new GoFlight drivers and latest version of FSUIPC. All my hardware (Saitek Pro Yoke and Throttle Quadrant, CH Pro rudder pedals and sundry GoFlight modules) working normally, have checked for "failures" (none), all settings normal. Have tried disconnecting all controls - no change.

 

I have looked pretty thoroughly through the forum posts but couldn't find any reference to this weird problem. Any help would be greatly appreciated

Cheers

Ian

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Sorry, but I don't have FSX-SE.  Are you starting up the piston engines from a cold and dark

 

setting.  Have you tried using about 1/3 throttle at start up to keep the engines running?

 

Piston slappers can be finicky starting and running  at altitudes above sea level.

Share this post


Link to post
Share on other sites

Maybe the mixture control is held fully off even with the control disconnected.

Share this post


Link to post
Share on other sites

Thanks guys but no to both suggestions. I can start a saved flight with either a jet or turboprop running, switch to a piston engine aircraft - it immediately dies - and then select a new aircraft and if it's a jet or turboprop the engine immediately starts running. Same thing if I select a free flight aircraft. It doesn't matter whether engine is running or not - if it's a piston it will immediately stop or if already off, will refuse to start. (It kicks over but no ignition)..

 

Mixture is in full rich position, whether I do it with Saitek throttle or mouse. Fuel is on, everything is normal.

 

I have checked everything that makes sense - nothing has worked. And trust me, I do know how to start an engine - former RW pilot and been FSing since FS95. Happens with saved flights that previously worked fine or with new flights created with default Cessna

Ian

Share this post


Link to post
Share on other sites

Hi Steve

Yes, the fuel is on, or at least it show visually that it's on. Same with mixture - what the sim is showing and what the software is recognizing may be two different things. But then that still leaves the puzzle that as soon as I select a turboprop or jet the engine immediately begins operating normally. In all my years using every version of FS I've never seen anything like this. If it was one particular airplane I would suspect a corrupted file but it's the same with every plane - from R22 to the Goose, C172, Baron etc.

Share this post


Link to post
Share on other sites

It's a strange one...Elimination may be the way forward, try a new standard.xml, try without FSUIPC, and so on.

Share this post


Link to post
Share on other sites

Try removing all your "fixes" etc to get back to a vanilla FSX-SE.

Share this post


Link to post
Share on other sites

Have you tried the default key combo to start engines (CTL + E), rather than doing the start manually? I've run into the problem you describe occasionally in P3D, where pistons will crank but not fire on a manual start, but the auto-start works. Not sure why.

Share this post


Link to post
Share on other sites

Try renaming your fsx.cfg to fsx.cfg.bak and let FSX make a new file, load up the piston plane that is giving you issues and see if it still happens.

 

If it doesn't happen, you know it must be something with your custom default flight file or something in your fsx.cfg (though I don't know what else it could be besides the flight file...).

Share this post


Link to post
Share on other sites

Thanks for all the good suggestions but no result. Tried regenerating a clean fsx.cfg file but it seems you can't do that with SE as it just wouldn't start without it. CTRL-E doesn't work - tried it. Uninstalled legacy SimConnect files - nope. Same with FSUIPC.

I checked all folders and files to see if any had been changed but all relevant files had the original install date and time.

 

The only theory I can come up with is that something in my system is somehow causing the sim to misread the mixture control. That's the only thing I can think of that would effect only reciprocating engines and not jets/turboprops. Although the mixture control is set to rich perhaps it is reading the mixture as in the cut-off setting.

 

Presumably the stuff I installed as described in my original post corrupted a file somewhere and uninstalling the files doesn't touch the corrupted file? Where is Sherlock Holmes when u really need him? :-)

Share this post


Link to post
Share on other sites

Steve - helos follow the same pattern... R22 - engine dies on loading. Merlin works fine

Share this post


Link to post
Share on other sites

Search AXIS_MIXTURE_SET in Standard.XML, should be with values something like scale 127, null 1.

Share this post


Link to post
Share on other sites

Thanks for the suggestion Steve. I checked the standard.XML file and the entries seemed correct as per your post. One other piece of the puzzle that might help someone identify the problem - no piston-engine AI aircraft show up. I have it set to 100% but no default or addon AI aircraft with reciprocating engines appear. This became apparent to me when I installed the ACG Duxford scenery with the full air show pack - all vintage WWII prop aircraft. None appeared.

 

This info may also help. If I start a flight with turbine engine aircraft it runs fine. As soon as I select a piston aircraft (Maule, C172 etc) the engine immediately stops. Switch back to a turbine engine aircraft and the engine instantly begins running normally.

Share this post


Link to post
Share on other sites

Problem solved! I will probably never know what caused it but the new FSX-SE update fixed it!!!! Now I'm going to be even more addicted :rolleyes:

 

Thank you to all who tried to help

Share this post


Link to post
Share on other sites

Was thinking about that, it's an odd one, glad it's sorted out now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this