Sign in to follow this  
Kuragiman

Exporting Liveries with the OPS Center for P3D

Recommended Posts

I paint liveries and have had no issue creating PTP packages in the past under FSX but the new Livery Manager in the new and improved Operations Center is not functioning for me correctly in P3D.   When I right click on my custom painted livery and tell it to export it asks me for the name of the livery I want to create.   I do so and it says that the export is completed.   It creates a completely useless PTP file that has no textures or the custom INI file or anything.    In the old version you could see it working its magic and compressing the livery and prepping it for PTP formatting.    This is not the case now in the the new Ops center with P3D.    Am I going to have to fool the ops center into thinking I have FSX installed or something to get it to find the path to the texture folder in the Simobjects library for the liveries I am painting?    Your insight on this is helpful.  I did not see any info in the new ops center manual regarding the functionality of this.

 

 

EDIT:  I just turned on Flight 1's migration tool and enabled it, making a virtual FSX and the export function is working now.   Are there plans for us non-FSX users to be able to use the Export functionality without the need of fooling the ops center?   We have 737/777 officially licensed now for P3D.  It would be nice if the Ops center could scan for the P3D install folder and simobjects folder if FSX is not found.    Thanks for your response to this inquiry.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

 

 


EDIT:  I just turned on Flight 1's migration tool and enabled it, making a virtual FSX and the export function is working now.   Are there plans for us non-FSX users to be able to use the Export functionality without the need of fooling the ops center?   We have 737/777 officially licensed now for P3D.  It would be nice if the Ops center could scan for the P3D install folder and simobjects folder if FSX is not found.    Thanks for your response to this inquiry.

 

Sounds more like you have a registry error in general. The Ops Center would have to do what you're asking (look for the P3D install location) in order to install liveries into P3D in general, so it's not like we've simply tethered it to FSX. Submit a ticket and we'll send you our registry mechanic to fix your computer's issue.

Share this post


Link to post

Sounds more like you have a registry error in general. The Ops Center would have to do what you're asking (look for the P3D install location) in order to install liveries into P3D in general, so it's not like we've simply tethered it to FSX. Submit a ticket and we'll send you our registry mechanic to fix your computer's issue.

 

Thanks for the response Kyle.  Yeah it seemed weird that it has no problem importing them in or downloading them from the download manager.  It's on the Right-Click/Export function that isn't reaching out to find the livery folder and compress the textures.  I'll send in a ticket today.  Thanks again.

Share this post


Link to post

Thanks for the response Kyle.  Yeah it seemed weird that it has no problem importing them in or downloading them from the download manager.  It's on the Right-Click/Export function that isn't reaching out to find the livery folder and compress the textures.  I'll send in a ticket today.  Thanks again.

 

Please reference ticket number 38B-1C9729B4-0424 in your ticket Brian, as I've had the exact same problem ever since the latest release of the OC.

On my new machine, I have FSX:SE and P3d installed, but never installed the legacy FSX.  I've totally uninstalled all PMDG software, deleted appropriate directories, reinstalled...did not work.

You are probably getting a 1kb PTP file like I am, no data in it at all, right?

I still have the legacy FSX on my old laptop, which works fine to export liveries, so I've been moving all my repaints over to it to package them for upload until they can figure this one out.

 

I've also installed a stand alone version of the OC Ryan sent me the link to, no joy.

Just to make it crazier, it also does it on my new laptop...it has Win 8.1 and my desktop has Win 7-64, so the OS is not the issue.

 

After reading your success by fooling the OC that you have FSX installed may be the key, as I didn't try Flight1's migration tool, and I suspect it not seeing the legacy FSX has something to do with it.

Share this post


Link to post

Please reference ticket number 38B-1C9729B4-0424 in your ticket Brian, as I've had the exact same problem ever since the latest release of the OC.

On my new machine, I have FSX:SE and P3d installed, but never installed the legacy FSX.  I've totally uninstalled all PMDG software, deleted appropriate directories, reinstalled...did not work.

You are probably getting a 1kb PTP file like I am, no data in it at all, right?

I still have the legacy FSX on my old laptop, which works fine to export liveries, so I've been moving all my repaints over to it to package them for upload until they can figure this one out.

 

I've also installed a stand alone version of the OC Ryan sent me the link to, no joy.

Just to make it crazier, it also does it on my new laptop...it has Win 8.1 and my desktop has Win 7-64, so the OS is not the issue.

 

After reading your success by fooling the OC that you have FSX installed may be the key, as I didn't try Flight1's migration tool, and I suspect it not seeing the legacy FSX has something to do with it.

 

In none of that did you reference the registry. That's likely the issue. Did anyone send you the registry mechanic?

Share this post


Link to post

 

 


In none of that did you reference the registry. That's likely the issue. Did anyone send you the registry mechanic?

 

Not yet.  I suspected the registry as well, but usually don't dig in there unless instructed to so.

Share this post


Link to post

Not yet.  I suspected the registry as well, but usually don't dig in there unless instructed to so.

 

Smart - go ahead and submit a ticket referencing the old one (or this thread) to my attention and I'll send you the mechanic. That should take care of it.

Share this post


Link to post

Smart - go ahead and submit a ticket referencing the old one (or this thread) to my attention and I'll send you the mechanic. That should take care of it.

Thanks Kyle, new ticket opened 341-1CEE16B3-0418

Share this post


Link to post

 

 


Please reference ticket number 38B-1C9729B4-0424 in your ticket Brian, as I've had the exact same problem ever since the latest release of the OC.

On my new machine, I have FSX:SE and P3d installed, but never installed the legacy FSX. I've totally uninstalled all PMDG software, deleted appropriate directories, reinstalled...did not work.

You are probably getting a 1kb PTP file like I am, no data in it at all, right?

I still have the legacy FSX on my old laptop, which works fine to export liveries, so I've been moving all my repaints over to it to package them for upload until they can figure this one out.



I've also installed a stand alone version of the OC Ryan sent me the link to, no joy.

Just to make it crazier, it also does it on my new laptop...it has Win 8.1 and my desktop has Win 7-64, so the OS is not the issue.

 

I have got the exact same issue with FSX:SE and the Operations Center. Also FSX:SE as a standalone - no PREPAR3D or FSX installed before - and I am unable to export liveries for 737NGX or the 777X. Process is rather quick, PTP-file has only a few bytes and can't be installed. Same goes for configurations which come with older PTP files, they are not recognized.

 

I have also opened a ticket a few weeks ago. If you want to refer to it here is the number: 182-1CD00AB1-041D .

 

Best regards,

Share this post


Link to post

Hey Kyle,

 

My ticket is still awaiting an agent to view it.   Reference # is:    Ticket: 01E-1CEDE880-040C 

 

Also, people who download my liveries are having trouble installing the ones I packaged in the OPS center with the Migration tool on.   It tells them that this livery is for P3D only...  since when did liveries become platform specific?  Shouldn't they work in either?  Did I miss something in the manual about exporting for P3D vs. FSX?   Thanks for the help!

Share this post


Link to post

Same here, POC doesn't uninstall nor install the configuration files (using P3Dv2.5). The textures itself are in place and are normally added to the aircraft.cfg

Share this post


Link to post

Someone here?

 

Patrick,

 

PMDG responded to my ticket with disheartening but good news.   They are aware of the problem, and it is a problem and are looking for solution for their next patch to fix the issue with the Ops Center packaging up liveries in P3D.   That was the last things I heard.   Waiting patiently.  Until then, just gotta zip it up the old fashioned way and write a manual entry for your users to copy and paste into their aircraft.cfg file.   Sucks but thems the breaks for now.

Share this post


Link to post

So several months have passed since this issue is known and still no fix from PMDG? Kind of a bummer for me since I've been working on some repaints lately and can't get them out tot he public in a .ptp file....

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this