Jump to content

Archived

This topic is now archived and is closed to further replies.

SuperCell

Mogwaisoft Shade CTD (No Backup)

Recommended Posts

Is there any way I can remove shade? Or do I need to do a complete reinstall. Multiple modules are being blamed in event viewer.

 

Faulting application name: prepar3d.exe, version: 2.5.12945.0, time stamp: 0x55145f5e
Faulting module name: ai_player.dll, version: 2.5.12945.0, time stamp: 0x55145f5b
Exception code: 0xc0000005
Fault offset: 0x00045d69
Faulting process id: 0x1518
Faulting application start time: 0x01d0a6c2896d7c8d
Faulting application path: D:\Prepar3D\prepar3d.exe
Faulting module path: D:\Prepar3D\ai_player.dll
Report Id: d91231dc-12b5-11e5-8268-4851b76b2b9f
Faulting package full name: 
Faulting package-relative application ID: 
 
 
and I got an api.dll error i think.

Nick Mathews

CFI

Banner_MJC8.jpg

 

Share this post


Link to post

According to the AVSIM CTD Guide, page 10, the probable cause of the ai_player.dll:

 

AI_Player.dll - The faulting module was the ai_player.dll which is the module that controls your AI (a commercial AI program or the default).

 

• Could be something wrong with an AI model or object. If you have MyTrafficX, you can disable AI in the Scenery Library to see if this fixes the problem. If so, then this is the problem. If you have another AI program installed, then disable that program to see if the program is causing your crashes.

• Problem occurs occasionally in the Seattle area with FTX/Orbx Pacific Northwest. This may have been fixed by now but check the FTX/Orbx forums and search for AI_Player.

• Caused by freeware airports in the area that has static aircraft or their own AI aircraft and flight plans. Disable the add-on airport and see if problem is gone. If you have any FSDT, Flight Beam airports, do not disable them. They are not the problem.

• AI programs like MyTrafficX has AFCAD's for hundreds, maybe thousands of airports in the MyTraffic/Scenery folder. Anyone of these could be the cause of the ai_player crash. In this case, make sure you have the latest version of your AI program installed.

 

An api.dll error indicates you have run out of virtual address space (also on page 10, AVSIM CTD Guide).

 

Best regards,


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post

 

Is there any way I can remove shade? Or do I need to do a complete reinstall. Multiple modules are being blamed in event viewer.

 

Faulting application name: prepar3d.exe, version: 2.5.12945.0, time stamp: 0x55145f5e
Faulting module name: ai_player.dll, version: 2.5.12945.0, time stamp: 0x55145f5b
Exception code: 0xc0000005
Fault offset: 0x00045d69
Faulting process id: 0x1518
Faulting application start time: 0x01d0a6c2896d7c8d
Faulting application path: D:\Prepar3D\prepar3d.exe
Faulting module path: D:\Prepar3D\ai_player.dll
Report Id: d91231dc-12b5-11e5-8268-4851b76b2b9f
Faulting package full name: 
Faulting package-relative application ID: 
 
 
and I got an api.dll error i think.

 

 

Shade is a wonderful add-on IMHO. I had the same problem with P3D v2.5 and managed to inject the shade thing using the option Set And Forget  Current Shade GUI Values under the tab Set And Forget.


Best regards, Luís

 

SYSTEM (build date 2013): Case: Corsair Obsidian 650D  |  Motherboard: Asus Sabertooth Z87  |  CPU: Intel® Core™ i7-4770K Processor @ 4.4 GHz  |  RAM: 16 Gb Kingston HyperX KHX2133C11D3/4GX @ 1867 MHz  |  Optical drives: 2x ASUS BW-12B1ST  |  SSD's: 2x Samsung SSD 840 PRO Series 250 Mb @ RAID 0  |  Cooler: Corsair H80i | PSU: Corsair AX860i | GPU's: 2x Nvidia Geforce GTX 780 (MSI & EVGA) reference cards with tweaked firmware | Microsoft Windows 10 x64 Pro | Prepar3D Academic v3.4.22.19868

 

CONTROLLERS: Saitek Pro Flight™ Multi Panel | Saitek Pro Flight™ Radio Panel | Saitek Pro Flight™ Switch Panel | 1x Saitek Pro Flight™ Instrument Panel | TrackIR 5 with TrackClip Pro | CH Flight Sim Yoke | CH Pro Pedals | CH Throttle Quadrant | Thrustmaster HOTAS Warthog™ | Thrustmaster MFD Cougar Pack                                                                                                                                                                                                                                                                                                                                                                                                     

Share this post


Link to post

Shade is a wonderful add-on IMHO. I had the same problem with P3D v2.5 and managed to inject the shade thing using the option Set And Forget  Current Shade GUI Values under the tab Set And Forget.

Which preset did you use? I've tried a few of them and used set and forget... nothing worked. I did a complete reinstall of everything but shade... so no crashing as of now.


Nick Mathews

CFI

Banner_MJC8.jpg

 

Share this post


Link to post

Which preset did you use? I've tried a few of them and used set and forget... nothing worked. I did a complete reinstall of everything but shade... so no crashing as of now.

 

I use Desert Tints if I am not mistaken in the name. Delete your shader cache then  do the Set And Forget "thing" and you will have shade effects. If you own REX and mess with textures you could loose the shade effect. Then you will need to delete cache once again and run Shade with the Set And Forget option to repeat the process.

 

Regards,

AK


Best regards, Luís

 

SYSTEM (build date 2013): Case: Corsair Obsidian 650D  |  Motherboard: Asus Sabertooth Z87  |  CPU: Intel® Core™ i7-4770K Processor @ 4.4 GHz  |  RAM: 16 Gb Kingston HyperX KHX2133C11D3/4GX @ 1867 MHz  |  Optical drives: 2x ASUS BW-12B1ST  |  SSD's: 2x Samsung SSD 840 PRO Series 250 Mb @ RAID 0  |  Cooler: Corsair H80i | PSU: Corsair AX860i | GPU's: 2x Nvidia Geforce GTX 780 (MSI & EVGA) reference cards with tweaked firmware | Microsoft Windows 10 x64 Pro | Prepar3D Academic v3.4.22.19868

 

CONTROLLERS: Saitek Pro Flight™ Multi Panel | Saitek Pro Flight™ Radio Panel | Saitek Pro Flight™ Switch Panel | 1x Saitek Pro Flight™ Instrument Panel | TrackIR 5 with TrackClip Pro | CH Flight Sim Yoke | CH Pro Pedals | CH Throttle Quadrant | Thrustmaster HOTAS Warthog™ | Thrustmaster MFD Cougar Pack                                                                                                                                                                                                                                                                                                                                                                                                     

Share this post


Link to post

Which preset did you use? I've tried a few of them and used set and forget... nothing worked. I did a complete reinstall of everything but shade... so no crashing as of now.

 

Did you use migration tool ? if not that would probably help you - I used emt and never had a problem with Shade


Rich Sennett

               

Share this post


Link to post

Did you use migration tool ? if not that would probably help you - I used emt and never had a problem with Shade

 

It's mandatory to use EMT or similar method otherwise the program won't launch in the first place... On the other hand he can have FSX installed... and Shade is injecting the effects in FSX. Shade doesn't recognize P3D.

 

PS @ Rich Sennett: Are you able to use Shade with P3D v2.5 without the Set And Forget feature with no CTD’s?


Best regards, Luís

 

SYSTEM (build date 2013): Case: Corsair Obsidian 650D  |  Motherboard: Asus Sabertooth Z87  |  CPU: Intel® Core™ i7-4770K Processor @ 4.4 GHz  |  RAM: 16 Gb Kingston HyperX KHX2133C11D3/4GX @ 1867 MHz  |  Optical drives: 2x ASUS BW-12B1ST  |  SSD's: 2x Samsung SSD 840 PRO Series 250 Mb @ RAID 0  |  Cooler: Corsair H80i | PSU: Corsair AX860i | GPU's: 2x Nvidia Geforce GTX 780 (MSI & EVGA) reference cards with tweaked firmware | Microsoft Windows 10 x64 Pro | Prepar3D Academic v3.4.22.19868

 

CONTROLLERS: Saitek Pro Flight™ Multi Panel | Saitek Pro Flight™ Radio Panel | Saitek Pro Flight™ Switch Panel | 1x Saitek Pro Flight™ Instrument Panel | TrackIR 5 with TrackClip Pro | CH Flight Sim Yoke | CH Pro Pedals | CH Throttle Quadrant | Thrustmaster HOTAS Warthog™ | Thrustmaster MFD Cougar Pack                                                                                                                                                                                                                                                                                                                                                                                                     

Share this post


Link to post

It's mandatory to use EMT or similar method otherwise the program won't launch in the first place... On the other hand he can have FSX installed... and Shade is injecting the effects in FSX. Shade doesn't recognize P3D.

 

PS @ Rich Sennett: Are you able to use Shade with P3D v2.5 without the Set And Forget feature with no CTD’s?

 

I dont have it loaded in 2.5 - i used it in 2.4 also i always used set and forget and it always worked so not sure


Rich Sennett

               

Share this post


Link to post

PS @ Rich Sennett: Are you able to use Shade with P3D v2.5 without the Set And Forget feature with no CTD’s?

 

I have Shade working in 2.5.  I am also using the set/forget method and I have not had any issues.  I use the EMT when running the Shade application.  I think messing with REX as mentioned in another post can mess it up as I have noticed that the Shade effect sometimes disappears during a flight if I don't run Shade again after messing with REX textures (I assume the sky textures will change things).  I use the 'Dark-Default' setting and find P3D looks stunning (no HDR).  It really gives the VC a darker tone which contrasts much better with the brighter outside.....which is much more realistic.


Eric

P3D v5 & MSFS   i7-6700k @ 4.4 GHz, Nvidia GTX 1080ti, 32GB ddr4 RAM, 1TB EVO 850 SSD, Samsung CRG90 49", Win 10

Share this post


Link to post

Yes I use EMT. If it ctds its all your fault ;P. I use hdr. I like marks final the best.

 

edit. it works thanks. 


Nick Mathews

CFI

Banner_MJC8.jpg

 

Share this post


Link to post
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    34%
    $8,560.00 of $25,000.00 Donate Now
×
×
  • Create New...