Jump to content

Archived

This topic is now archived and is closed to further replies.

Murmur

Much improved fog easily attainable, but...

Recommended Posts

You are right , the same here.

 

That's because the lights aren't really casting light on the fog ; it's a bigger topic I think , that street lights can light the atmosphere in real life.

When watching a city from far away , you can see an orange "glow" above it.

 

Yes, but the strange thing is that not only lights halos, but also the gradual loss of contrast due to fog seems to disappear at night. That should not happen.


"The problem with quotes on the Internet is that it is hard to verify their authenticity." [Abraham Lincoln]

Share this post


Link to post
Share on other sites

I am @WSSS with FSRealWX the ground is full of fog and I am using the script. Not that I understand all this


Zulfiqar  Location : VABB - Boombay - India

Powered By : X-plane  / il2 / DCS

Taking Flight where no one does

Share this post


Link to post
Share on other sites

How exactly do you use the lua posted by mtaxp?

 

 

Copy the script to a new text file in Notepad and save, goto command prompt rename xxx.txt to xxx.lua like move xxx.txt xxx.lua and move the lua file to /Resources/Plugins/FlywithLua/Scripts folder.

 

Or better download the LUA IDE as this will allow you to save it directly as a .lua

I have noticed an issue and not sure what is causing it, it could be the fog script here it is :

 

737_2.png

Yes it is due to the script


Zulfiqar  Location : VABB - Boombay - India

Powered By : X-plane  / il2 / DCS

Taking Flight where no one does

Share this post


Link to post
Share on other sites

That's strange.

One of the checks I made is when visibility is higher than 16098 meters , all the values will be back on default.

Ypur picture shows much higher visbility than this , so it shouldn't happen.

Share this post


Link to post
Share on other sites

That's strange.

One of the checks I made is when visibility is higher than 16098 meters , all the values will be back on default.

Ypur picture shows much higher visbility than this , so it shouldn't happen.

 

I have a few Lua scripts in FlywithLua all copied from the net. One of them is the Atmosphere Scatter Hmmm I think it is your script. Do you want me to post that script here ?


Zulfiqar  Location : VABB - Boombay - India

Powered By : X-plane  / il2 / DCS

Taking Flight where no one does

Share this post


Link to post
Share on other sites

Copy the script to a new text file in Notepad and save, goto command prompt rename xxx.txt to xxx.lua like move xxx.txt xxx.lua and move the lua file to /Resources/Plugins/FlywithLua/Scripts folder.

 

Or better download the LUA IDE as this will allow you to save it directly as a .lua

I have noticed an issue and not sure what is causing it, it could be the fog script here it is :

 

737_2.png

Yes it is due to the script

I also have RTH installed. Should I remove that first before installing this new lua?


Baber

 

My Youtube Channel http://www.youtube.com/user/HDOnlive

Share this post


Link to post
Share on other sites

I also have RTH installed. Should I remove that first before installing this new lua?

 

I don't think you need to remove RTH.


Zulfiqar  Location : VABB - Boombay - India

Powered By : X-plane  / il2 / DCS

Taking Flight where no one does

Share this post


Link to post
Share on other sites

It is the Atmosphere Scatter script which was the issue, after removing it :

 

Changi airport with FSRrealWX

 

 

dr400_1.png


Zulfiqar  Location : VABB - Boombay - India

Powered By : X-plane  / il2 / DCS

Taking Flight where no one does

Share this post


Link to post
Share on other sites

This new atmospheric effect is really nice and it should be present there at all times. Without this X-Plane's atmosphere looks way too clean and dead. After increasing visibility the effect stays for like 2 or 3 seconds and then goes away. Can someone look into that?


Baber

 

My Youtube Channel http://www.youtube.com/user/HDOnlive

Share this post


Link to post
Share on other sites

Works and looking real nice, but also had to remove RTH. With the RTH lua-scripts it just said "Lua stopped" in red letters when entering the sim.


Phanteks Eclipse P500A D-RGB || Ryzen 9 5900X || G.Skill TridentZ RGB 32GB@3600CL16(b-die) || Asus ROG Strix Gaming-E X570
Asus Geforce RTX 3080 TUF Gaming  || Corsair iCUE H115i RGB PRO XT LCS || XPG SX8200 Pro 2TB M.2 NVMe || Phanteks Revolt Pro 1000W
Samsung 32" Odyssey G7 1440p@240hz || X55 Rhino || G27 || TrackIR5 || Oculus Quest 2

 

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    39%
    $9,930.00 of $25,000.00 Donate Now
×
×
  • Create New...