Sign in to follow this  
Capt. PERO

SIMstarter Version 2.7 - out now!

Recommended Posts

It took a long while to release that new version. There was a beautiful summer, new job and so on. But the time has come to present v2.7 of SIMstarter. I did a lot of improvements especially to the SceneryManager. But find it out yourself:

[FEATURE] P3Dv3 – Compatible with P3Dv2.4, 2.5 and 3.0
[FEATURE] SceneryManager – New SceneryManager with a lot of improvements
[FEATURE] SceneryManager – Overview of all ScenerySets
[FEATURE] SceneryManager – Groups (Spacers) available to easy activate or deactivate a group of Sceneries
[FEATURE] SceneryManager – Add, Delete and edit Sceneries from Scenery.cfg
[FEATURE] SceneryManager – Change Scenery order (with more than one selected Scenery)
[FEATURE] SceneryManager – Insert Scenery at the selected cursor position
[FEATURE] SceneryManager – Drag and Drop Scenery folders from outside (to easy add them)
[FEATURE] ORBX Settings Tab – Auto select ORBX Region without using FTX Central 2 (THANKS to Michael!)
[FEATURE] StartManager – Programs can be set to pause to allow waiting for 3rd party programs
[CHANGED] Settings – FTXcentral Reminder removed. Can be handled in ORBX Tab of each profile
[CHANGED] Startup – ORBX Region switch will be done after scenery.cfg handling
[bUGFIX] Jumpstart – Misplacing of southern latitude locations (THANKS to Ken!)
[bUGFIX] Profiles – Realism > Autorudder to AutoTRIM renamed (THANKS to Rainer!)

>> DOWNLOAD <<

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hey Pero,

 

When I open the scenery manager, either edit something or not, then close it, Simstarter disappears, but still running in the background, have to end task then re-open it.  Has anyone else run into this?

 

If I open the scenery manager from the tools menu it works fine.  Only if I open it from a newly created profile, from the ScenerySet Tab.

Not a big deal.  I'm using Win 8.1 x64, if that makes any difference.

 

Also, DLL.xml and Exe.xml show no entries.

Share this post


Link to post
Share on other sites

Hey Pero,

 

When I open the scenery manager, either edit something or not, then close it, Simstarter disappears, but still running in the background, have to end task then re-open it.  Has anyone else run into this?

 

If I open the scenery manager from the tools menu it works fine.  Only if I open it from a newly created profile, from the ScenerySet Tab.

Not a big deal.  I'm using Win 8.1 x64, if that makes any difference.

 

I've got the same problem on Win 7 x64.

BTW: Thank you very much for that great tool, Pero!

Share this post


Link to post
Share on other sites

Thank you all for your great feedback!!!

 

[...] When I open the scenery manager, either edit something or not, then close it, Simstarter disappears, but still running in the background, have to end task then re-open it.  [...]


Confirmed and fixed! :-)
 

[...]
Also, DLL.xml and Exe.xml show no entries.


That is strange. Just tested at my rig. It worked fine.
Can you please check your folder

C:\ProgramData\Lockheed Martin\Prepar3D v3

are they exe.xml and dll.xml? Are they empty?

I will share the new build tomorrow and wait for other possible bugs.

Share this post


Link to post
Share on other sites

Thank you all for your great feedback!!!

 

Confirmed and fixed! :-)

 

That is strange. Just tested at my rig. It worked fine.

Can you please check your folder

 

C:\ProgramData\Lockheed Martin\Prepar3D v3

 

are they exe.xml and dll.xml? Are they empty?

 

I will share the new build tomorrow and wait for other possible bugs.

 

i have those files in two different locations:  C:\ProgramData\Lockheed Martin\Prepar3D v3    &   C:\Users\username\AppData\Roaming\Lockheed Martin\Prepar3D v3

 

All my addons are in the .xml's in %appdata% folder, and not in the %programdata%

 

does this help?

 

thanks for looking into these Pero !

Share this post


Link to post
Share on other sites

Thank you all for your great feedback!!!

 

Confirmed and fixed! :-)

 

What do you mean with fixed? I just downloaded SIMStarter and the issue with the disappearing SIMStarter still exists. Minor issue though, I love the new scenery manager!

Share this post


Link to post
Share on other sites

What do you mean with fixed? I just downloaded SIMStarter and the issue with the disappearing SIMStarter still exists. Minor issue though, I love the new scenery manager!

 

It will be fixed with the new build deliverd today. It will be v2.7.01. :O)

I just wait until other bug reports...

...but looks pretty safe!

i have those files in two different locations:  C:\ProgramData\Lockheed Martin\Prepar3D v3    &   C:\Users\username\AppData\Roaming\Lockheed Martin\Prepar3D v3

 

All my addons are in the .xml's in %appdata% folder, and not in the %programdata%

 

does this help?

 

thanks for looking into these Pero !

 

Ooops, that looks like you are using incompatible Addons without any kind of "migration tool".

The new location of PREPAR3D dll.xml and exe.xml is 

 

C:\ProgramData\Lockheed Martin\Prepar3D v3

 

old and wrong location is:

 

C:\Users\username\AppData\Roaming\Lockheed Martin\Prepar3D v3

 

try to enter the entries into the right .XML files.

 

Should work then. Can you please verify?

  • Upvote 1

Share this post


Link to post
Share on other sites

i just checked, it is confirmed!

it has been moved to C:\ProgramData\Lockheed Martin\Prepar3D v3\

in v3 xml.dll seems to be a global config file now; as appose to user specific,

Share this post


Link to post
Share on other sites

 

It will be fixed with the new build deliverd today. It will be v2.7.01. :o)

I just wait until other bug reports...

...but looks pretty safe!

 

Ooops, that looks like you are using incompatible Addons without any kind of "migration tool".

The new location of PREPAR3D dll.xml and exe.xml is 

 

C:\ProgramData\Lockheed Martin\Prepar3D v3

 

old and wrong location is:

 

C:\Users\username\AppData\Roaming\Lockheed Martin\Prepar3D v3

 

try to enter the entries into the right .XML files.

 

Should work then. Can you please verify?

 

 

Hey Pero,

 

Thanks for looking into these so quickly.  I'm surprised, I have the new Migration Tool, but everything is still editing the xml's in the old location, but seems to work? It's strange, but I will copy over the xml's to the new location.

Share this post


Link to post
Share on other sites

With FTX Central 2, the dialog can be immediately started for a specific simulator (FSX, P3Dv2, P3Dv3, etc) by using the /sim command-line parameter.

 

On the ORBX tab of the Profile Settings, when "Use SIMStarter for ORBX settings" is enabled and the selected region is set to "Use 'FTX Central 2' dialog":  When SIMStarter starts the FTX Central 2 dialog, the /sim parameter is apparently not passed to specify the simulator version.  So FTX Central displays the "Select a simulator..." dialog.

 

Can this be fixed such that SIMStarter will automatically start the FTX Central 2 dialog for the currently enabled simulator?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this