Sign in to follow this  
arnava1304

PMDG Products cause P3D V3 and 2.5 to fail.

Recommended Posts

Hi,

 

I recently installed v3 but after trying a side by side install of pmdg 738/739/736/737/772/773, neither p3d 2.5 nor p3d v3 work. I followed all install instructions. The sim just partially loads the aircraft and closes, no error. Eventvwr has the following:

 

<code>

Fault bucket 128924842659, type 5

Event Name: AppHangB1

Response: Not available

Cab Id: 0

 

Problem signature:

P1: Prepar3D.exe

P2: 3.0.10.14945

P3: 560b4abe

P4: 6c02

P5: 67246336

P6:

P7:

P8:

P9:

P10:

 

Attached files:

 

These files may be available here:

C:\ProgramData\Microsoft\Windows\WER\ReportArchive\Critical_Prepar3D.exe_9c5e911e42754b78c2a26f99b16fcdef92684c18_eafecabe_21b0c0a8

 

Analysis symbol:

Rechecking for solution: 0

Report ID: 4741eacb-74e5-11e5-830c-74d435e46466

Report Status: 0

Hashed bucket: e97123b23051e3be987a073bde400459

 

</code>

<code>

 

The program Prepar3D.exe version 3.0.10.14945 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.

Process ID: 37f4

Start Time: 01d108f100b43f0b

Termination Time: 4294967295

Application Path: E:\Lockheed Martin\Prepar3D v3\Prepar3D.exe

Report Id: 4741eacb-74e5-11e5-830c-74d435e46466

Faulting package full name:

Faulting package-relative application ID:

 

</code>

 

Fsuipc log says:

 

<code>

 

590610 E:\Lockheed Martin\Prepar3D v3\SimObjects\Airplanes\PMDG 737-800NGX WL\B737-800WL.air

597235 Aircraft="Boeing 737-800NGX Thomson Airlines (TUI) Winglets"

600438 Hook Error: can't find .1467084248 in SIM1.dll

600438 Hook Error: can't find .1467084248 in VISUALFX.dll

 

</code>

 

I've spent four hours on this, one thing I haven't tried and don't want to either is uninstalling p3d 2.5.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I am not sure of what you mean by side by side installation.  If you have installed the PMDG product in both P3Dv2.5 and v3 then that is not supported.

 

Most people do not have a problem with both versions of P3D installed, as long as you install PMDG to only one of them.

Share this post


Link to post
Share on other sites

I've only installed it into p3d3 though, not 2.5.

I tried uninstalling and running it only in p3d 2.5, but no luck.

Share this post


Link to post
Share on other sites

The PMDG installers will only install to v3 if you have both versions installed. I am not sure how you tried running "it" in v2.5, assuming "it" is one of the PMDG products you listed.

 

I'm can't be of much help because I do not understand your problem. I keep on reading from you that your are trying to use PMDG in both versions and I keep on saying you can't do that.....so that's where we are.

Share this post


Link to post
Share on other sites

1. It was working fine in P3D 2.5.

2. I uninstalled the products from 2.5 and into 3, resulting in the error above.

3. I uninstalled it from v3 and changed the v3 directory names to trick the installer into installing it into p3d 2.5, resulting in the following when loading the sim:

 

FSUIPC log:

334109 Hook Error: can't find .1427701400 in SIM1.dll
334109 Hook Error: can't find .1427701400 in VISUALFX.dll

I running on windows 10 64bit.

 

Now neither p3d v3 nor p3d v2 will run pmdg products.

 

After this, I went back to v3 again, but with no luck.

Share this post


Link to post
Share on other sites

Arnav, perhaps your best route is through the PMDG Product Support trouble ticket. Your original problem was an appHang that is often a result of a program in a permanent state of waiting for something but now the problem is complicated by your attempt to fool the installer.

Share this post


Link to post
Share on other sites

Arnav,

 

When you wind up using registry "tricks" in order to install, or change the installer behavior, you more-or-less imediately make it impossible for us to offer you much meaningful support.

 

Our P3D products do not currently support a side-by-side installation, which is why we did not offer it.

 

We are working to offer this, but I do not have a timeline for rolling it out, as it is more complex than simply writing a few lines of code for the installation process.

 

Given that we will likely be unable to tell what you have done to your installation, you may need to consider clean-sheeting the install and allowing the processes to work as designed.  This is always the best method, no matter what you read in the various internet groups specializing in "hacking" a fix for things the developers never envisioned.

 

Also:  You show an FSUIPC error above.  Our products do not use FSUIPC, and in fact we recommend you do not use FSUIPC with our products.  This is advice that remains unchanged since 2007.

  • Upvote 1

Share this post


Link to post
Share on other sites

Words of wisdom, from Mr. Randazzo himself.

 

-Jim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this