Sign in to follow this  
bloxboy

Can't load World2XPlane Europe, please help

Recommended Posts

Hi, I am just getting into X-plane, had been using FSX. Anyway I have been trying to improve the default scenery so I download "W2XP_ Europe" scenery from Simheaven, installed it in my "Custom Scenery" folder, installed all the various libraries (R2,FF,world models,openscenery X), made sure W2XP_Europe was in the right order, just below the Airports, in the scenery ini file. Before installing W2XP__Europe, XP would take about 30-45 SECONDS to fully load, with W2XP_Europe, the loading screen in XP gets to saying "Loading New Scenery Files", and that's where it stays, I have left it loading like this for 40 MINUETES and although the hard disk light is flashing, it stll never fully loads, so I have to take out W2XP_Europe, and XP loads normally. Am I doing something wrong ?. BTW, using XP10.42 steam edition.

 

Thanks,

 

John.  

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Well, W2XP needs more RAM and VRAM. What says your Log.txt when you tried to load W"XP. And do you have installed the needed world models database?

Share this post


Link to post
Share on other sites

Hi, I have 16GB of DDR 4 system ram and 4GB of video ram (GTX980). I also have the latest world models installed. I will check my log file and post it here.

 

Thanks for the reply.

 

John.

Share this post


Link to post
Share on other sites

I had W2XP causing x-plane to crash at startup, after I replaced the world models from the simheaven site by the latest.
I have now 3 different world models directories in Custom Scenery, the one from simheaven, v7.4 that came with world2xplane and v7.6 that is needed for Denmark pro and the crashes stopped, so there are some differences. 

Share this post


Link to post
Share on other sites

I think the world-models folder which Simheaven uses have modified LODs and textures, and is not the same as you'll get with W2XP. However, if you just grab the latest world-models from github https://github.com/tonywob/world-models/archive/master.zip, and then remove the other versions, then you'll always have the latest version. The world-models from github has lower LODs and smaller textures than the simheaven one, and it should also work happily with all the Pro sceneries and Simheaven's Europe scenery.

 

As for X-Plane taking forever to load, I guess the problem is the sheer huge amount of custom 3D buildings in Germany. Every time somebody has chosen a colour for a roof or wall, W2XP has made a custom building to match, this never used to be a problem because they were limited to some city centre buildings, but since the data has grown so much over the past 2 years (There are entire towns or villages mapped like this) it is now a problem. 

 

That being said, even on my laptop which has 16GB of RAM and only a 2GB Nvidia card, I can still use the European scenery without huge loading times.

Share this post


Link to post
Share on other sites

Hi Tony, Thanks for the reply. I downloaded the World-Models from your web site (World-Models-Master) and replaced it with the one from Simheaven. I also replaced the W2XP_Europe with the smaller file W2XP_Europe_1_West, hoping that would load quicker, but still the same result still only gets to "Loading New Scenery Files" even after 20 minutes. I could post my log file but not sure how on this site.

I would be grateful for any more help.

 

Thanks,

 

John.

Share this post


Link to post
Share on other sites

Which airport are you trying to start up at? Also, please do post your log file as well (You can just copy & paste the text from it into this window)

Share this post


Link to post
Share on other sites

Hi Tony, I start up at EGBB which loads fully (as all other airports) without the Europe scenery installed. With Europe installed as I said before it only gets as far as "Reading New Scenery Files". When I click the X to close XP it says "X-Plane not responding", and I have to click on a box to close the program. I have tried to paste my log file here but when I right click and bring up the menu, the paste option in greyed out, so this window will not let me paste anything in it, don't know why. Any other options ?.

 

Thanks,

 

John.

Share this post


Link to post
Share on other sites

John, if you have something like dropbox (Which is free for under 2GB I think), you can just share the file that way, althought I suspect the log file won't actually tell us much.

 

However, I'm surprised this is happening at EGBB. I have GB Pro installed here instead of the European scenery, and it loads in under 2 minutes. GB Pro is far more detailed than the Simheaven scenery, which leads me to believe it's some sort of nasty bug in the area causing XP to hang.

 

Can you try downloading GB Pro from http://world2xplane.com/scenery, temporarily disabling the European scenery, and seeing if it will load then? You have a better system than me, and I have no problem loading GB Pro up with half of the video memory you have.

 

Also, if anyone else is reading this thread and has Simheaven's Europe installed, could you please try loading EGBB and let me know if it works and how long it took?

Share this post


Link to post
Share on other sites

 

 

Also, if anyone else is reading this thread and has Simheaven's Europe installed, could you please try loading EGBB and let me know if it works and how long it took?

Hi Tony,

 

I made a video last year that featured Birmingham and Simheaven textures. Loading times were normal, maybe 3 to 4 minutes. So it works fine. I guess I should be looking at GB Pro, if it's better than the Simheaven stuff it must be amazing.

 

Share this post


Link to post
Share on other sites

Thanks Michel

 

Birmingham is actually quite detailed inside OpenStreetMap. GB Pro is more detailed and covers the entire country, but this area is one huge urban sprawl so performance may vary. If you do any sort of low-level flying in the UK, then I highly recommend you grab GB Pro which works great with photoscenery and is more accurate.

 

I have seen similar issues with hanging before, and it's very very hard to find. One of the issues was in Munich and a road which was cut out in the data and caused an infinite road (crashing X-Plane). I've since put in checks for it, but it's difficult to find these issues unless I can also reproduce the problem.

Share this post


Link to post
Share on other sites

Hi Tony, I do apologise I should have mentioned in my first post that I had installed "GB PRO" and runs and loads fine. The problems was with the Europe sceneries. However I have been trying the north America scenery, starting with W2XP_US_West which loaded fully, so Installed the other US sceneries, North South etc, which all loaded fully with no problems. I then tried some Europe sceneries and so far have installed W2XP_Europe_2, Europe_3, Europe_4, and although the loading time is around 5 minutes before XP is fully loaded, I don't mind waiting knowing that they do now run. Still not sure why Europe_1 doesn't seem to load, but as you say GB PRO covers nearly all of that.

 

I want to thank you for all your help and suggestions, it was very much appreciated, and I will be donating to W2XP.

 

John. 


Hi Michael, Just watched your "Welcome to Birmingham" video which was amazing. BTW did you use any AI traffic, and do you know if there is a version of EGBB without the cross runway, which is now taxiway (Tango & Lima).

 

Cheers,

 

John.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this