Sign in to follow this  
Michael Moe

Photoreal textures always blurry

Recommended Posts

Hi,

 

Normally i do not have any issues regarding LOD crisp textures but as soon as scenerys uses photoreal i always see only blurry textures even with LOD 6.5 . That not the case elsewhere.

 

Is there something i can try out ? 

 

For instance at KJAC

 

Thanks

 

Michael Moe

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You could try this from the P3D SDK Tuning Guide

 

[DISPLAY]

TextureMaxLoad=6

Non-Default entry. This entry will not exist in your Prepar3D.cfg file by default and must be added to the file.

Performance Tuning Tip:

This can induce stutters. Use multiples of 3 only such as 3, 6, 9, etc. This is perfect for photorealistic scenery

 

Don't know if it will help or not.

Share this post


Link to post
Share on other sites

Some things to try...

Set TBM if you use less autogen with photoscenery:

[Display]
TEXTURE_BANDWIDTH_MULT=180 (Smoother texture handling with medium+ autogen.)
TEXTURE_BANDWIDTH_MULT=10 (Smoother frame rate with very low or no autogen.)


Increase the time for background processing:
[main]
FIBER_FRAME_TIME_FRACTION=0.40 - 0.50


Turn on HT and allocate four logical processors to the sim:
[JOBSCHEDULER]
AffinityMask=85 (example for 4 core HT=On)

Share this post


Link to post
Share on other sites

Some things to try...

Set TBM if you use less autogen with photoscenery:

[Display]

TEXTURE_BANDWIDTH_MULT=180 (Smoother texture handling with medium+ autogen.)

TEXTURE_BANDWIDTH_MULT=10 (Smoother frame rate with very low or no autogen.)

Increase the time for background processing:

[main]

FIBER_FRAME_TIME_FRACTION=0.40 - 0.50

Turn on HT and allocate four logical processors to the sim:

[JOBSCHEDULER]

AffinityMask=85 (example for 4 core HT=On)

Steve, shouldn't SWAP_WAIT_TIMEOUT come into the equation, say reducing it from the default 30 to say 10, I run it at 6 in p3d with your recommendation AM =116. (That's for my processor of course)

 

bob

Share this post


Link to post
Share on other sites

Hi,

 

Normally i do not have any issues regarding LOD crisp textures but as soon as scenerys uses photoreal i always see only blurry textures even with LOD 6.5 . That not the case elsewhere.

 

Is there something i can try out ? 

 

For instance at KJAC

 

Thanks

 

Michael Moe

KJAC in P3d will not give you the same clarity as we got in FSX in regards to the textures, this has been discussed over at Orbx by Jarrad, if its any consolation i do not get blurries at KJAC and i have no tweaks at all.

 

2015-11-11_15-27-20-685.jpg

Share this post


Link to post
Share on other sites

KJAC in P3d will not give you the same clarity as we got in FSX in regards to the textures, this has been discussed over at Orbx by Jarrad, if its any consolation i do not get blurries at KJAC and i have no tweaks at all.

 

 

 

 

 

Thanks. will look for that thread. I have winter and snow all over the Mountains.Are you at summer season?

 

Thanks Michael Moe

Share this post


Link to post
Share on other sites

Steve, shouldn't SWAP_WAIT_TIMEOUT come into the equation, say reducing it from the default 30 to say 10, I run it at 6 in p3d with your recommendation AM =116. (That's for my processor of course)

 

bob

Yes, although you can get away with just lowering TBM if you're reducing autogen a lot. There's more in the P3D tuning guide but it's a bit vague:

 

P3D v2/3 tuning guide

 

 

Another thing you can do is set Tessellation. Tessellation set low in the Display Settings is 60, but can be set around 50-20 for better performance, even 20 should be better than no Tessellation at all.

[GRAPHICS]

TESSELLATION=1

[TERRAIN]

TESSELLATION_FACTOR=25 (50% or below for performance, above for quality.)

 

(Remember that this is set back to default if the display settings are made in the sim(.

Share this post


Link to post
Share on other sites

Hi.

 

I tried with HT on and AM=85 but saw no improvement to textures. Also texturemaxload=30 and bandmulti to 180.

 

HT is going to be on for a while because it was rather smooth today. Could be placebo so time will tell.

 

oh and i did set tesselation to low. What does i miss with this?

 

Thanks Michael Moe

 

Prepar3D 3.1

Share this post


Link to post
Share on other sites

I tried with HT on and AM=85 but saw no improvement to textures.

Maybe not this time, but it still pays to have prerequisites set up properly. You should get a bit better background performance with HT On, as much as 3-5% at least.

 

did you try:

 

"Increase the time for background processing:

[main]

FIBER_FRAME_TIME_FRACTION=0.40 - 0.50"

Share this post


Link to post
Share on other sites

Maybe not this time, but it still pays to have prerequisites set up properly. You should get a bit better background performance with HT On, as much as 3-5% at least.

 

did you try:

 

"Increase the time for background processing:

[main]

FIBER_FRAME_TIME_FRACTION=0.40 - 0.5

 

 

Hi Steve

 

Thanks tried it but no luck . Guess i just have to live with it. Might be my i7-4770K@4,6 thats just asking for more power. Maybe a none complex aircraft instead of the Dash8 will help ?

 

I noticed that i have to be really close to the mountains before the blurry starts to go away but it is always the top of the mountains that stays blurry

 

Thanks for helping me out here

 

Michael Moe 

Share this post


Link to post
Share on other sites

You should be able to get good results with that. Try dragging a few sliders to the left, see if you can find anything that makes a difference to the speed the textures sharpen up. Also can try setting the fps limit in NI to 30fps and Vsync+Triplebuffer on in display settings

Share this post


Link to post
Share on other sites

You should be able to get good results with that. Try dragging a few sliders to the left, see if you can find anything that makes a difference to the speed the textures sharpen up. Also can try setting the fps limit in NI to 30fps and Vsync+Triplebuffer on in display settings

Thanks i will try that also. Photoreal is a whole different ballgame. Lots of changes.

 

 

Setting NI@30fps instead of inside P3D does not take a massive fps hit? Thats why i should try it externally?

 

Thanks Michael Moe

Share this post


Link to post
Share on other sites

P3D works different to FSX. The NI limiter will more or less to P3D mimic a monitor refresh.

 

So we can set a "refresh" frequency as low as 29fps here. P3D VSync (which isn't the monitor refresh) is steered to by the GPU so you will see fps "hanging around" 30 with VSync on and slider at Unlimited. Put the triple buffer on since this takes up no more time, just a little GPU memory.

 

Alternatively keep the NI limit on, turn off VSync and TBuf, and move the slider to 30fps the same as in NI limiter.

 

Either of these set-ups give good results.

 

Using the fps slider introduces look ahead frames and also computes each frame at an equal time period but consumes more GPU and CPU.

 

...don't be fooled into (the popular idea around the forums) putting a limit of 30 in NI and setting 33 in the sim, this does not work since it's two different time periods that cannot, by definition, ever match up. Generating faster frames does not give us a frame-in-hand.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this