Sign in to follow this  
CaptBmckay

NTDLL CTD's P3D

Recommended Posts

Gentleman, I now randomly have been receiving the NTDLL crashes after having no problems for months. Its consuming me. I am at work now reading every forum for answers.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Split from another post.  Trying to manage several types of crashes in one post is difficult.

 

The ntdll.dll crash is common.  There are many suggestions for fixing this crash in the AVSIM CTD Guide (see link in my signature).  There is no known fix that works for everyone.  You will have to investigate "the scene of the crime".  AVSIM recommends you move your p3d.cfg, dll.xml, and exe.xml (if you have them) to a temporary folder and then restart p3d and the p3d.cfg will be rebuilt.  This fixes a majority of the crashes as many employ tweaks in their p3d.cfg that are not compatible with their computer.  The dll.xml and exe.xml load modules that might be incompatible with P3D so, if rebuilding the P3D.cfg did not fix the problem, then you need to see if one of the modules inside the dll.xml is corrupted or incompatible.  This is explained in the CTD Guide how to modify the dll.xml and exe.xml to try to find the offending module.  Lastly, if overclocked, this is a know cause of this crash if your cpu voltage is too high or too low.  You can play with the cpu voltage or return your overclock back to the defaults and start all over.  If you are not overclocked, this this does not apply.

 

EDIT:  Did you upgrade to P3D 3.2 yet?  That might fix it too.

 

Best regards,

Share this post


Link to post
Share on other sites

I have. Its kind of strange. Everything works well its just after about 40 minutes into cruise The sound stutters and boom, I recieve an error stating P3D fatal error program must close. It appears to only be happening with the Airbus X

Share this post


Link to post
Share on other sites

I totally stopped the NTTdll..dll crashes I started getting a couple of months ago that were happening on about every 5th flight or so, doing these two things:

 

1. In My Traffic 6 ,  renamed the file MyTraffic\scenery\MyTrafficmil.bgl to MyTrafficmil.bgl.passive ( I think this was the main cause of my CTD's) 

2. Turned off UAC in windows. 

 

Haven't had one in almost 2 weeks. 

Share this post


Link to post
Share on other sites

Yes, regarding MyTraffic, that's stated in the AVSIM CTD Guide as one of the possibilities.  According to the developer, it's a scheduling program error.  All of the AI have to have a flight plan to take off and land.  If an AI does not have a flight plan, it cannot take off or land and the sim crashes.  I thought this problem was fixed in MyTraffic6 but evidently not.  You did the right thing by deactivating the military.bgl.  I have not seen it yet in MyTraffic6.  It was common in MyTrafficX5.4c.

 

Best regards,

  • Upvote 1

Share this post


Link to post
Share on other sites

good morning

 

yesterday evening i had this error just 10min after took of ksfo

 

i don't know why but since i had updated P3D from 2.5 to 3 i am not able to achieve a flight from ksfo to paris, with the 777 pmdg with orbx global vector and lc

however when i fligh in enrope for exemple paris to dubai or dubai to paris 7H30 flight sometimes i have no problem at all!

So ntdl.dll could be a problem with orbx LC ?

Share this post


Link to post
Share on other sites

My issue was with MyTrafficX 6a.  I wish there was a way we could tell you what to do to fix your issue.  I hear you, it's madding!

Share this post


Link to post
Share on other sites

I totally stopped the NTTdll..dll crashes I started getting a couple of months ago that were happening on about every 5th flight or so, doing these two things:

 

1. In My Traffic 6 ,  renamed the file MyTraffic\scenery\MyTrafficmil.bgl to MyTrafficmil.bgl.passive ( I think this was the main cause of my CTD's) 

2. Turned off UAC in windows. 

 

Haven't had one in almost 2 weeks. 

 

I turned UAC back on and it has been on for over a week and still now CTDs, so it was definetly the My Traffic 6   renamed the file MyTraffic\scenery\MyTrafficmil.bgl to MyTrafficmil.bgl.passive fix . 

  • Upvote 1

Share this post


Link to post
Share on other sites

I turned UAC back on and it has been on for over a week and still now CTDs, so it was definetly the My Traffic 6   renamed the file MyTraffic\scenery\MyTrafficmil.bgl to MyTrafficmil.bgl.passive fix . 

 

Great post Bob 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this