Sign in to follow this  
cropduster

P3D FPS Drop below 5

Recommended Posts

When I start P3D I have been running into issues within 10 minutes of the sim running my FPS go below 5 and the sim comes completely unusable and extremely stutter filled.  Sometimes P3D just closes and I can restart it and load up to my last point and it runs smooth the rest of the way.  This occasionaly occurs in flight as well or on decent.

 

Current System- I7 4790K no OC, GTX970 and 8GB of Ram.  I have an SSD and is used to about 65%.

 

Addons Used typically on my P3D computer....

- PMDG 737

- Go Flight MCP Pro

- Avialsoft Data Provider

 

Addons on Network

- ASN

- ACARS for VA

- Avialsoft Display Unit

- Wide FS

 

 

I typically restart my P3D computer before each flight.  I also have never really messed with NVIDIA Inspector since I dont really know how and I have no CFG fixes or changes that I have attempted.

 

I run one monitor, 4K 29"

 

 

 

4.png

3.png

2.png

5.png

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Start over with just the default P3D with NO addons - does same thing happen? Do not start tweaking etc - this is a corrupted file or a hardware malfunction that won't be fixed with settings. Just ruin default and let us know what happens. If it works - then add back your stuff one by one and retest.

 

 

Vic

Share this post


Link to post

Vic- Are you saying to uninstall P3D and all my addons and then re-install P3D?

Share this post


Link to post

When faced with something like this I tend to go back to the basics. logically - unless you have a really nad P3D install - this is NOT a native p3d problem or you'd be hearing the screams. That leaves only add-on software and/or hardware.

 

i'd start by doing a quick check of running processes, run a memory test, check your disks, etc. Be sure you have no AV scanning files during simming, etc. If none of that works -

 

then I'd do a complete uninstall of P3D and add-ons - be sure to delete the added folders suggested by LM.

 

then reinstall JUST p3d - and run.

 

Again, *MY* logic - if nothing jumps out as the cause quickly - I can spend a few hours uninstalling and reinstalling or I can try random tests and tweaks hunting blindly in the dark and spend the same two or threwe hours or MORE and be frustrated while I'm doing it.

 

Frankly, and this is just MHO, I see way too many folks spend more time trying to find the easy way when they could have done it faster the hard way.

 

Vic

Share this post


Link to post

May i ask, are you running with ship traffic?  I was having the same issue until i turned off ship traffic

Share this post


Link to post

How do I fix that?

Well, as others have said, it is a detective work for sure.  I would start with removing one by one, all the add on programs or scenery, after flying P3D v3.2 each time for the length of time you say the problem (very low FPS occurs). The one time, you no longer have the problem...will show you what add-on, or scenery was causing the memory leak, that brought your sim down to 5 FPS, and eventually failing to Desktop.  That's about the only way you can do it, unless you use a memory sniffer program, and watch for when your memory is being used up as you run the program.  That's about the only two ways that I have used...but others might have other suggestions.  Sorry to read of your problem.

 

I hope this will help you out.

 

Ses

Share this post


Link to post

Are you starting from a sleep/hibernate state?. It can take up to 30 minutes for windows to return to full operating mode after wake up. I experienced these low frame rates when using Prepar3D straight from hibernation, I now cause a full reboot if my PC has been in hibernation mode and I wish to use Prepar3D.

Share this post


Link to post

May i ask, are you running with ship traffic?  I was having the same issue until i turned off ship traffic

No, not running ship traffic. Currently removing addons one at a time to see if I can find the problem 

Share this post


Link to post

You use addon for night lights? Taburet or Aerosoft night environment for example.

In this day i have same issue when approaching at LICC by RFScenery. 2 flights...to crash at same point.

Few minutes ago, i test area over scenery LICC, after 15/20minutes, sim drop down to 5fps and crash.

In area use: FTX Global Terrain, OpenLC, LICC RFS and Taburet lights europe base.

During test, and on 2 crash flights, monitor VAS and no >1500/1600, good, and gpu  don't over 40/45%.

I don't have any idea for this crash... My p3d 3.2 is fresh install, no tweaks in cfg...no shader mod, no enb...

Share this post


Link to post

Some versions of the Nvidia driver may cause this, specially in case the sim was minimized to the taskbar for an extended time.

Try to investigate toward the video-driver first...

 

Potroh

Share this post


Link to post

...in my case i have the 364.72.

Test now on LICC without taburet lights, and at moment i don't have any issue. Now, test it with taburet on... :wink:

Share this post


Link to post

Some versions of the Nvidia driver may cause this, specially in case the sim was minimized to the taskbar for an extended time.

Try to investigate toward the video-driver first...

 

Potroh

I tested this theory all day yesterday and i think it may be the cause of my problem. Is there any solution recommended for this?

 

Regards..

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this