Sign in to follow this  
bobrbend

Graphics Driver Failed, Recovered

Recommended Posts

I've had this happen a couple of time now on trans-Atlantic flights. I believe its limited to P3D v.3.5.

 

My screen flashes, goes dark, almost instanlly comes back on and I get the above message. Of course, the event causes a CTD in P3D.

 

I have an Nvidea GTX 970 and the driver is 368.39-and a dual monitor setup.

 

Running Windows 10 64.

 

Anybody had this experience or have an ideas what causes it?

 

Thanks.

 

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It happens to me from time to time, not too often, also using a GTX970 but with a single 4K screen with FSX. 

Not sure of the Nvidia driver, not at PC, but it was the most current one as of a couple of months ago. I'm using WIN 7, so apart from the same end result, and the same video card, not much in common, which would leave me to believe it's down to the card.

Fortunately, although it's annoying, it's not that frequent for me, so I just live with it.

Eugene

Share this post


Link to post
Share on other sites

Could indicate a hardware problem, but as stated above, it can happen occasionally for no apparent reason.

Share this post


Link to post
Share on other sites

This happened to me too - rarely and very infrequently, with an AMD card, on Windows 7, in P3Dv2 and v3. I could not link it to a specific scenario. Therefore I assume that it is a mixed bag of P3D and graphics drivers issues that surface just in the worst moment. I gave up on trying to analyze and report it.

 

Cheers

Frank

Share this post


Link to post
Share on other sites

It could also be RAM exhaustion, on the card, as your scene demands get ever more complicated...or the weather gets nastier.

Share this post


Link to post
Share on other sites

 

 


Anybody had this experience or have an ideas what causes it?

 

Believe you are getting the "Display driver stopped responding and has recovered" error?  This is actively being discussed in the AVSIM CTD Forum - http://www.avsim.com/topic/491631-black-screen-on-airbus-decent/ .  It's a fairly common error.  I provided a link to possibly fix the problem - https://support.microsoft.com/en-us/kb/2665946.

 

Best regards,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this