Sign in to follow this  
Angelo Cosma

Small pauses but 30FPS all the time

Recommended Posts

Hey guys I have been on the fence about posting since I like to do my research first, and narrow down to the potential suspects. But I feel I have done that and there are so many threads reference variations of the issue I want to seek out the most up to date information. 

 

Quick rundown: 

 

P3D V3.3 / WIN 10 64 Bit / Single Monitor

Specs are in my sig

I can achieve 30FPS via unlimited in P3D and using an external limiter to 30fps such as Dxtory

I run my sim from a clean boot and do not engage in any web browsing or the sort while simming.

I do run ASN, REX, PMDG, FSDT, Orbx (Global Only)

 

I am noticing now I can be in the 777 at dusk, running all my addons on the ramp at FSDT KLAX, AI traffic, and hold a solid 30 FPS. Note I am not having a low FPS stuttering issue. I am having what I perceive to be a small pause periodically for less than a second but noticeable enough to kill the immersion. 

 

Steps I have taken to mitigate the issue:

 

1. Delete and let P3D rebuild the CFG.

 

2. Clear Shaders folder and let one regenerate.

 

3. Disable my AV just for testing purposes.

 

4. My GFX drivers are the ones just prior to the current release that is out now. 

 

I run HT OFF but there is no AF=14 in my cfg, I have not added it in there as I hear it is best to run with a vanilla cfg. 

 

That's all I can think of now guys, please let me know what you think and what to try. I will report back any additional information as needed. 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Try locking at 30 in P3D and not using external limiter - see if that changes anything. If the pause is timed at a regular interval, look for programs that are loading or checking status, etc..

 

Part of my thinking is that when you run unlimited in sim, regardless of external limiters, you are telling P3D to devote maximum effort to FPS which detracts from other processing tasks. If all is well (meaning settings within limits) you may not notice anything but if you get into an area that puts the sim under more load - you may start to get pauses - no matter what you call it, a pause is a stutter.

 

Until you can determine the cause, it will be hard to find a "fix" - you can  play with FFTF and AM but it may also make it worse.

 

Vic

Share this post


Link to post

If I lock the FPS in P3D then the hit is too great, locked will do about 20-24 fps which is pretty apparent. I will try it again however, and try running without active sky and other programs that may poll for info. 


I also forgot I had FSUIPC AutoSave running. Could that be the culprit?

  • Upvote 1

Share this post


Link to post

Just try with autosave "off". Otherwise I would guess it is the scenery in combination with your settings (autogen, traffic etc.)

Share this post


Link to post

With me the same problem :
PMDG 777 FPS ( Intern ) locked at 50 at 50Hz .
Each default aircraft is running smoothly , with the 777 I have this short stopper , like so:
... Stop ... Stop ... Stop ... etc.
Have FSUIPC installed but unregestriert because it is supposed to not auto-save function give .
Sorry my English !

Share this post


Link to post

 

 


FPS ( Intern ) locked at 50 at 50Hz .

 

Why so high?  You should be able to get smooth animation at rates down to 24.  You are forcing the program to put out frames at a rate that might not allow it to complete a frame so you get a stutter.

Share this post


Link to post

Why so high?  You should be able to get smooth animation at rates down to 24.  You are forcing the program to put out frames at a rate that might not allow it to complete a frame so you get a stutter.

 

50 FPS / 50Hz I get the best plan found on my system with all standard - aircraft , also Aerosoft Airbus and ORBX - FTX Global and LC Europe .

No stuttering even with off / landing at 50 % AI Traffic and Road Vehicles .

In PMDG 777 I have translated 51 FPS , same result .

If I put exactly 50 FPS as with other aircraft , no stuttering , but brief stops .

Share this post


Link to post

Have you tried disabling the "cockpit tool tips" option? I was having exactly the same small pauses and got rid of them by disabling it. You could also try setting your frames to unlimited and enable the VSync in P3D graphics settings...

Share this post


Link to post

Yes , Cockpit tool tips are disabled .
FPS Unlimited gives stuttering , VSync is On .

Share this post


Link to post

Try with vsync off in invidia control panel stopped all my stuttering

Share this post


Link to post

Already had tool tips off and all NVI NVCP set to default/off. Turning OFF FSUIPC Autosave is what did the trick for me. 

  • Upvote 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this