Sign in to follow this  
RISCfuture

Thrust levers move but no response from engines (and other issues)

Recommended Posts

OK, brand new computer, and a fresh install of

  • Prepar3D v3 v3.4.18.19475
  • FSUIPC v4.959
  • PMDG 737 NGX v1.10.6462
  • FS2Crew NGX v3
  • Ground Services X v1.9.9.10
  • Active Sky 2016 SP1

This setup worked fine in my last computer, but now I'm getting all sorts of strange avionics and control problems. In particular:

  • The flight data recorder fails shortly after power is applied.
  • Following a normal APU start, both engines fail to respond to thrust lever commands. The levers move in the pit, but the engines remain at 20.8% N1.
  • Turning on the APU causes engine #1 only to become responsive and fixes the flight data recorder.
  • Turning off the APU has no effect on the APU EGT gauge.

I've seen other posts on this forum and I've tried

  • Resetting FSUIPC.ini
  • Resetting the PMDG default flights
  • Creating a new vanilla Prepar3D default flights
  • Disabling TrackIR (someone said it worked for them??)
  • A manual engine start without using FS2Crew or GSX

to no avail. If anyone has any insight, I'd appreciate it.

 

In case it matters, the relevant hardware setup:

  • ​PFC C2 with a custom macro file to disable most of the C2 when flying a PMDG aircraft

and some other random deviations with the PMDG aircraft that I've noticed:

  • Selecting the PMDG DEFAULT saved state fails to start the engines and leaves the aircraft with a few other faults.
  • GSX insists that the left forward passenger door is shut even when it's opened by FS2Crew. I have to shut it and reopen it to get GSX to continue.
  • One time I got a "DOORS" light even though the FMC confirmed all doors were shut.

I want to reiterate that none of these problems happened on my last install. All of a sudden everything is wonky after a fresh start.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Follow-up: Tried the PMDG 777 too, simple start with no FS2Crew or GSX.

 

Like the 737, the thrust levers have no effect, but UNLIKE the 737, the position indicators on the DU do respond to lever movements. But thrust does not increase above idle. Also, the engine bleeds fail to turn on.

Share this post


Link to post
Share on other sites

Are you overclocking - if so - try with default settings

 

Check your real time clock and high-precision event timer, which are part of your motherboard. Many programs depend on these for keeping systems synced.

Share this post


Link to post
Share on other sites

"PMDG 737 NGX v1.10.6462"

 

Or, PMDG 737 NGX v1.10.6461 ?

 

P3D default aircraft ok?

 

Exterior view, have landing gear present?

Share this post


Link to post
Share on other sites

Sorry yes, 6461. P3D default aircraft work fine. The landing gear is present in the exterior view, but for some reason the seats are visible outside the cockpit model in the scenario editor window.

Share this post


Link to post
Share on other sites

I'm not sure about this because I don't have a clue what PFC C2 is; however, it could be that your configuration is not compatible or is interfering with PMDG products.  Most of the PMDG simulation takes place outside of P3D in their own modules.  If the product is not initializing, the 20 sec countdown, then I think this is most likely.

 

Also don't have any idea why you'd be using the P3D scenario editor. It most certainly is not required to set up a scenario such as aircraft at the gate in a turn around mode, or enroute at cruise, or any other scenario.  I have removed it so it doesn't load and waste valuable VAS.

Share this post


Link to post
Share on other sites

The PFC C2 is an integrated yoke and switches: https://flypfc.com/shop/flight-consoles/c2-professional-flight-console/ It worked fine with my last computer and FSUIPC and PMDG

 

The 20-second countdown does occur when initializing, but if I initialize to the PMDG DEFAULT state, the engines immediately quit after the countdown completes.

 

The suggestion about the scenario editor is helpful, thanks, but doesn't really address my problem.

Share this post


Link to post
Share on other sites

Did you activate the 737, 777?

Also have you installed simconnect?

Share this post


Link to post
Share on other sites

Both airplanes are activated. I thought I had installed SimConnect but I don't see it in my Programs & Features list. When I double-click the installer (any of the installers), I very briefly see a progress dialog but then it quickly disappears, and nothing else. My Event Viewer has the following event:

 

 

Windows Installer reconfigured the product. Product Name: Microsoft Flight Simulator SimConnect Client v10.0.60905.0. Product Version: 10.0.60905.0. Product Language: 0. Manufacturer: Microsoft Corporation. Reconfiguration success or error status: 0.


Ah I see it now. I have the following SimConnect versions installed:

 

ESP SimConnect Client v1.0.20.0

MFS SimConnect Client v10.0.60905.0, v10.0.61242.0, and v10.0.61259.0.

Share this post


Link to post
Share on other sites

OK, some progress. If I remove the PFChid.dll file (the DLL created by Pete Dowsen of FSUIPC that allows the PFC C2 to work with FSX/P3D), everything is normal -- but of course, my PFC C2 doesn't work.

 

There must be some configuration difference relating to the C2 between my old and new computer that's causing this...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this