Sign in to follow this  
WebMaximus

VFXCentral is automatically launching with P3Dv3.2

Recommended Posts

Noticed a thing I haven't seen before, how VFXCentral is launching automatically with P3Dv3.2 although I haven't enabled this under Preferences.

 

Not a big deal but still a bit annoying.

 

Anyone else seen this?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Check the structure of your exe.xml file so see if anything is broken in there. It could be enough to prevent the proper modification of the file

Share this post


Link to post
Share on other sites

Does vfxcentral have to run at all when using ChasePlane? I would rather close it down if I have the option.

Share this post


Link to post
Share on other sites

Check the structure of your exe.xml file so see if anything is broken in there. It could be enough to prevent the proper modification of the file

 

Checked both my exe.xml files but they both look fine and I couldn't find anything related to VFXCentral in either one of them.

Share this post


Link to post
Share on other sites

Noticed a thing I haven't seen before, how VFXCentral is launching automatically with P3Dv3.2 although I haven't enabled this under Preferences.

 

Not a big deal but still a bit annoying.

 

Anyone else seen this?

make sure you're logged into the vfx app before launching your sim.

Share this post


Link to post
Share on other sites

make sure you're logged into the vfx app before launching your sim.

 

Whenever I manually launch VFXCentral I'm already logged in and this is what my preferences tab looks like and as you can see the option to have VFXCentral started with P3D is unchecked/disabled.

 

VFXCentral%20preferences.JPG

Share this post


Link to post
Share on other sites

Thanks for your input Jeff.

 

So since I'm not the only one having this issue (although I'm on P3Dv3.2) something clearly changed in the latest version of VFXCentral causing this.

Share this post


Link to post
Share on other sites

Same here, seems it's added itself to my exe.xml, I would dearly love to have the old stand alone PrecipitFX back, I have had constant issues when I launch VFXCentral, it automatically downloads updates then cannot install those because it is locked by another process using VFXCentral.

Only way I can get it to update then is to boot in safe mode with networking, as a last resort I downloaded VFXCentral and installed it in the root of my C drive then I find this in my exe.xml

 

<Launch.Addon>
    <Name>VFXCentral</Name>
    <Disabled>False</Disabled>
    <Path>C:\OldProp Solutions Inc\VFXCentral\VFXCentral.exe</Path>
    <CommandLine>P3Dv3</CommandLine>
  </Launch.Addon>

 

Edit:

I have unticked the option to start VFXCentral with P3D and it is now gone from my exe.xml (don't know how that got ticked in the first place)

But I am unable to untick the automatic check for updates, it's grayed out.

Share this post


Link to post
Share on other sites

I seem to have fixed it but who knows for how long it will last.

 

I had another look in my exe.xml files trying to figure out where/how VFXCentral was loaded and now I did find it's entry in exe.xml under %appdata%\Roaming. Weird since I didn't see it in there yesterday when I checked but maybe I somehow overlooked it.

 

Anyway what I did today was to manually edit exe.xml removing the VFXCentral entry.

 

I then made sure it was no longer started automatically with P3D. After doing this I started VFXCentral and enabled the option to have it loaded with P3D and then exited out of VFXCentral.

 

I then checked my exe.xml and correctly there was now and entry in there again for VFXCentral. I then started VFXCentral again and disabled the option to have it start automatically with P3D, exited out of VFXCentral and checked exe.xml and this time it was removed.

 

So...with this said it seems to work as intended but I still don't understand how it ended up in my exe.xml in the first place since I have never enabled the option to have VFXCentral start automatically with P3D.

Share this post


Link to post
Share on other sites

Why would we ever want VFXCentral to run alongside P3D anyway, maybe the Dev could comment.

Share this post


Link to post
Share on other sites

thanks guys for your posts

checked my exe.xml

found VFXCentral in there are you saying delete this entry as it should not be there

or maybe <Disabled>True</Disabled>

would this sort out the problem

thanks again Glynn- WebMaximus

Share this post


Link to post
Share on other sites

 

 


are you saying delete this entry as it should not be there

or maybe True

 

I just opened up VFXCentral and set VFXCentral not to start with P3D, that removed it from exe.xml.

No Idea how it got set like that, imagine if every third party app we have for the Sim took it on themselves to start up without asking. maybe the Dev would like to comment.

Share this post


Link to post
Share on other sites

Setting the disabled parameter to true would of course stop VFXCentral from being loaded as long as you don't manually launch it. Not sure what will happen if or when you do.

 

A better option is to follow my example above I think.

Share this post


Link to post
Share on other sites

I'm guessing now but maybe what happens is some update of VFXCentral will set it to load automatically via exe.xml even when that option is disabled in the GUI meaning they will get out of sync sort of speak.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this