oliver1234

Sudden loss of fps with mouse cursor bug

Recommended Posts

Hello all!

 

My fps have suddenly dropped over the course of one night

 

I used to use OpusFSX, before I decided to make the switch to Ezdok V2 (I did have Ezdok V1) - I changed to Ezdok v2, and the 'mouse cursor issue' appeared out of nowhere - I've never had that issue before in my entire time of simming. I uninstalled V2, went back to V1 and still had the issue - So then I went back to no camera addon (ie. the default FSX camera system) and the problem persists). I've reinstalled FSX this morning to no avail...

 

Any ideas? I am aware that this is an age old bug with FSX, but anyone for ideas?

 

Thanks,

Oliver Mitchell

 

Edit: Only in VC do the FPS drop (30-35fps to 15-20fps (NGX))

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It suddenly appeared for me too. I wrote a long reply on another thread recently. I annihilated it completely by running Borderless Gaming. Running fsx in window fixes mouse problem in vc for me permanently.

Share this post


Link to post
Share on other sites

It suddenly appeared for me too. I wrote a long reply on another thread recently. I annihilated it completely by running Borderless Gaming. Running fsx in window fixes mouse problem in vc for me permanently.

Right, okay - Is there still lag however, when the mouse is placed inside of the window?

 

I have no solution to your problem, and I have the same problem, but I have written a workaround in FSUIPC:

http://forum.simflight.com/topic/80982-mousemovelua-move-mouse-to-upper-window-edge-of-fsx-if-the-mouse-is-not-used/

Thanks! Will check it out :)

Share this post


Link to post
Share on other sites

 

 


Right, okay - Is there still lag however, when the mouse is placed inside of the window?
 

 

There is absolutely no lag at all. Only lags in original 'full screen' mode. Borderless Gaming runs game in window without a border which looks same as FS, often runs smoother too as windows can manage vsync better. You can wave the mouse around and use mouselook finally with no frame hit..

Share this post


Link to post
Share on other sites

There is absolutely no lag at all. Only lags in original 'full screen' mode. Borderless Gaming runs game in window without a border which looks same as FS, often runs smoother too as windows can manage vsync better. You can wave the mouse around and use mouselook finally with no frame hit..

 

Right, okay! Interesting. If I were to use windowed mode instead of full screen mode without borderless gaming, would it have the same effect as with borderless gaming installed? As in like - Will putting FSX in windowed mode ensure there is no lag when the mouse is placed inside of the window or will there be lag, and only with borderless gaming will the lag go?

 

Thanks, Oliver Mitchell

Share this post


Link to post
Share on other sites

I read a blog "have a mouse button assignment for cockpit pan of EZCA" it will hide the cursor automatically.

Share this post


Link to post
Share on other sites

installed? As in like - Will putting FSX in windowed mode ensure there is no lag when the mouse is placed inside of the window or will there be lag, and only with borderless gaming will the lag go?

 

Lag is entirely gone in a window, regardless of how you get there

You can test that out by maximizing the window then pressing alt-enter to switch back and forth. I only mentioned BG as only full screen users should get the issue so thought fs was important. Try moving your mouse in a slow smooth continuous circle over the vc gauge panels. I could drop the fps to 0 doing that. Ie it would actually freeze until I let go of the mouse.

Share this post


Link to post
Share on other sites

I don't think it's a bug. I still got it when I tried out P3D 3.3.5. I think it's hardware related, rather than a problem with the sim itself. Others have reported that better hardware doesn't seem to have this issue as much.

Share this post


Link to post
Share on other sites

I have this issue in windowed mode (borderless or not), loss is about 5-10fps (of 30fps)

Share this post


Link to post
Share on other sites

Lag is entirely gone in a window, regardless of how you get there

You can test that out by maximizing the window then pressing alt-enter to switch back and forth. I only mentioned BG as only full screen users should get the issue so thought fs was important. Try moving your mouse in a slow smooth continuous circle over the vc gauge panels. I could drop the fps to 0 doing that. Ie it would actually freeze until I let go of the mouse.

I still have the lag in windowed mode, like ThomasAH...

 

I don't think it's a bug. I still got it when I tried out P3D 3.3.5. I think it's hardware related, rather than a problem with the sim itself. Others have reported that better hardware doesn't seem to have this issue as much.

I'm seriously stumped - I haven't changed my hardware, and it just came out of nowhere!?

 

I have this issue in windowed mode (borderless or not), loss is about 5-10fps (of 30fps)

Same :(

Share this post


Link to post
Share on other sites

Try going to mouse properties, on 3rd tab option in POINTER OPTIONS is ENHANCE POINTER PRECISION.

Unselect this, turn it OFF.

When turned ON it may conflict with the game/sim internal mouse handling. It was part of my complete fix procedure when going borderless window. 


http://www.avsim.com/topic/479100-mouse-cursor-performance-impact-fact-or-fiction/page-2

 

The full details of my particular fix are here, also entire thread may be useful for OP here as well. Good luck y'all its so much better without mouse lag!

Share this post


Link to post
Share on other sites
21 hours ago, oliver1234 said:

I'm seriously stumped - I haven't changed my hardware, and it just came out of nowhere!?

Let me clarify. If you've been using FSX all this time and it wasn't affecting you until recently, the problem is not FSX.

Perhaps not hardware related like me, but maybe you have some software running outside of FSX that's competing for resources causing it to drop.

Share this post


Link to post
Share on other sites
On 2/23/2017 at 10:07 AM, magnetite said:

I don't think it's a bug. I still got it when I tried out P3D 3.3.5. I think it's hardware related, rather than a problem with the sim itself. Others have reported that better hardware doesn't seem to have this issue as much.

The issue happens due to the flawed way the FSX/ESP/P3D engine calculates where the Windows 2D mouse cursor is pointing within the 3D world of the sim. In most modern game engines that use a cursor, the cursor is rendered as a 3D accelerated object that's part of the game world. The sim's engine doesn't do this unfortunately, it relies on a bunch of heavy CPU math to figure out what the cursor is pointing at. This is why you get a bigger slow down when using a complicated VC with a lot of clickspots as soon as the cursor comes into the game window - it's sitting there enumerating all of the clickspots for mouse interaction over and over. Obviously the more powerful your CPU is, the less of an effect it has on you - I did a pretty huge CPU upgrade last month (going from a nearly 7 year-old i7 860 to an i7 7700K) and I barely see the issue now.

I seriously doubt any of the Windows cursor settings play a role in this - I remember testing them back when we tried to figure out how to mitigate this issue when making the NGX. "Enhance pointer precision" is just the Windows mouse acceleration feature (not to be confused with hardware graphics acceleration above) - instead of 1:1 movement, the motion of the cursor accelerates as you move it faster and decelerates as you move it slower - variable sensitivity. Generally this is frowned upon in gaming, especially in first-person-shooters where you want a consistent relationship between the distance the mouse moves and the rate of rotation of your aiming crosshair in the game world. The standard recommendation is to run it on the 6th notch of the speed slider with Enhance Pointer Precision off - this gives you 1:1 motion with most mice. The only time I turn Enhance Pointer Precision on is with laptop trackpads where your physical motion is so constrained that it's necessary.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now