Chuck Dreier

SODE, Another Process Is Still Running

Recommended Posts

I've just started getting this error message:  "Another SODE Process is still running in the background.  Please kill the process in task manager and restart the sim."  It happens every time I start P3D and I don't see anything running in Task Manager.  The only thing I can think of is that I just installed Ultimate Traffic Live, but have nothing to make me believe that's the cause.  I need help please!  Thanks guys!

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Chuck,

I've had this pop up a few times now but a different situation to yours.

For me, it generally happens when I start FSX:SE and then it crashes (usually due to FSLabs & it's DLL) and I need to restart the sim. Sode doesn't shut off because it hasn't recognised that FSX has closed. Upon restart of the sim I get this error message because SODE is trying to start itself and has realised it is already running. Interestingly though, I only started to see this FSLabs DLL issue pop up AFTER I installed UT Live. (previously it was only after installing a FSLabs update) so perhaps UT Live is the culprit?

 

 

Share this post


Link to post

Chuck, I had the same problem. I completely deleted the SODE version I was using and replaced it with the new one. I first hit the button to update and this problem started. Apparently the update created another SODE, so 2 were running at once. Worked for me

 

Bill W

Share this post


Link to post

I'm having is issue also, where is sode installed? would anyone mind explaining how to uninstall and install the new version? please.

Share this post


Link to post
13 hours ago, ssimm1958 said:

I'm having is issue also, where is sode installed? would anyone mind explaining how to uninstall and install the new version? please.

C:\Program Files (x86)\12bPilot\SODE

Share this post


Link to post
On 4.4.2017 at 1:37 AM, BillW said:

Chuck, I had the same problem. I completely deleted the SODE version I was using and replaced it with the new one. I first hit the button to update and this problem started. Apparently the update created another SODE, so 2 were running at once. Worked for me

 

Bill W

I've have the same problem, Bill W. But it did'nt work for me. I had to uninstall SODE and the addon (Mallorca X) that coused the problem so I could get P3D to start. I have always had problems with Aerosoft addons. Never more. 21 Euros down the drain :-(

Share this post


Link to post

This happens because FSX/P3D doesn't terminate as it should, which would normally end the running SODE program. Thus SODE is still running and when FSX/P3D tries to start again it sees an already running process and complains. Going into Windows Task Manager and ending the SODE task should allow things to start normally.

Share this post


Link to post
55 minutes ago, Pease_W said:

This happens because FSX/P3D doesn't terminate as it should, which would normally end the running SODE program. Thus SODE is still running and when FSX/P3D tries to start again it sees an already running process and complains. Going into Windows Task Manager and ending the SODE task should allow things to start normally.

I can confirm this. It happened to me when I had some problem with a dll entry (probably HiFi) which caused a CTD during P3Dv4 start. When I tried to restart the sim, I got the above mentioned SODE error. After I had resolved my dll problem and rebooted the PC, the problem was gone.

Share this post


Link to post

I'm having the same issue. I uninstalled and installed again SODE, but that did not work. Any other solution?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now