Recommended Posts

Hello!  I just bought x-plane 11 and I find it absolutely sublime apart from the view controls, which I can't seem to get working.  I initially got x-camera and installed that in the plugins folder, but when I tried to use it the camera twitched annoyingly and I found it hard to read the text in the cockpit so I disabled it.  But now that I'm trying to work with X-plane 11's default view controls, I find that they don't function at all in 3D cockpit view.  I set up key bindings in the "view/manipulate view" menu, but when I try to use them nothing happens.  

Do you have any suggestions as to what I might try?  

 

Thank you in advance!  

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You can control views using the keyboard's numpad. Position the camera view you wish to record, including zoom. Then press CTRL (Numpad Number) to record that view. Now whenever you press that particular numpad number it will return to that view. As an example I record the overhead panel to the Numpad 8 key and the MCDU to Numpad 5. 

Share this post


Link to post
Share on other sites

The neat thing about the default Ctrl+Numpad views mentioned above, is that they're saved separately for each plane model. That's very handy, because what you need to look at is likely to be in a different place in each cockpit.

Share this post


Link to post
Share on other sites

Thanks for the reply!  The trouble is that I can't move the view to look at any place in the cockpit other than dead ahead, so it's impossible for me to customize the views in the first place.  

Share this post


Link to post
Share on other sites
9 hours ago, Paraffin said:

The neat thing about the default Ctrl+Numpad views mentioned above, is that they're saved separately for each plane model. That's very handy, because what you need to look at is likely to be in a different place in each cockpit.

I also new in X-Plane, I get visualisations without problems but I have a problem with 747-400.
Well. I on FD, A / T Arm and other functions, they turn it on and off.
But SPD if connected airplane obeys selected speed, but it is not possible to switch off.
Is it possible to create a keyboard shortcut for the SPD function?
My hope is that this works because I already sent BUG Report to LR, from February of this year, but until yesterday nothing, I do not know if 747-400 will be finished.
Thank you.

 

João Alfredo

Share this post


Link to post
Share on other sites
2 hours ago, TristanHarmsen said:

Thanks for the reply!  The trouble is that I can't move the view to look at any place in the cockpit other than dead ahead, so it's impossible for me to customize the views in the first place.  

Okay, first make sure you're in the 3D cockpit view mode (default is Shift + 9).

Then you should be able to pan, tilt, and move in and out with the keys listed in the Settings menu (Keyboard, Views, Manipulate View). 

You can also map the view movements to a joystick or other controller button in the Joystick menu (Move view up, Move view down, etc.) by setting the various commands. Some of this should already be mapped to your joystick or yoke hat switch by default.

Once you have that working, you can set a view for whatever part of the cockpit you want by using Ctrl + (numpad) which is saved for each plane, and be recalled by hitting that key on the numpad.

Share this post


Link to post
Share on other sites
14 minutes ago, Paraffin said:

Okay, first make sure you're in the 3D cockpit view mode (default is Shift + 9).

Then you should be able to pan, tilt, and move in and out with the keys listed in the Settings menu (Keyboard, Views, Manipulate View). 

You can also map the view movements to a joystick or other controller button in the Joystick menu (Move view up, Move view down, etc.) by setting the various commands. Some of this should already be mapped to your joystick or yoke hat switch by default.

Once you have that working, you can set a view for whatever part of the cockpit you want by using Ctrl + (numpad) which is saved for each plane, and be recalled by hitting that key on the numpad.

I did make sure that I was in the 3D cockpit, and I also double-and triple-checked my key and joystick mappings.  But no controls that I try to use, either with default or custom mappings, have any effect on the view, including the right mouse button.  

Share this post


Link to post
Share on other sites
44 minutes ago, TristanHarmsen said:

I did make sure that I was in the 3D cockpit, and I also double-and triple-checked my key and joystick mappings.  But no controls that I try to use, either with default or custom mappings, have any effect on the view, including the right mouse button.  

Okay, then the only thing I can think of, is that your previous installation of x-camera might have screwed up the view system somehow. It sounds like something is mapped to those controls that's overriding your keys and joystick settings.

Assuming you've done a complete removal of x-camera from the plugin folder, try this:

Delete the" X-Plane.prf" file from /Output/preferences folder and let X-Plane rebuild it on the next program start. If that doesn't help, delete "X-Plane Joystick Settings.prf" from that same folder. Then try remapping your keys and joystick mappings. 

  • Upvote 1

Share this post


Link to post
Share on other sites

I just started having trouble setting views with the control num pad.  I have double checked the number pad on of course.  I never had a problem with this before!  Now for some reason it doesn't work.  All I have is the default view and the mouse to change views.  I was wondering what got changed in my settings that might be causing this.  

Thanks,

Jim

Share this post


Link to post
Share on other sites
On ‎4‎/‎15‎/‎2017 at 10:48 AM, Paraffin said:

Okay, then the only thing I can think of, is that your previous installation of x-camera might have screwed up the view system somehow. It sounds like something is mapped to those controls that's overriding your keys and joystick settings.

Assuming you've done a complete removal of x-camera from the plugin folder, try this:

Delete the" X-Plane.prf" file from /Output/preferences folder and let X-Plane rebuild it on the next program start. If that doesn't help, delete "X-Plane Joystick Settings.prf" from that same folder. Then try remapping your keys and joystick mappings. 

Thanks a lot. That worked for me too!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now