kingconan

P3D 3.4 Texture Problem

Recommended Posts

Hi all,

I'm really pulling my hair out trying to figure out what's going wrong here so I would hugely appreciate any help anyone can suggest. I've tried over at the P3D forums but have received no help at all and it's the only way of me requesting 'official' help.

Ever since I've installed P3D3.4 I have an issue where the ground textures seem to be slow to load. It almost looks like they are constantly refreshing and even ground textures that I'm overflying will look to "re-load" as I fly over. It's hugely distracting and I can't enjoy my sim at all at the moment.

This is when flying a fresh installed (on a reformatted SSD) with no addons and I've tried experimenting having my P3D settings as low as they will go, medium and high but the same happens. This occurs when flying low and slow (3000ft, 170kt) and at FL360 M.780 so it happens across all ranges.

The textures will look fairly crisp on the ground but as I fly near them they will reload constantly.

My system specs: I7 6700K overclocked to 4.0Ghz, Nvida GTX 960, 250gb SSD and 16gb DDR4 RAM.

The link below will take you to 2 images. The first at 0.70 zoom and the second at 0.80 zoom. This shows how close ground objects are before they are loaded. This isn't the exact issue I'm facing with the ground textures but you'll get the point.

http://imgur.com/a/uquzm

 

Can anyone suggest what's going on here? I've tried everything from reformatting and fresh installs to tweaks, affinity masks, nvidia nspector but still can't find anything to work.

It's so distracting that my sim is useable in this current form. Interstingly I didn't have this problem in V2.5 but now many of my addons are only compatible with 2.5 so I don't want to have to revert back.

Thanks so much, 

Owen

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hello Owen, 

Currently what 3rd Party Software (Add On's)  do you have Installed ? 

I understand you have formatted your SSD but was your Operating System on the same drive ?  Do you have Prepar3D Installed here ?

------------------------

A quick step you can try first,  This will not effect any of your Add On's

Locate and Delete the 3 blue Generated files \ folder below,  When you Launch Prepar3D these will generate again removing any possible clutter in there  

-----

Local Disk (C:) ► ProgramData ► Lockheed Martin ► Prepar3D v3  -  SceneryIndexes 

Local Disk (C:) ► Users ► You ► AppData ► Roaming ►Lockheed Martin ► Prepar3D v3 -  Prepar3D.cfg

Local Disk (C:) ► Users ► You ►  AppData ► Local ► Lockheed Martin ► Prepar3D v3 -  Shaders 

-----

Launch Prepar3D and test 

===========================================================================

 

Are your Nvidia Drivers up to date ?   If not update your drivers and Insure you Tick the box for  "Perform a Clean Installation"  during the process 

Share this post


Link to post

Hi Poppet

What does deleting sceneryindexes accomplish?

Thanks,

Mark

Share this post


Link to post

Hey Poppet,

Yesterday I did another wipe of my SSD (all that's on my SSD is Windows and P3D).

Tested with no addons and straight out of the box I had the same issue. Tried turning the sliders all the way down but didn't help the issue.

I've updated to the newest Nvidia Drivers when I did the windows re-install and then checked again via Geforce Experience.

Tried deleting the folders above but no fix I'm afraid, it's really weird, especially on a fresh install!

Kind Regards,

Owen

Share this post


Link to post

Try removing NVidia experience, it worked wonders for me.

Share this post


Link to post
19 hours ago, newtie said:

Hi Poppet

What does deleting sceneryindexes accomplish?

Thanks,

Mark

Hello Mark,

It was a long shot,  but a cluttered up sceneryindexes folder can contribute to extreme scenery loading (catch up) 

Share this post


Link to post
15 hours ago, kingconan said:

Tried deleting the folders above but no fix I'm afraid, it's really weird, especially on a fresh install!

Hello Owen 

Could you take a Video of this "scenery refreshing"  using the built in Nvidia Shadow play,  Upload it to YouTube and post a link here,  It will give the Forum Users a first eye view of this Issue  

Share this post


Link to post

You have the blurries like everyone else who owns P3Dv3 has had since FSX was first released.  The blurries, or slow rendering of textures, is caused by high settings and/or tweaks and have been around in various degrees since FS2000.  It is one of the most talked about subjects since the inception of flight simulation. People have been trying unsuccessfully to come up with tweaks to get rid of these blurries.  Even the fastest computer in the world cannot stop "the blurries" (see my system specs).  I had a nasty fight with "the blurries" this past week and this weekend with FSX (which is the engine used by P3D with some modifications).  I finally fixed it.  Moved most of my sliders to the max but kept my display driver settings set to the defaults.  Problem gone (mostly).  You should do the same with P3D mostly because P3D has the display driver settings embedded in the P3D.cfg.  That's what I do.

IMHO, your video is one of the best showings of textures rendering fairly fast.  A jet aircraft going over 200 mph skips over Earth pretty fast and P3D and Windows and your computer hardware have to work pretty fast and hard to render everything almost instantly.  I do not think computers are there yet.  There's a lot going into rendering and much of it has to do with the monitor resolution.  For instance, I have a 34" monitor at 3440x1440 resolution and that's a lot of pixels that have to be rendered so my chances of getting the blurries are increased.  Much more than a 22 inch monitor rendering at 1920x1080 resolution.  When FSX was first released in 2006, I believe a 27 inch monitor was the largest monitor and users definitely saw their fps drop dramatically and were looking for ways to fix it.

If you have the LOD_Radius set above 4.5, you will have an even harder time getting the sim to render fast enough.

Autogen is one of the main causes of "the blurries".  The higher the setting, the more likely you will see "the blurries" or slow rendering of textures.

Any photoscenery installed and enabled, whether flying over it or not, will be loading in the background taking up valuable resources.

In the AVSIM CTD Guide, I have suggested settings for setting up a program called Resource Monitor so that it only monitors anything P3D (and not all of things being loaded in Windows).  You can use this program to see exactly what is loading in the background.

I have my zoom settings set at 40-50% for outside views.  For me it looks more realistic and provides faster rendering.

You might want do download and check out the AVSIM P3D Guide prepared by one of our moderators, Rob Ainscough (see the link in my signature or in the right sidebar).  He's the expert and he developed the guide to help people like you get the most enjoyment out of P3D.  I still doubt you will see rendering much faster than what you are showing in your video though.

One of the other things I have done to try to give me faster rendering is the installation of Flight One's GEP3D.  These are optimized textures that replace your default textures.  But I've heard that Lockheed has also optimized their texture and especially their Autogen.  Still I have GEP3D mainly because GEX did such a good job in FSX.

I have the Samsung 960 M.2 SSD, currently considered the fastest SSD in the world, and I still see slow rendering in FSX and P3D.  I have now gotten my settings in P3D set where I am satisfied mostly with the outside views.

Hope this helps.  Good luck in your continued testing and tweaking to get the best (or optimal) graphics for your P3Dv3.  I've been doing it for 10-15 years now.

Best regards,

Jim

  • Upvote 1

Share this post


Link to post

Hi Jim,

Thanks so much for such a detailed post, I am hugely grateful.

I've been simming for around 10 years, through FS9/FSX/P3D2.5 and P3D3, but except way back in the early days of my simming this is some of the worst visual anomalies that I've encountered. 

The interesting point is that I upgraded my computer around 6 months ago to my current specs and the texture issues (popping, slow redraw, small radius of detail around the aircraft) seems to have got worse since then.

Out of interest yesterday I got a friend with the same graphics card as me but a worse processor to do the same flight that I did in the video posted above. He had no texture issues and his ground was clear. Yes there were blurries in the distance but they didn't redraw and pop as he was flying over them.

I copied his P3D.cfg and confirmed the graphics card drivers and P3D version he was using and confirmed that he wasn't running anything like Nvidia Inspector. 

I'll hopefully get a chance to test tonight and will report back.

Kind Regards,

Owen

 

Share this post


Link to post

The only thing I can suggest is to have a play around with your CPU and the affinity mask settings.

Firstly I would try disabling hyperthreading in the bios, also if you have a decent CPU cooler overclock your 6700K (most will do 4.5 / 4/6 with safe voltage).

Although some folks don't recommend it, tweaking P3D's affinity mask still has benefits in helping faster texture rendering.

Share this post


Link to post
7 hours ago, kingconan said:

Out of interest yesterday I got a friend with the same graphics card as me but a worse processor to do the same flight that I did in the video posted above. He had no texture issues and his ground was clear. Yes there were blurries in the distance but they didn't redraw and pop as he was flying over them.

I copied his P3D.cfg and confirmed the graphics card drivers and P3D version he was using and confirmed that he wasn't running anything like Nvidia Inspector. 

Those with systems less powerful have to turn down their settings.  Heck, I can make everything render immediately too by lowering all of my settings at the expense of not so clear and crisp graphics on the ground.  I'd rather see the rendering of some textures and mainly get crisp and clear textures.  I have fixed a lot of my problems by turning off cloud shadows.  Although nice eye-candy, I do not need them.

EDIT:  Forgot to add, you should not use an old p3d.cfg or someone else's config. 

Best regards,

Jim

Edited by Jim Young

Share this post


Link to post
3 hours ago, Gordon Hutchison said:

Although some folks don't recommend it, tweaking P3D's affinity mask still has benefits in helping faster texture rendering.

I have never gotten AF to work and have tried many different configurations.  On the Internet some say it is no longer needed for powerful systems like the OP has.  So, when you comment out the parameters that run AF (placing two slashes in front of the parameters - //), does the rendering get bad?  I've just never heard AF ever working for anyone.  Not with FSX or P3D anyway.  People say after they employ it that it is working great but a month or two later say they still have problems.

Share this post


Link to post

I use Process Lasso to set AM with hyper threading on. 

Works beautifully. Google Steve Waite over at Code Legend and read.

Cheers,

Share this post


Link to post

Hey all,

Thanks again for your help so far. I am determined to try and find the cause of this issue.

Since upgrading my Cpu/SSD/RAM I didn't upgrade my PSU (think its 500w). Could this be causing the slow graphics performance?

Interestingly I came across a screenshot that I took last year (before I upgraded) and my textures looked sharp even into the distance.

@newtie I've read a lot about AM. Can you advise what SM I should set within P3D and what to set in Lasso? I'm running an i7 6700k with hyperthreading on.

Thanks again,

Owen

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now