Sign in to follow this  
tutmeister

XP 11 fps seems locked

Recommended Posts

Hi all,

 

After some advice please. I am running xp 11 and seem to have my fps stuck at 39 no matter what I change.

I was running with ortho and GB Pro with every slider maxed on a 4k screen on a 7600 at 4.5Ghz and a 1080 Ti and just about hitting 30fps if the weather was clear but it wasn't totally smooth with track ir so I need to up my fps a bit.

I'm now trying to hit 60fps so it syncs nicely with my screen but no matter what I turn off it won't go over 39fps. Now before you say 39 is enough, well sort of, but its more the fact that it is stuck there that is my problem as it means something is locking it. I have removed ALL add ons and tried this in the default 172, every slider down so it looks like crap and yet it is still stuck on 39( see below shot).

Any idea why it is stuck like this? 60fps should be easy with a default 11.01with this set up but what am I missing?

xpsettings.jpg

Chris

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Lower the resolution at 1920x1080. Is it still locked at 39 FPS?

Load the default KC10 (it should be one of the less performance hungry aircrafts), go to external view, and zoom all the way out until you're in outer space. Is it still locked at 39 FPS?

 

Share this post


Link to post
Share on other sites

Hi Murmur

That screenshot was actually a low Res one. Just to be sure, I went full screen at 1080p and used the old kc10. With minimum everything it was still stuck at 39fps.

 

Chris

Share this post


Link to post
Share on other sites

This could be a preferences issue. To move the preferences in X-Plane:

Open the X-Plane installation directory

Go to the Output folder / the Preferences folder.

Move all the files inside the /Preferences folder to your desktop (you can even just make a copy of the folder and place it on the desktop...it'll be safe there.  Delete the contents of the original folder

Restart X-Plane

Sage advice from the Reverend Ben here: http://developer.x-plane.com/2011/06/the-cult-of-bad-preferences/

Share this post


Link to post
Share on other sites

Just a thought Chris...  but have you tried deleting/rebuilding your prefs file in case there are any nasty remnants of something lurking within?

 

[Edit - you beat me to it Jim]

Share this post


Link to post
Share on other sites

Good advices. Moving the preferences out should allow you to establish wether the lock is due to X-Plane setting or to GPU control panel settings.

Share this post


Link to post
Share on other sites
Just now, Murmur said:

Good advices. Moving the preferences out should allow you to establish wether the lock is due to X-Plane setting or to GPU control panel settings.

I almost suggested that perhaps the OP made some settings changes in the gpu control panel, which could also be the culprit, but it doesn't hurt to troubleshoot the obvious first. :happy:

Share this post


Link to post
Share on other sites

I myself have always found XPXI to be severely FPS bound. No Idea why.

Share this post


Link to post
Share on other sites
1 minute ago, HiFlyer said:

I myself have always found XPXI to be severely FPS bound. No Idea why.

Ben's blog had a post in it a while back, whereby someone posed a similar question, to which Ben responded that (paraphrasing) "set up the sim to run at 30fps, then balance out the settings to get the best visuals and fly", which translated, meant that the days of achieving ungodly fps aren't in the cards for XP11, unlike FSX or even P3D. Monitoring your cpu and gpu limits, allows you the freedom to make changes to your settings to balance out the sim.

On my own system, my fps vary, depending on aircraft flown.  This is really the only variable that causes the fps to increase or decrease.  Aerobask's aircraft will give me 30's, while the default C172 will push upper 40's to low 50's, with all of that within default global scenery.  Add on a custom mesh/ortho, and the fps come back down.  Location is a factor as well, whereby heavy OSM data, combined with additional add-on scenery objects, can decrease the frames.  For the most part, my sim is balanced out to pump out low 30's, but the sim is still usable and stable.

I'm not sure why your sim is fps "bound", unless you have a frame limiter setting or add-on, causing the binding to occur.  One thing I made sure of, early on, was that nothing was controlling the fps, except for XP11's settings.

Share this post


Link to post
Share on other sites
10 minutes ago, Jimm said:

I'm not sure why your sim is fps "bound", unless you have a frame limiter setting or add-on, causing the binding to occur.  One thing I made sure of, early on, was that nothing was controlling the fps, except for XP11's settings.

Pretty much bound in exactly the way you mentioned, in that reducing the settings to a minimum, much as the OP noted, produces similar FPS to turning the settings up much higher. This represents a seeming FPS plateau: relatively unresponsive to user changes that in other sims would greatly affect framerate.

Or essentially, you can't generally attain high FPS in XPXI.

A bit troubling, most especially for those of us interested in VR. It also makes settings using heavy clouds a bit problematical.

I suspect a lot of people are flying only on clear days.

Share this post


Link to post
Share on other sites

Laminar Research has stated that they're working on performance improvements. They even hired new coders for that. VR will require higher FPS, and since they're also targeting VR usability...

Share this post


Link to post
Share on other sites

Ok I have deleted all prefs and am running xp in low res with default scenery only in the 172 with every slider at min but still stuck at 39.

 

Just to point out, I'm not after crazy high fps, I'd just like to have them a bit higher for really smooth track ir. It really should be possible with this hardware so something is obviously locking it. I'll check in control centre but I did leave that all default. Failing that I might try an XP reinstall.

 

Chris

Share this post


Link to post
Share on other sites

I've found that when I want higher FPS I fall back to XPX.

XPXI is more of an eye candy thing for me, right now. And I like the new interface.

Share this post


Link to post
Share on other sites
2 minutes ago, HiFlyer said:

I've found that when I want higher FPS I fall back to XPX.

XPXI is more of an eye candy thing for me, right now. And I like the new interface.

Do what works best for you, and it's understandable if you feel that XP11 isn't up to the level of performance that you have expected, but give it time and it will.  Rome wasn't built in a day, and I know that the team at LR are working on a great many things.  Everyone has their own impressions on what makes a great simulator, and there are plenty of choices out there.  With that said though, there isn't one single go to sim that encompasses everyone's expectations and tastes, so opinions aside, the OP seems to clearly have an issue going on with the fps being locked somehow and outside of any crazy evil juju injected into the sim, I suspect that a 3rd party application is still holing control over the fps.

To the OP:  You can always post your log.txt file here and we can have a look to see if anything latent was left behind to cause the problem.

  • Upvote 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this