Sign in to follow this  
srsparky32

White texture blocks when using VR

Recommended Posts

Hey all,

I use P3D v4 developer, When i'm in the normal 2d monitor environment, everything is perfect as can be, but as soon as i put on my VR headset (Oculus Rift) i start to see these white texture squares on the ground. The only way to make them go away is to restart P3D and not use my Rift.

Does anyone know why this might be happening? Any and all ideas or opinions are welcome.

I run P3D using a Xeon E5-4650v4 and a GTX 1080Ti and 32GB of DDR4 so my hardware definitely isnt the cause.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

hmm can you post your settings - by default p3dv4 vr is broken in my book.  But lets see your settings, I might be able to help

  • Upvote 1

Share this post


Link to post

here you go. im supposing they might be too high for running VR? the thing though is that it runs smooth with those settings in VR(does lose quite a bit of FPS in high density areas w/ addon airports tho)

 

 

Share this post


Link to post

Try with FXAA off and if that does not work - try disabling dynamic lighting.  

Also - try with default config of p3dv4 and see if you still get white textures.

By the way - I assume you have Orbx installed? Re-run force-migration in FTX Central 3.  And always delete Shaders directory in C:\Users\Your Username\AppData\Local\Lockheed Martin\Prepar3D v4 after trying these setting changes.

 

  • Upvote 1

Share this post


Link to post

thanks skywolf i will try your solutions and report back.

I only have ORBX FTX NA Socal, i dont have the stratch to buy FTX Global Base yet so im still running default there.

PS on a vanilla copy of P3D with those same settings i still got white textures in VR so maybe FXAA or dynamic lighting is causing the problem. will let you know asap.

Share this post


Link to post

So i tried with FXAA off and dynamic lighting off and i still got texture glitches. i was flying over land and then water and snow texture squares started showing up. so i think going to have to hang up the Rift for P3D until lockheed martin polishes it further sadly.

Share this post


Link to post
12 hours ago, srsparky32 said:

as soon as i put on my VR headset (Oculus Rift) i start to see these white texture squares on the ground. The only way to make them go away is to restart P3D and not use my Rift.

They're called "pixels" :dry:

Share this post


Link to post
16 hours ago, MarkDH said:

They're called "pixels" :dry:

um, was that actually serious? if so, youre a numbskull. anyone with half a brain can tell what a pixel is and what an actual problem is. if youre just going to submit snarky responses to an issue, then dont even comment at all.

THIS happens when you turn on VR, and its fine if you dont touch VR. Want to say its pixels again???

Z75TP7q9c1E8iafJwovA4X0xHEXng7CZEgCKQklo


 

Share this post


Link to post
12 hours ago, srsparky32 said:

um, was that actually serious? if so, youre a numbskull. anyone with half a brain can tell what a pixel is and what an actual problem is.

As Scott Adams would say, it's not funny if I have to explain it :mellow:

Share this post


Link to post

And it's also not funny if you don't explain your joke, or whatever it was. So kinda a lose-lose situation, I'm afraid.

Share this post


Link to post

ok well this thread is about asking for a solution to my problem not making stupid jokes so again if you have nothing useful to say then just go to another topic. thanks

Share this post


Link to post

Hello Srsparky32

Do you have the Hotfix 1 Installed ?    Prepar3D v4 Hotfix 1 (4.0.28.21686)  

Share this post


Link to post
On 7/27/2017 at 1:14 AM, Poppet said:

Hello Srsparky32

Do you have the Hotfix 1 Installed ?    Prepar3D v4 Hotfix 1 (4.0.28.21686)  

Yes i do have that p3d version number. I only see the visual glitch shown in post #9 only in VR. without VR it is 100% perfect. I really wonder why im getting these glitches and its so dissapointing because its so nice to be inside the cockpit but these glitches make it unplayable in VR.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this