Dal 1

Simconnect in P3D V4

Recommended Posts

HI
I have recently rebuilt my client pc which is where my Active Sky 2016 sits. I connect to the server pc via simconnect.
I cannot get a connection. I have followed the trouble shooter and gone through all of the steps 3 times with no joy.

I have avliasoft EFB connected and it is working fine on the client. So it would appear that the sim connect is? working for EFB at least. I have tried the support desk at hifi and they suggest that i need wider sim connect support which they don't provide.

I don't know where to start with this given i have had this working before with no issues and appear to have interrupted this with a rebuild. I have checked the install of simconnect time and time again and cannot see where the problem is but here again.I am not a network expert so would welcome some help pls


Daz

  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

25 minutes ago, Dal 1 said:

HI
I have recently rebuilt my client pc which is where my Active Sky 2016 sits. I connect to the server pc via simconnect.
I cannot get a connection. I have followed the trouble shooter and gone through all of the steps 3 times with no joy.

I have avliasoft EFB connected and it is working fine on the client. So it would appear that the sim connect is? working for EFB at least. I have tried the support desk at hifi and they suggest that i need wider sim connect support which they don't provide.

I don't know where to start with this given i have had this working before with no issues and appear to have interrupted this with a rebuild. I have checked the install of simconnect time and time again and cannot see where the problem is but here again.I am not a network expert so would welcome some help pls


Daz

My first guess, have you installed legacy simconnect versions? I don't know which one AS2016 use, but it's working fine for me. You will find all versions in Prepar3D v4\redist\Interface folder. Just run every installer there, except FSX-RTM-JPN and FSX-SP1-RUS versions. They need to be installed manually for some other addons, so i think this can be your problem.

Let me know if that fixed it

Share this post


Link to post
Share on other sites

Thank you so much for replying. I am so lost with this.

I uninstalled the old versions and installed the new versions as you describe so it's not that one. However happy to try any ideas you have?

 

Daz

Share this post


Link to post
Share on other sites

Firewall block?  I would also do an AS16 Repair by right clicking on the AS16 installer, selecting install with Admin Privileges.

Best regards,

Jim

Share this post


Link to post
Share on other sites

HI

   I have taken the fire wall down and opened up all the ports just in case. 

I have done the admin reinstall with admin privileges. No change.

Kepp the ideas coming. I am determined to crack this

 

cheers

Daz

Share this post


Link to post
Share on other sites

Daz

Try resetting the sharing privileges on your server pc - that's caught me out before with as next etc.

John Rooum

Share this post


Link to post
Share on other sites
31 minutes ago, FOD said:

Daz

Try resetting the sharing privileges on your server pc - that's caught me out before with as next etc.

John Rooum

Thanks

    I have just tried that . No joy...

keep the ideas coming please

 

thanks again

Share this post


Link to post
Share on other sites

I had the same problem, now it works, but sometimes I have to restart my server PC to connect to AS. I run Aivlasoft Vpilot and VA client my client and they all connect fine.
I can not get any connection If I connect to my local network via lan, if using WIFI  it works..
I belive windows 10 have some issue regards to home network..

Have you installed ASConnet on both computers?

Be sure to have simconnec-cfg in your document folder on your client PC .

I followed this tutorial to make it work:

 

Share this post


Link to post
Share on other sites
32 minutes ago, Olmba said:

I had the same problem, now it works, but sometimes I have to restart my server PC to connect to AS. I run Aivlasoft Vpilot and VA client my client and they all connect fine.
I can not get any connection If I connect to my local network via lan, if using WIFI  it works..
I belive windows 10 have some issue regards to home network..

Have you installed ASConnet on both computers?

Be sure to have simconnec-cfg in your document folder on your client PC .

I followed this tutorial to make it work:

 

Thanks

I have used this tutorial too and followed it to the letter. I don't have wifi capability on my two pc's to follow your next step

Share this post


Link to post
Share on other sites

HI 
I have simconnect.xml in the following location


C:\Users\daz\AppData\Roaming\Lockheed Martin\Prepar3D v4 ( this is the P3d V4 machine)


with the following content

<?xml version="1.0"?>

-<SimBase.Document version="1,0" Type="SimConnect">

<Descr>SimConnect</Descr>

<Filename>SimConnect.xml</Filename>

<Disabled>False</Disabled>


-<SimConnect.Comm>

<Disabled>False</Disabled>

<Protocol>IPv4</Protocol>

<Scope>global</Scope>

<Address>192.168.1.106</Address>

<MaxClients>64</MaxClients>

<Port>500</Port>

<MaxRecvSize>4096</MaxRecvSize>

<DisableNagle>False</DisableNagle>

</SimConnect.Comm>


-<SimConnect.Comm>

<Disabled>False</Disabled>

<Protocol>Auto</Protocol>

<Scope>global</Scope>

</SimConnect.Comm>


+<SimConnect.Comm>

</SimBase.Document>




I have the .cfg file in the following location

\\XWINGRED2\Xwing Red2 C Drive\Users\dazfr\Documents (this is the client which has AS for p3dv4 installed)


with the following content 



[SimConnect]
Protocol=IPv4
Address=192.168.1.106
Port=500
MaxRecieveSize=4096
DisableNagle=0


can you spot any problems?

Daz

Share this post


Link to post
Share on other sites

Here is mine that work ..

<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <Address>192.168.38.107</Address>
    <MaxClients>64</MaxClients>
    <Port>500</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
 
 <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <MaxClients>64</MaxClients>
    <Address>192.168.38.107</Address>
    <Port>29764</Port>
    <MaxRecvSize>8192</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
  
   <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>Auto</Protocol>
    <Scope>local</Scope>
  </SimConnect.Comm>
</SimBase.Document>

 

*The last one is for PSXseeconTraffic

Share this post


Link to post
Share on other sites

Ok Guys - Update time.

I have uninstalled and reinstalled simconnect on both machines. I am now getting the sim connect status window running. I have also reset the fire walls and opened up the programme files and ports on both machines again.
I now get the following error when i open up EFB - This is new. States that the simconnect .dll is missing. I have tried to reinstall the 4 simconnect files but it doesnt resolve it. Any ideas

The is the full error script

ee the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.FileLoadException: Could not load file or assembly 'Microsoft.FlightSimulator.SimConnect.dll' or one of its dependencies. The referenced assembly is not installed on your system. (Exception from HRESULT: 0x800736B3)
File name: 'Microsoft.FlightSimulator.SimConnect.dll'
at ht.b(Boolean A_0)
at ht.t()
at fe.a()
at fe.h()
at ia.k()
at hr.b(Boolean A_0)
at ia.e(Object A_0, ItemClickEventArgs A_1)
at DevExpress.XtraBars.BarItem.OnClick(BarItemLink link)
at DevExpress.XtraBars.BarButtonItem.OnClick(BarItemLink link)
at DevExpress.XtraBars.BarItemLink.OnLinkClick()
at DevExpress.XtraBars.BarButtonItemLink.OnLinkClick()
at DevExpress.XtraBars.BarItemLink.OnLinkAction(BarLinkAction action, Object actionArgs)
at DevExpress.XtraBars.BarButtonItemLink.OnLinkAction(BarLinkAction action, Object actionArgs)
at DevExpress.XtraBars.BarItemLink.OnLinkActionCore(BarLinkAction action, Object actionArgs)
at DevExpress.XtraBars.ViewInfo.BarSelectionInfo.ClickLink(BarItemLink link)
at DevExpress.XtraBars.ViewInfo.BarSelectionInfo.UnPressLink(BarItemLink link)
at DevExpress.XtraBars.Controls.CustomLinksControl.OnMouseUp(MouseEventArgs e)
at DevExpress.XtraBars.Controls.CustomPopupBarControl.OnMouseUp(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at DevExpress.XtraBars.Controls.CustomControl.WndProc(Message& msg)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)




************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
AivlaSoft.Efb.DataProvider
Assembly Version: 1.6.10.26311
Win32 Version: 1.6.10.0
CodeBase: file:///E:/Program%20Files%20(x86)/AivlaSoft/EFB/AivlaSoft.Efb.DataProvider.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
Castle.Windsor
Assembly Version: 3.3.0.0
Win32 Version: 3.3.0.2412
CodeBase: file:///E:/Program%20Files%20(x86)/AivlaSoft/EFB/Castle.Windsor.DLL
----------------------------------------
AivlaSoft.Efb.Common
Assembly Version: 1.6.10.26311
Win32 Version: 1.6.10.0
CodeBase: file:///E:/Program%20Files%20(x86)/AivlaSoft/EFB/AivlaSoft.Efb.Common.DLL
----------------------------------------
DevExpress.Utils.v15.1
Assembly Version: 15.1.5.0
Win32 Version: 15.1.5.0
CodeBase: file:///E:/Program%20Files%20(x86)/AivlaSoft/EFB/DevExpress.Utils.v15.1.DLL
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
Castle.Core
Assembly Version: 3.3.0.0
Win32 Version: 3.3.3.2300
CodeBase: file:///E:/Program%20Files%20(x86)/AivlaSoft/EFB/Castle.Core.DLL
----------------------------------------
Desaware.MachineLicense40
Assembly Version: 2.0.0.0
Win32 Version: 2.0.5.6
CodeBase: file:///E:/Program%20Files%20(x86)/AivlaSoft/EFB/Desaware.MachineLicense40.DLL
----------------------------------------
System.Core
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
DevExpress.Data.v15.1
Assembly Version: 15.1.5.0
Win32 Version: 15.1.5.0
CodeBase: file:///E:/Program%20Files%20(x86)/AivlaSoft/EFB/DevExpress.Data.v15.1.DLL
----------------------------------------
Accessibility
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
DevExpress.XtraEditors.v15.1
Assembly Version: 15.1.5.0
Win32 Version: 15.1.5.0
CodeBase: file:///E:/Program%20Files%20(x86)/AivlaSoft/EFB/DevExpress.XtraEditors.v15.1.DLL
----------------------------------------
System.Data
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_32/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
DevExpress.XtraGrid.v15.1
Assembly Version: 15.1.5.0
Win32 Version: 15.1.5.0
CodeBase: file:///E:/Program%20Files%20(x86)/AivlaSoft/EFB/DevExpress.XtraGrid.v15.1.DLL
----------------------------------------
System.ComponentModel.DataAnnotations
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.ComponentModel.DataAnnotations/v4.0_4.0.0.0__31bf3856ad364e35/System.ComponentModel.DataAnnotations.dll
----------------------------------------
DevExpress.XtraBars.v15.1
Assembly Version: 15.1.5.0
Win32 Version: 15.1.5.0
CodeBase: file:///E:/Program%20Files%20(x86)/AivlaSoft/EFB/DevExpress.XtraBars.v15.1.DLL
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 10.0.0.0
Win32 Version: 14.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System.Xml.Linq
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll
----------------------------------------
System.Security
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Security/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Security.dll
----------------------------------------
System.Management
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Management/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Management.dll
----------------------------------------
Microsoft.GeneratedCode
Assembly Version: 1.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
UIAutomationClient
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/UIAutomationClient/v4.0_4.0.0.0__31bf3856ad364e35/UIAutomationClient.dll
----------------------------------------
UIAutomationTypes
Assembly Version: 4.0.0.0
Win32 Version: 4.6.1590.0 built by: NETFXREL2
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/UIAutomationTypes/v4.0_4.0.0.0__31bf3856ad364e35/UIAutomationTypes.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


I am way out of my depth now. Really appreciate anyones help..

Daz

Share this post


Link to post
Share on other sites

 Have you checkout this video on connecting 2 pc together may help some way, although it was done for FSX!

sorry if no use.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now