Sign in to follow this  
mopperle

PC12 getting out of control

Recommended Posts

I've done numerous flight now, but sometimes during flight the P12 suddenly gets totally out of control. Example:

flying on a loaded flightplan, after take-off at around 1000ft turn on AP, set cruise alt to 20.000 ft, climbrate 1800ft, everything ok but then aircraft suddenly starts to climb till stall warning comes up, aircraft turns elsewhere, looses flightpath. After turning off AP and flying manually, i can stabilize the aircraft somehow, but when turning on AP again, same mess, weired climb behaviuor and never finds back to the flightpath and finally I have to abort the flight. No errors/warnings on the CAWS come up.

Flying in P3Dv4.1 under Windows 10

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Check your elevator trim..  you may very well have stalled the airplane with 1800 ft per min climbrate.

Share this post


Link to post
Share on other sites

Flaps?

Torque?

Trim?

I'll usually set about 37-39 psi on the torque for take off power, flaps 15 and about -3 on the elevator trim for take off. If I firewall the throttle on take off I'll get 2000+ FPM climbs and if I don't trim (a lot) at about 1200 AGL what you're experiencing is not uncommon.

Share this post


Link to post
Share on other sites

Checked this on another flight and the elev trim indeed behaves weird with up to +10°

Strange thing is that I could use a climb rate of 2000ft without problems, speed was in all cases between 130 and 150 kts

Share this post


Link to post
Share on other sites

Torque was as you said around 39 psi, flaps 15, but retracted above 110kts, but will watch trim closer on next flight.

but strange thing is that it also happened in level flight.

Share this post


Link to post
Share on other sites

+10° on trim at take off?

Hmm. I don't think I've ever needed positive elevator trim on any phase outside of short final.

Do you ever have flights without an issue? Did it just start happening? Any chance or recording a short clip of it happening?

Weather on/off, same issue?

Share this post


Link to post
Share on other sites

No, trim at TO was zero; did another flight today; climbed with 1500ft and 150kts, 37psi, watched trim which went down to -7, AP on, NAV hold on, all good, but then it started banking to the left and right more and got out of control, trim went up in this case up to +10.

And yes I had many flights with out issues, always the same: start sim, load a fligtplan with real weather (Active Sky for P3dv4)

Share this post


Link to post
Share on other sites
7 minutes ago, mopperle said:

...but then it started banking to the left and right more and got out of control, trim went up in this case up to +10.

What altitude?  The left/right banking starts at 150kts? If the trim goes from -7 to +10 it's impossible that the IAS stays at 150kias and the ROC at 1500ft/min.

Tried without active sky ? (as this sometimes doesn't play nice with add-on planes?

Share this post


Link to post
Share on other sites

I had exactly the same problem. After installing GTN 750, it disappeared completely. The autopilot in PC12 appears to be faulty.

Peter

Share this post


Link to post
Share on other sites

What disappeared? The problem?  Don't have the GTN750 (or any other add-on) and never experienced any AP problems.

Share this post


Link to post
Share on other sites
1 hour ago, J35OE said:

If the trim goes from -7 to +10 it's impossible that the IAS stays at 150kias and the ROC at 1500ft/min.

Of course it does not stay at those numbers, as the aircraft gets totally crazy and due to the strange trim settings it starts to climb until stalling. When turning off the AP i have to put full pressure on the stick to prevent the aircraft from climbing (due to the strange trim value).

But maybe the problem lies elsewhere, cause when I closed the sim, restarted P3D and repeated the flight everything was ok.

I'm currently investigating something different and will report back

Share this post


Link to post
Share on other sites
10 minutes ago, mopperle said:

Of course it does not stay at those numbers, as the aircraft gets totally crazy and due to the strange trim settings it starts to climb until stalling. 

You still haven't answered the vital question:  What's the speed when the left/right banking (wing dropping?) starts. 

It's difficult to troubleshoot without any screenshots or a more precise description.

I'm pretty sure that the PC-12 doesn' get crazy (whatever this means) due to the 'strange' trim setting.

It's much more likely that you are e.g. loosing speed (and torque?) and the AP naturally starts to trim nose up to compensate.

Icing? wind shifting suddenly from head to tailwind? temp change?

Share this post


Link to post
Share on other sites
1 hour ago, J35OE said:

What disappeared? The problem?  Don't have the GTN750 (or any other add-on) and never experienced any AP problems.

Yes, the problem disappeared. With the standard GPS that comes with the PC12, it regularly happened that the plane veered off course in the middle of a flight. It could be (I can't remember all the details) that the autopilot did not pass precisely over a waypoint and then reacted too strongly to get back to that waypoint. The plane went into a steep corner and then spiralled out of control. With the GTN 750 that never happened again, and hand-flying was never a problem.

I should add that I observed this in P3D v3.x. I never flew the plane in P3D v4 without the GTN 750.

Peter

Share this post


Link to post
Share on other sites

Did meanwhile make 3 flights (each over 3 hrs) without any problems and today, again same strange behaviour. Suddenly during climb with 1200ft/min at 150 kts IAS at around 15000 ft aircraft suddenly started to turn ending in uncontrollable turns, climbs till stalling. Again, trim seemed to be the problem: during the normal climb, the trim was around -4 and during the strange behaviour again I noticed +12!

I'M out of ideas now, especially as I can not reproduce it.

@Peter: do you use the GTN750 under P3Dv4.1?

Share this post


Link to post
Share on other sites
50 minutes ago, mopperle said:

 Again, trim seemed to be the problem: during the normal climb, the trim was around -4 and during the strange behaviour again I noticed +12!

Again, it's impossible to do any troubleshooting without any screenshot or a useable description.

Trim can't be the problem. It's the result of something that has obviously gone wrong before.

Furthermore trim doesn't jump from -4 to +12, it takes a while so it would be interesting to know when the trim runaway starts.

Before/after the turning starts? Why is the turn uncontrollable? What's the torque and IAS when the turning/trim runaway starts. etc. etc.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this