blackbird7

P3D v4.1 screen tearing considerably worse without Vsync?

Recommended Posts

Not sure if this has already been discussed.  I did quick look in the forums and didn't see anything.

I have traditionally set my P3D internal display settings to 59 fps with Vsync OFF.  This has given me the best performance with a relatively stutter free experience.  For reasons I don't fully understand, unlimited frames have always caused more stutters.  I'm running an i7-7700K, GTX 1080Ti w/latest driver, and a 60 Hz monitor.  After updating from v4.0 to 4.1, I noticed that my screen tearing was horrid with my previous settings.  They are bad at 59 fps and even worse at unlimited frames.  Enabling Vsync does remove the screen tearing, but I am curious what has changed or if I'm the only one who has experienced this?  I would be interested in your thoughts.

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I have made the same experience. Never had to use Vsync until 4.1.

Share this post


Link to post

I had significant vsync issues with the 388.00 driver and my 1080TI, I went back to 387.92. Not sure if I'm going to try 388.13 or not.

Share this post


Link to post

Ah, ok, thanks for the insight.  I'm glad that I'm not the only experiencing this.  Maybe my issue is related to the recent driver if you were having issues with 388.00.

Share this post


Link to post

And FWIW, I have had no tearing at all for several P3D versions running with no triple buffering and no vsync. 

 

Vic

Share this post


Link to post

Hi,
I had terrible screen tearing too, but not after going to v4.1 but after the W10 fall creators update which I only received here in England a fortnight ago. Never had the problem before in 4.1 or any previous version.
It made using TrackIR unbearable, but yes although using Vsync helped I was curious why it didn't tear in windowed mode and as I have always been on unlimited frames with no Vsync and stutter free I wanted to know why.
After days of frustration for some reason I right clicked the P3D.exe on the desktop, clicked properties > compatibility and ticked disable fullscreen optimisations. Instant cure! Happy days. 
I've also disabled W10 game mode just in case. Yours may be a different problem but worth a try if you haven't already. Hope it helps because it ruined flying for me for a week.
 

  • Upvote 2

Share this post


Link to post
8 hours ago, Chairflyer73 said:

...
After days of frustration for some reason I right clicked the P3D.exe on the desktop, clicked properties > compatibility and ticked disable fullscreen optimisations. Instant cure! Happy days. 
I've also disabled W10 game mode just in case. Yours may be a different problem but worth a try if you haven't already. Hope it helps because it ruined flying for me for a week.
 

This seems to be a useful tip. At least it helped on my setup.

  • Upvote 1

Share this post


Link to post

 

10 hours ago, Chairflyer73 said:

Hi,
I had terrible screen tearing too, but not after going to v4.1 but after the W10 fall creators update which I only received here in England a fortnight ago. Never had the problem before in 4.1 or any previous version.
It made using TrackIR unbearable, but yes although using Vsync helped I was curious why it didn't tear in windowed mode and as I have always been on unlimited frames with no Vsync and stutter free I wanted to know why.
After days of frustration for some reason I right clicked the P3D.exe on the desktop, clicked properties > compatibility and ticked disable fullscreen optimisations. Instant cure! Happy days. 
I've also disabled W10 game mode just in case. Yours may be a different problem but worth a try if you haven't already. Hope it helps because it ruined flying for me for a week.
 

Thanks for the tip.  I will give this a try.

Share this post


Link to post
23 hours ago, blackbird7 said:

 

Thanks for the tip.  I will give this a try.

How did it go?

Share this post


Link to post

I tried your tip and you are absolutely right. Thank you so much, chairflyer73!

Jos

  • Upvote 1

Share this post


Link to post
5 hours ago, Chairflyer73 said:

How did it go?

I just tried it, and it worked like a charm.  Thank you! 

Share this post


Link to post

For me, it dosen't helps, it's a case of new kind of stutter, nothing more.

I noticed also that W10 fall creators update ruins G-sync in P3Dv4.1. Before it I havent any problems with screen tearing on my spec (used G-sync). Now I cant do this, so only when I check V-sync on no any screen tearing. Pity!

Share this post


Link to post
11 minutes ago, blackbird7 said:

I just tried it, and it worked like a charm.  Thank you! 

 That's great, it's mad isn't it?  I did clean installation of drivers, reinstalled P3D client and content and TrackIR, rolled back the creators update and reinstalled, when all I had to do was tick a box on the desktop. Got to love simming!

13 minutes ago, YoYo said:

For me, it dosen't helps, it's a case of new kind of stutter, nothing more.

I noticed also that W10 fall creators update ruins G-sync in P3Dv4.1. Before it I havent any problems with screen tearing on my spec (used G-sync). Now I cant do this, so only when I check V-sync on no any screen tearing. Pity!

Sorry YoYo, keep searching. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now