scottb613

Power On Now [solved]

Recommended Posts

Hi Jean-Luc,

Finally had a little time to mess with this... As per the dark screen we spoke of before... I installed the new RC update last night - still my unit in the PC12 would not power up... Then I installed the trainer software via the RXP installer and it did power up fine - it appears your gauge needs the trainer included with your installer - regardless of if you had the one F1 needed installer previously...

Thanks for once again bringing us excellent products...

Continuing to evaluate...

Regards,

Scott

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Scott, thank you for the feedback. There could be a regression problem in our code since it is supposed to support v6.41, v6.21 and v6.11 but it could also be a problem with the trainer files when used with the other solution, should they ever mess with the trainer files for their needs.

Our solution keeps all files genuine and never mess with the trainer installation, I can't say for others.

We'll review the code path with 6.21 at least and let you know.

  • Upvote 1

Share this post


Link to post
Share on other sites

I how have this issue. Today my RXP GTN750 has gone dark.  I messed with it for a while, then uninstalled completely. Then reinstalled.  Still dark. Today is also the first time I encountered an AV warning. File quarantined was the rxpGtnSim32.dll.  rxpGTN-750-FSIM.exe was also quarantined today.  I have added both to my AV exclusions list and fully rebooted system.  Checked after reboot and both files do now appear in my exclusions.  Loaded FSX. Still dark.  Reverted to my panel.cfg file for the other brand GTN750 and it works.  Scratching my head.  Should I uninstall the trainer and reinstall?  How do I do that. The recent update made no mention of the Garmin trainer.

Share this post


Link to post
Share on other sites

In the meantime I have installed GTN Trainer 6.41 and it is working standalone. However my GTN 750 in FSX is still inop.  Cold and dark.

Share this post


Link to post
Share on other sites

I upgraded to the latest version of the RXP GTN750 at the end of last week.

Then over the weekend I too had Windows Defender flag rxpGtnSim32.dll as infected and my RXP GTN750 went dark in p3d (despite the dll being restored). Throughout this the standalone trainer continued to work.

To get the RXP GTN750 working again I only had to reinstall RXP software.

 

Share this post


Link to post
Share on other sites

Hi, it is possible there is an issue with GTN Trainer 6.21 and RXP GTN 2.4.10, that we didn't uncover during v2.4.10 RC. We'll further review this tomorrow and let you know.

@fppilot There shouldn't be any problem with GTN Trainer 6.41. Have you changed anything since the last time it worked or is the only change Windows updates? 

Please note GTN Trainer 6.41 is supported since v2.4.8, and if it is already installed, the RXP GTN installer tells you about this in the page displaying right before it copies the files to the hard drive.

Share this post


Link to post
Share on other sites

The only thing I did today was start to apply the knobs and buttons .xml from Ryan, and that only in the panel.cfg file of the Real Air Turbine Duke v2.  I made the panel.cfg edits and the appropriate "0 0 0 8" entry in the .xml file before positioning it in its subfolder.  When I loaded the RA TDv2 following that is when I first experienced the cold and dark GTN750.  Not sure what all that .XML file might do. Is there any way it may have affected more than the TDv2 I was working on?

The RA TDv2 is the only aircraft I made changes to. But the RXP GTN750 is cold and dark in all 8 aircraft for which I have it configured.  Of note is that after updating to the latest release yesterday, I confirmed working RXP GTN in all 8 of those aircraft. (BTW I only have the RXP GTN 750, no 650).  

Not sure what version trainer I had yesterday. After the issue surfaced today I started the trainer standalone and it too stayed dark.  After uninstalling the RXP GTN 750 and reinstalling to no avail, I followed a link you provided in the xPlane GTN support forum and DL and applied the 6.41 trainer. Did not uninstall it first so assume it overwrote the previous.  Current is confirmed as v6.41. Still dark. I do not know the version of the trainer that I had prior to that, but expect it was the trainer version installed at the time of my original RXP GTN installation in early November.

 

Share this post


Link to post
Share on other sites
2 hours ago, RXP said:

There shouldn't be any problem with GTN Trainer 6.41. Have you changed anything since the last time it worked or is the only change Windows updates? 

After running through the steps I completed after experiencing the issue today, as earlier stated, I have 6.41 in place. The issue is current after that. 

I am not aware of any windows updates today and thus did not mention any, so I am perplexed by that question.

Share this post


Link to post
Share on other sites

Hi Frank, GTN Trainer 6.41 installs side-by-side with previous GTN trainers.

6.41 installs in "C:\Program Files (x86)\Garmin\Trainers\GTN\bin\"
previous in "C:\Progran Files (x86)\Garmin\GTN Trainer\GTN\sys\sim\"

Provided you haven't uninstalled the previous, you should have both on the drive. If this is the case, can you let me know which previous version it is?

Share this post


Link to post
Share on other sites
4 hours ago, RXP said:

Hi Frank, GTN Trainer 6.41 installs side-by-side with previous GTN trainers.

6.41 installs in "C:\Program Files (x86)\Garmin\Trainers\GTN\bin\"
previous in "C:\Program Files (x86)\Garmin\GTN Trainer\GTN\sys\sim\"

Provided you haven't uninstalled the previous, you should have both on the drive. If this is the case, can you let me know which previous version it is?

My installation does not appear in those paths.  I do not have a folder "C:\Program Files (x86)\Garmin\Trainers" and thus no subfolders under that path.  I also do not have a folder there named "C:\Program Files (x86)\Garmin\GTN Trainer"

My installation appears to be as: "C:\Program Files (x86)\Garmin\RXP GTN_Trainers\Launcher\Aviation_Trainer_Launcher.exe".  When I start that .exe it loads a launcher from which I can start the trainer, and the trainer is 6.41.0.  It powers up and operates as a standalone.

6.41.0 also loads from C:\Program Files (x86)\Garmin\RXP GTN_Trainers\GTN\bin\GTN Simulator.exe.  Not sure what the relationship is to the launcher above.  This instance loads but does not power up.

For comparison my RXP Garmin GNS trainer appears to be in: "C:\Program Files (x86)\Garmin\GNS Trainer\"  The only other GTN related folder(s) are related to F1 and the GTN Trainer Lite v5.13.0 and is in C:\Program Files (x86)\Garmin\GTN Trainer Lite\GTN\sys\sim\

I ordered and downloaded the GTN750 on 11/9/17 and the exe files for the Launcher and Trainer are 10/3/17.  What trainer version would have been associated at that time?

My GTN worked fine until yesterday.

 

Share this post


Link to post
Share on other sites

Hi, I confirm there is a bug introduced in the latest v2.4.10 which crashes the GTN Trainer v6.21. It is fine with GTN Trainer 6.41 though.

A fixed update is on its way today or tomorrow the time we validate a few other related things.

In the meantime, I'm wondering about the installation path:
"C:\Program Files (x86)\Garmin\RXP GTN_Trainers\GTN\bin\GTN Simulator.exe"

Have you manually set the destination folder in the GTN Trainer 6.41 installer when prompted?

Can anyone cross check if they have the same path on their drive, or if it is the normal:
"C:\Program Files (x86)\Garmin\Trainers\GTN\bin\GTN Simulator.exe"

.

Share this post


Link to post
Share on other sites

My path is different. C:\Program Files (x86)\Garmin\Trainers\GTN\bin\GTN Simulator.exe

GTN Simulator.exe opens a non operating 650GTN and a trainer navigation control.

Share this post


Link to post
Share on other sites

@bills511 sorry for the typo, normal path now edited.

as for launching the GTN 6.41 standalone, it requires using the launcher instead.

Share this post


Link to post
Share on other sites
45 minutes ago, bills511 said:

My path is different. C:\Program Files (x86)\Garmin\Trainers\GTN\bin\GTN Simulator.exe

GTN Simulator.exe opens a non operating 650GTN and a trainer navigation control.

Bill, I believe the standalone trainer starts from a launcher in a separate folder.

 

 

Share this post


Link to post
Share on other sites
1 hour ago, RXP said:

In the meantime, I'm wondering about the installation path:
"C:\Program Files (x86)\Garmin\RXP GTN_Trainers\GTN\bin\GTN Simulator.exe"

Have you manually set the destination folder in the GTN Trainer 6.41 installer when prompted?

Yes. I believe I spec'd a path at the time of first installation to make sure it differentiated from the F1's GTN Trainer installation.  Again, I am clearly seeing version 6.41.0 when I use the launcher, and the properties of the GTN Simulator.exe file confirm that.   My RXP GTN 750 was working prior to yesterday and again the only change I made was an attempt to use Ryan and gang's mod for buttons and knobs.  And that only for the Real Air TDv2.  My GTN is dark in all aircraft it is installed into.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now