Holdit

Problems with Carenado and Real Air with V2

Recommended Posts

Hello,

I (possibly unwisely) purchased the V2 GNS 430, taking advantage of the sale, without doing the necessary homework, with a view to also getting the 530 if all went well. Unfortunately, it hasn't. Now I find that I can't install it into any of my RealAir aircraft, which would be the most important ones, along with a some Carenado aircraft. RealAir doesn't see the RXP GPS unit as being installed at all, and greys out all of its options.

I know I can get a refund, but before going down that road I'd like to see if there is a solution for this, or if the license for the 430 V2 will cover the legacy model also, which I'd be quite happy with.

Please advise...

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I am sure that you can make it work.. although it may take a bit of manual effort.  Which flightsim are you using?

  • Upvote 1

Share this post


Link to post
Share on other sites

Bert do you ever get time to fly between helping fix things? :biggrin:

I'm not afraid of some manual tweaking where required. I'm running FSX:SE.

Thanks for the quick response...

Share this post


Link to post
Share on other sites

Try putting a dummy RXPGNS.dll file in the FSX\Gauges folder.

That should fool the RealAir config app.

If that works, use the RXP config app, from the Addons menu in FSX, to replace the gauges..

Or, edit the panel.cfg file by hand.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi, first let me reassure you it was a wise choice! Not only because the GNS V2 is way above our legacy GNS, but also because we don't know if we'll make any other discount soon!

Now, back to the integration, there is something quite easy you can try:

1) Duplicate the rxpGNS2.gau file to rxpGNS.gau (this will make aircraft config tools happy).

2) Configure the aircraft for the RXP GNS and load aircraft.

3) The Reality XP GNS V2 includes a gauge name aliasing technology (in short, makes FltSim believe there are GaugeA, GaugeB and GaugeC while in fact there is only GaugeA), and it supports the legacy gauge names: a panel.cfg referring to a legacy gauge will find the expected gauge name automatically (only because the gauge file has been renamed from rxpGNS2 to rxpGNS of course).

4) Once in the aircraft, SHIFT + right click the top edge of the GNS V2 opens the settings.

   There, you just have to enable Gauge Options | Advanced | Use Legacy L:Vars

   These legacy vars were used only to sync the 3D knobs with the 2D popup gauge knobs, as well as the power state (is the GNS on or off)

 

This shall work properly, except maybe the gauge in the panel will be slightly off-ratio (width vs height) because the GNS V2 dimensions are to scale with the real device, the legacy ratio was slightly off.

  • Upvote 2

Share this post


Link to post
Share on other sites

If you really want to have some fun with the Duke configuration I found a different method. This allowed me the ability to select the GTN's in order to create positions for the 650/750 since I never had the F1 gauges.

Open the ...\Turbine Duke V2 P3D4\RealAir\duketv2p3d2\AutoPlay\Files Config.ini file.

Find:

[Radios]
gps1.X=10
gps1.Y=1
gps2.X=0
gps2.Y=6
nc1.X=0
nc1.Y=7
nc2.X=20
nc2.Y=3
adf.X=20
adf.Y=4
ap.X=10
ap.Y=2
audio.X=0
audio.Y=5
xpndr.X=0
xpndr.Y=8
gps1.type=750  Change this to 500 or 650, etc     This allows you to move the other radios around with the Dukes wonderful graphical gauge configurator.
gps2.type=NoGps Same here 650 or a second 750
ncShow=0
xpndrShow=0

 

  • Upvote 1

Share this post


Link to post
Share on other sites
On 11/25/2017 at 8:07 PM, RXP said:

Hi, first let me reassure you it was a wise choice! Not only because the GNS V2 is way above our legacy GNS, but also because we don't know if we'll make any other discount soon!

Now, back to the integration, there is something quite easy you can try:

1) Duplicate the rxpGNS2.gau file to rxpGNS.gau (this will make aircraft config tools happy).

2) Configure the aircraft for the RXP GNS and load aircraft.

3) The Reality XP GNS V2 includes a gauge name aliasing technology (in short, makes FltSim believe there are GaugeA, GaugeB and GaugeC while in fact there is only GaugeA), and it supports the legacy gauge names: a panel.cfg referring to a legacy gauge will find the expected gauge name automatically (only because the gauge file has been renamed from rxpGNS2 to rxpGNS of course).

4) Once in the aircraft, SHIFT + right click the top edge of the GNS V2 opens the settings.

   There, you just have to enable Gauge Options | Advanced | Use Legacy L:Vars

   These legacy vars were used only to sync the 3D knobs with the 2D popup gauge knobs, as well as the power state (is the GNS on or off)

 

This shall work properly, except maybe the gauge in the panel will be slightly off-ratio (width vs height) because the GNS V2 dimensions are to scale with the real device, the legacy ratio was slightly off.

(1) and (2) don't work for the RealAir Duke V2 in P3Dv4.  I am using Bert's mode with the default GPS500 unit rather than the custom 3D RealAir has but its config tool refuse to allow me to configure.  Is Bert's mod the only option?

Share this post


Link to post
Share on other sites
2 hours ago, Anxu00 said:

(1) and (2) don't work for the RealAir Duke V2 in P3Dv4.  I am using Bert's mode with the default GPS500 unit rather than the custom 3D RealAir has but its config tool refuse to allow me to configure.  Is Bert's mod the only option?

I've posted a modification for the Duke in The Official Panel Configuration Thread.

https://www.avsim.com/forums/topic/518703-official-panel-configuration-thread/?page=3#comment-3760213

Share this post


Link to post
Share on other sites
6 hours ago, bills511 said:

I've posted a modification for the Duke in The Official Panel Configuration Thread.

https://www.avsim.com/forums/topic/518703-official-panel-configuration-thread/?page=3#comment-3760213

Thanks Bill.  However my post was for the Piston Duke V2 :mellow: Anyway, I am using Bert's mod which also use the GNS500 default, which is also what you use for the Turbine Duke V2.  My point was that if we can figure a way to get the RealAir Config tool to recognize the new RXP GNS v2, then I could set up the VC to have two GNS530W for example.  Until now, it does not matter what I do: renaming the rxpGNS2.dll to rxpGNS.dll or rxpGNS.gau and dropped it into the gauges, or main sim folder, or in RealAir folder, none works, the config tools refuse to acknowledge.  I even changed the path for FSX in the resgistry to point to P3D!  So if someone figures out how to get the RealAir config tool to work, please share.

Cheers

Share this post


Link to post
Share on other sites
On 11/25/2017 at 7:53 PM, Bert Pieke said:

Try putting a dummy RXPGNS.dll file in the FSX\Gauges folder.

That should fool the RealAir config app.

If that works, use the RXP config app, from the Addons menu in FSX, to replace the gauges..

Or, edit the panel.cfg file by hand.

hi Bert, for FSX yes, not with P3D.  Sadly I don't have FSX installed anymore.

Share this post


Link to post
Share on other sites

Try this :

1- Open Options.xml. You will find it at "YourFlightSimulatorFolder\RealAir\dukeb60v2\AutoPlay\Files"

2- look for the line :

"<Value>(G:Var1) 0 == if{ 0 (&gt;L:dukeRadioConfig,number) }</Value>"

3- Change to :

"<Value>(G:Var1) 0 == if{ 10 (&gt;L:dukeRadioConfig,number) }</Value>"

4- Save the file

5- Open "Config Panel.exe" and see if it is what you want. 

6- Close "Config Panel.exe" WITHOUT SAVING.

7- If it is not the layout you want, good back to step 3 and try any other number like 20, 30, etc.

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now