Sign in to follow this  
gianmarcoragazzoni

Problem buying online PMDG

Recommended Posts

Hi, I wanted to report a problem regarding the online purchase of your products.
I can not buy the 737NGX for Prepar3D, arrived at the payment page and clicking on the "checkout" button to pay with a credit card appears a page with the word "empty cart".
I would not use Paypal because of the disadvantageous Dollar / Euro exchange rate.
Is the purchase only through Paypal or directly by credit card?
Thank you.

Gianmarco Ragazzoni

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You should be able to use your credit card as I've done it before, so not really sure why it's not working for you. In any event, you may need to submit a support ticket since the forums are primarily user to user support, and we as users can't really do anything here.

Share this post


Link to post
Share on other sites
8 hours ago, gianmarcoragazzoni said:

Hi, I wanted to report a problem regarding the online purchase of your products.
I can not buy the 737NGX for Prepar3D, arrived at the payment page and clicking on the "checkout" button to pay with a credit card appears a page with the word "empty cart".
I would not use Paypal because of the disadvantageous Dollar / Euro exchange rate.
Is the purchase only through Paypal or directly by credit card?
Thank you.

Gianmarco Ragazzoni

Try to logout and relogin. Does the cart shows the product? 

Share this post


Link to post
Share on other sites

I also have the same problem.

When I press "Checkout" I receive this message:

"Your cart is empty.
Continue Shopping"

 

Santiago V.

Share this post


Link to post
Share on other sites
18 minutes ago, svfranchini said:

I also have the same problem.

When I press "Checkout" I receive this message:

"Your cart is empty.
Continue Shopping"

 

Santiago V.

Did you try what Chris recommended?

Share this post


Link to post
Share on other sites

Gents,

We had a rash of similar reports last month during the server transition.  When we resolved the issue, we did have a trailing number of complaints on the issue that were resolved once customers dumped the cache in their browser.  (usually CTRL+R but your mileage may vary...)

I'd recommend that route- as it seems to resolve the issue quickly.  If not, let us know and I'll have tech investigate...

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this