snowyuk

Steering The NGX - Problem On The Ground

Recommended Posts

Hi all, I am using some ch pro pedals within the p3d v4.1 sim. I also have SPAD NX which I use to calibrate all my controls and Saitek panels. FSUIPC is also running (paid version). I have the (enable controllers) in the p3d options unchecked. the problem is that when I steer the aircraft left or right by pushing the pedals, the wheel turns but then straightens up again as soon as my foot stops moving, so if I push the pedals full left, and then hold my position, the wheel straightens up until I waggle my foot a bit which makes it turn again until I stop moving and it straightens up again. its not holding a value for some reason. looks like I am practicing riverdance when I need to make a sharp turn.

any ideas please. Thanks for looking.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Posted (edited)

Hello,

Do you have the autorudder setting unchecked in the P3D settings?

Also, be informed that PMDG requires anyone to sign all their post with full names in their forums (cf. forum rules).

Edited by Budbud

Share this post


Link to post
Share on other sites

I have to admit I can't steer the thing with pedals on the ground. I use a second joystick to operate the nose wheel steering as I'm used to doing that for real and the pedals only give a very limited steering effect of 7' or so.

It is not SIM related I suspect, more your hardware and interface software.

Share this post


Link to post
Share on other sites

I use CH pedals to steer the NGX on the ground, and have no problems. 

Share this post


Link to post
Share on other sites

I had a real similar problem with the tdfi b717 but it was with the ailerons and elevators.   They would always snap back to the centered position unless I “pumped” the yoke.  Turned out to be an issue with my FSUIPC (paid).  I made a new control configuration - airplane specific profile and it eliminated the issue

Share this post


Link to post
Share on other sites
Posted (edited)

p3D controllers MUST be enabled in the options but you need to delete the assignments of the rudders for ALL found axes. (P3D assigns main axes automatically to all found controllers, even to virtual axes like gaming mouses and other game controllers. Be pedantic!!) 

I suppose this to fix your issue. 

Edited by Ephedrin

Share this post


Link to post
Share on other sites

MOD NOTE:

Thread title modified to set normal case. Please do not use all caps, as IT COMES ACROSS LIKE YOU'RE YELLING, and it's difficult to read.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now