Recommended Posts

Hello, 

I was recently changing some settings with my Logitech controllers and my screen started flickering black. I have searched for similar posts but they seem to be concerned largely with overclocking. I have also switched off shadows being cast as other suggested and yet the problem persists.I am new to a lot of this and I've generally stayed away from taking the visuals too high but this seems to have occurred without me changing any visual settings. I have confirmed that it is limited to the P3D window when minimised. It occurs randomly every few seconds at inconsistent but regular intervals. 

I have a K7700i Processor with a GTX1070 card and nothing is overclocked. Could there be issues with my hardware without tinkering?

Any suggestions?

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hmm.. I just noticed some flickering as well when flying in windowed mode. Never had that before actually. I've done nothing to the computer besides letting W10 do the regular updates...

The flickering is quite annoying tbh.

Share this post


Link to post

Just tried flying tonight, loads of problems loading p3d, now im finally in i have a black flicker also, happening more often in outside view.

Share this post


Link to post

Did you have the problems after Windows 10 version 1803 update and do you use  multi GPU / multi monitor?

I had similar problem in P3D V3 and could reduce it by enabling Triple buffering and Vsync in the settings 

Also reducing Target Framerate could help

 

 

 

 

 

Share this post


Link to post

I had the flickering also after the Windows updates, but installing the latest nvidia driver fixed it.

Share this post


Link to post

Ok thanks people, I will try the above and see if that fixes things, thanks for you help.

 

Share this post


Link to post

Updating the driver alone did not fix the problem however enabling triple buffering and also limiting the frame rate to 60Hz seemed to do the trick, thank you people.

Share this post


Link to post

I had the same problem, and setting V-sync (Options > Graphics > Display > Frame Rate Controls > VSync)=On fixed it right away. 🙂

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now