Sign in to follow this  
denny

rift wont load

Recommended Posts

Got the rift, Will not load in p3dv4. Error message VrlnitError _Lnit _HmdNotFound    Have done the following  CFG shows loadvirtualreality=1  enablevirtualrealityonstartup=1  In oculus settings have set up Allow apps that have not been reviewed by Oculus to run on Rift checked. Rift runs great on apps I have downloaded from oculus website.  I tried  reinstalling the client from  Lockheed but did not help. Any one using the rift in p3dv4 please advise. Maybe I have missed something along the way.   I am using a 1080 nvidia card cpu is at 4.1 . Should be good with this kind of power.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I am using the Rift in P3dV4.3 with no issues.  The only recommendation I could make is to change "enablevirtualrealityonstartup=1" to 0.  I remember having an issue when I had the enablevr set to start on startup.  Once P3D is loaded and have a plane loaded you can enable VR from the top menu.

Danny

Share this post


Link to post
Share on other sites
1 hour ago, denny said:

Got the rift, Will not load in p3dv4. Error message VrlnitError _Lnit _HmdNotFound    Have done the following  CFG shows loadvirtualreality=1  enablevirtualrealityonstartup=1  In oculus settings have set up Allow apps that have not been reviewed by Oculus to run on Rift checked. Rift runs great on apps I have downloaded from oculus website.  I tried  reinstalling the client from  Lockheed but did not help. Any one using the rift in p3dv4 please advise. Maybe I have missed something along the way.   I am using a 1080 nvidia card cpu is at 4.1 . Should be good with this kind of power.

Have you installed the Oculus software?

Were you able to set up your Rift successfully, placing the sensors, checking the vr controllers etc?

Were you able to run any of the Rift experiences with no problems?

In the P3d VR dropdown are you correctly selecting Rift as your device of choice?

Share this post


Link to post
Share on other sites

all software loaded. Rift runs great on x plane and all apps purchased from oculus website. rift not a choice in vr dropdown oculus is choice and I choose oculus Thanks for replys . Seems strange runs great in  xplane . Any other thoughts

Share this post


Link to post
Share on other sites
Quote

 

when I select oculus from dropdown in p3d I have sound of aircraft but only get oculus library.  no change on screen. but p3d is not showing in the library. does your library have p3d as an option . xplane shows in my library

Share this post


Link to post
Share on other sites
44 minutes ago, denny said:

when I select oculus from dropdown in p3d I have sound of aircraft but only get oculus library.  no change on screen. but p3d is not showing in the library. does your library have p3d as an option . xplane shows in my library

You can't really launch P3D from the Oculus library. Launch it the normal way and then choose Oculus in P3D, and it will automatically start the Oculus software.....

Or perhaps I'm not understanding.

Share this post


Link to post
Share on other sites

I had a similar problem. Unchecking oculus run as administrator fixed it. Your problem may be different.

Share this post


Link to post
Share on other sites

when I choose oculus from dropdown menu in p3d the following comes up " your virtual reality device failed to initialize"  With the headset on I get sound of p3d aircraft through the headset but view shows the oculus library but not p3d. I can then select any app in the library including x plane which is in my library or any other app and  all run fine. it seems p3d is not recognizing the visual hook up of the oculus. all other apps ,as I stated run great. When I contacted oculus rift support , reply was that p3d is not supported by them ,and they could not help. Even though I purchased the rift just for p3d, I can use for x plane and any other app I have purchased from oculus. Been using flightsims for 15 years, have a powerful computer system. First time purchased any hardware could not get to work. It does not seem the rift is bad because all other apps run with no problems. It seems  for some reason p3d is not recognizing the oculus visual hook up, Don't no what to try next.. Only other option I can see is complete delete of p3d and reload with no addons and just pure basic p3d to see if  p3d will then recognize.   Thanks for replys I do love all the help we try to give each other in the flightsimming community.  Dennis

Share this post


Link to post
Share on other sites
Quote

 

Took oculus to a friends  and  ran fine in p3dv4 on his computer. Must be something with my setup. Deleted all p3dv4 from my computer and reinstalled the p3dv4 with no add ons . Still p3dv4 would not recognize oculus. Still no solution found. So strange runs all other apps and xplane but no p3dv4. What a loss after all that cash spent  to purchase.  Does look pretty good in xplane, but p3dv4 is my preferred sim. If I ever solve reason wont load in p3dv4 ,will post solution.  Dennis

Share this post


Link to post
Share on other sites

2c. I find that if I don't have Oculus Home running before launching P3D, or DCS come to that, then they won't play nicely. No sound is the usual one. Oculus is a picky bugger. Wouldn't go without it though.

Share this post


Link to post
Share on other sites

always have oculus home loaded and running before loading p3dv4. Thanks for reply. As stated runs great in xplane.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this