swallsgaming

Stuttering/Lag/Micro-Freezes

Recommended Posts

Hi All,

I have just moved over to P3Dv4.3 by recommendation as I am aware that it uses the GPU more than the CPU and so would fit my system better:

i5 4690K @ 4.5GHz

GTX 1060 3GB

After running FSX for a few years, I had managed to achieve a solid between 25-40fps on the ground and 60-70fps at cruising but fps didn't matter to me because as long as there was no stuttering, lag or jumpy freezes, it was fine and looked amazing!

I made the switch to P3D to take some of the strain off of my CPU and also so that I could begin to use a weather addon to improve my experience and maybe even be able to turn the sliders up to make the sim look even better. This is not the case and currently I am getting 20-35fps on the ground which is prefectly fine but there is some sort of lag that ruines the experience. The only way I can describe it is that it looks almost as if the sim pauses for half a second every 3 seconds which creates a jumpy, laggy picture. Sort of like micro-stutters that other people have experienced but much worse and the stutter lasts much longer and is far from "micro".

So far I have tried:

- Lowering my refresh rate to 59Hz in the NVIDIA Control Panel

- Capping the sim at 30fps and at 20fps in NI

- Reducing the sliders (Improves fps but stutters remain)

- Adding the AffinityMask=14 entry to the CFG (just makes my terrain texture go blurry)

- Changing FTX Global Vector Settings to only Main Roads and coastlines

 

My Addons used at this point are:

- Aerosoft Airbus A319 Professional

- ORBX FTX Global Base, Vector, Europe England OpenLC

- UK2000 Gatwick Extreme v4

 

This is a real shame as I thought the upgrade to P3D would be good and so far am dissapointed. If anyone knows of a fix, any help would be much appreciated!

Thanks in advanced!

Matthew.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

What is the operating system?

First if is windows10 64 (even windows 7), open task manager, performance and see if CPU speed is at 4.5 GHZ steady while using P3dV4 or actually any other software.

Share this post


Link to post

@swallsgaming Hi Matthew,

Look in P3D Options Lighting and try turning OFF:

HDR, Dynamic Lighting and Dynamic Reflections slider to OFF (full left) to see how it goes.  Also, use casting and receiving shadows with moderation. Try enabling CAST for only Internal vehicule, External vehicule and clouds. Receive shadows = all enabled.

Mike

Share this post


Link to post

I upgraded to an i7 9700K and a GTX1080 GPU a few weeks ago and thought that it would be the end of all stutters only to find that this was not the case. I then noticed something that I knew from the FSX days, but thought was solved a long time ago. The stutters started when I went to another window (I was playing around with Process Lasso, performance tools, mapping toots etc) and then went back to P3D (now paused) and continued flying. If you open the display settings menu and just close it immediately (cancel) things smoothed out immediately.

I know that this may be a well know cure and you may be doing it already, but I did not realise that this still an issue in P3D v4.3

Share this post


Link to post

Hi everyone,

Thanks for all the comments!

@killthespam I have Windows 10 64bit and the CPU does use a constant 4.5GHz clock with P3D open

@Mikelab6 I have done as you suggested also and the problem remains, even with all shadows of

@pinepix62 Yes I am doing this already so the problem must be something different!

Cheers,

Matthew!

Share this post


Link to post

Here is a visual representation of what I am talking about, notice the constant freezing:

The main things are:

- Please don't tell me to turn the scenery down because the same thing happens with scenery sliders all at the left

- CPU usage is 100% all the time but even without chaseplane when it lowers to 70%, the problem is still there

- It's not smooth at all so please don't tell me to "deal with it" or "it looks good" either

Video Link

 

 

Share this post


Link to post

Ahhhh, pretty frustrating.

I see that you go as low as 16 FPS, something is going on really bad there.

Before running the sim start the Task Manger, go options and select Always on top.

Start the sim while you have Task manager running see in the Processes tab which one is creating the problem, it should go red indicating that particular issue.

 

Share this post


Link to post

Make sure Hyper-Threading is turned off in the BIOS.  For an i5 4690K the video looks good.  I really did not see that much stuttering. If you did not say there was stuttering, I would have not noticed.  It appeared you were taking off from a payware addon airport.  But flight simulation is in the eyes of the beholder and your eyes demand more than mine.  You should not expect it to run as good as my system where I get mostly 50-60 constant fps. See specs in my signature. Turning off HT will help as it improves the visuals too.  Have you saved p3d.cfg by renaming it to p3d.off, restarting and letting the config rebuild?  When doing this, I usually will max out the first graphics page and leave the other pages as defaults.  See if this improves anything.  Shadows are a big performance hit so be careful there.

Share this post


Link to post

Jim if you don't mind, I see that you recommend the HT off. My question is (because I don't know) what is the advantage of

having it off versus on? I understand that one issue is related to the CPU temps but other than that how is this working on this P3D. If you know pluses and minuses with HT on versus HT off. Thank you!

Share this post


Link to post

@killthespam @Jim Young As I have a 4690k which is not HT capable, I have no option to turn it on as it is a 4 core 4 thread only CPU. My dilemma is that on my system I can run FSX with the same settings for better performance which shouldn't be the case. P3D should suit my pc better because it's not so CPU intensive

Share this post


Link to post

@killthespam The fps is fine for my eyes, even at a default airport, all addons off, I still get the same awful stuttering which at times when it freezes, is unbearable. I wouldn't care if the fps was 6, as long as it's smooth that's all that matters

Share this post


Link to post

You use the AS Airbus, that looks exactly like me. The PMGD 777, however, runs superglatt.Hast you have it already with other aviators z.b. with one of the default aircraft?

Grüße Kalle

Share this post


Link to post

swallsgaming, my concern is that big jump on FPS you have, especially when is dropping below 20 (in your case 16 as I noticed). With such a big drop is impossible to achieve a smooth and fluid flight.

That's why I mentioned checking the Task manager, did you check that?

Also, you mention that CPU is 100% all the time. It shouldn't be like that all the time, running at 100% is an indication that is overloaded.

What is the CPU load when you play another program or at idle (stay at idle for at least 5 or 10 minutes and notice the load please).

 

Share this post


Link to post
5 hours ago, swallsgaming said:

As I have a 4690k which is not HT capable

Yes, all i5's do not support HT.  My recommendation would of course not work on your system.  Sorry for the mistake in not seeing this before commenting.

12 hours ago, killthespam said:

Jim if you don't mind, I see that you recommend the HT off. My question is (because I don't know) what is the advantage of

having it off versus on? I understand that one issue is related to the CPU temps but other than that how is this working on this P3D. If you know pluses and minuses with HT on versus HT off. Thank you!

I answered in a PM you sent but will also answer here.  I had the blurries with my i7 8086K w/6 cores.  I overclocked CPU AND all 6 cores to 5.0GHz and saw blurries in MSE SoCal/NoCal.  Saw on the Internet somewhere HT was not really needed so turned it off.  Suddenly all of my blurries were gone.  I mean, this was like night and day.  The textures are crisp and clear and I feel as if I can almost see people on the ground.  I had some minor stuttering when taking off from FSDT KLAX in any of my payware aircraft and this also reduced or eliminated it (cannot see any issues now). 

Share this post


Link to post

Thank you Jim! 

I just turned mine off and as you pointed out textures are crisp and clear now.

Share this post


Link to post

@Jim Young Do you have any other Ideas as to what may be causing my stutters? I have tried lowering my CPU's clock speed but they remain, I have used Matt Davies' preset on PTA to which the sim looks better but the problem remains

Share this post


Link to post

First of all, you need to start with a set of P3D settings that run well on your system, without payware planes and airports.

I also came from FSX, and this is what I would recommend as a starter set.

You can change all this later when you have things working well.

Since you do not have an HT option, forget about affinity masks, P3DV4 will make good use of your four cores.  Also forget about PTA etc for now..

You are taking too big a leap and as a result, you cannot tell what is causing the performance issues. 

When you have P3D running, have a look at the Windows Task Manager and see what is using CPU cycles.. you should not be at 100% CPU usage, at least not on an ongoing basis, only when loading scenery.

SETTINGS
within P3Dv4

Display:
FXAA off   
AA:  4XSSAA
texture filtering: anisotropic  8X
texture resolution: high 2048x2048
Vsync  off
Target framerate: unlimited
Wideview aspect: off
mipmap VC panels off
Screen resolution:  1920X1080

World
LOD radius:  high
Tesselation factor: high
mesh resolution:  5m
texture resolution:  1m
high resolution terrain: on

Scenery complexity: extremely dense
autogen draw distance:  medium
autogen vegetation density: normal
autogen building density: dense
Dynamic vegetation: unticked

water detail:  medium
Reflections: user vehicle only
Special effects: medium/medium

Lighting
shadow quality:  high
draw distance: low
casting and receiving: Internal vehicle only

Dynamic lighting: off

HDR on:
Brightness 0.85
Bloom 0.05
Saturation 0.97

 

 

Edited by Bert Pieke
  • Like 1

Share this post


Link to post
40 minutes ago, killthespam said:

Thank you Jim! 

I just turned mine off and as you pointed out textures are crisp and clear now.

Good to hear!  I'm happy it worked for someone else.  For me the difference was stunning!

3 minutes ago, swallsgaming said:

Do you have any other Ideas as to what may be causing my stutters? I have tried lowering my CPU's clock speed but they remain, I have used Matt Davies' preset on PTA to which the sim looks better but the problem remains

In your case, I would suspect the video card memory but, if the video was you taking off from UK2000 Gatwick, For instance, my GTX 1080ti has 11GB of GDDR5X memory.  I think 99.9% will have the same lag as yours if flying out of Gatwick.  But it is a nice scenery so what can we say.  Yours is really not that bad and I would fix it by not looking out the window until you get away from Gatwick or from any payware scenery.  Watch the panel and make sure you are getting to VR1, VR2, etc.  That's what I was doing with my old i7 7700K. 

I would also try renaming your p3d.cfg to p3d.off (do not delete) and restart P3D and let it rebuild.  Leave it at default settings and see if the issue goes away.  If it does, then you know it is a setting your config that is probably causing it.  Same thing goes with taking off from payware scenery.  Try disabling the payware scenery and fly with the default airport.  Unfortunately, there is no magic wand for fixing this issue other than upgrading to the most powerful system you can find.  My system (in my signature) has turned out to be the best I have ever seen as it has the capability of overclocking each core to 5GHz.  The memory modules I have and overclocked have helped too.  I think my system is future-proof for many years.  (Did someone say P3DV5, 128-bit is being released?  LOL!).

Share this post


Link to post
5 hours ago, killthespam said:

Thank you Jim! 

I just turned mine off and as you pointed out textures are crisp and clear now. 

I'm beginning to not understand what is going on but I was starting to see blurry textures with it off as the textures had been crisp and clear.  Just for kicks, I decided to turn HT back on and now the textures are crisp and clear again.  So I will now leave it on and see what happens.  .

Share this post


Link to post

Jim,

I'm still good on my end. Something is going on here, I will keep you posted and maybe you guys have more traction in finding a good answer from P3D tech.

 

Share this post


Link to post

Hi Alex,

Hopefully this might help.

I used to have a constant rhythmic stutter in P3Dv3 previously & nothing I did would eliminate it, even turning off all scenery & lowering graphics settings to zero.

What I did to fix this eventually was to uninstall the video driver in Windows, re boot in safe mode then run DDU (Display Driver Uninstaller). then reboot to windows & re install the driver. This fixed the stutter issue that was driving me crazy for so long.

This was a procedure we used to have to perform years ago if you wanted a clean install of the video driver & the general consensus is it's no longer necessary. Afraid I beg to differ.

I have recently seen a stutter in P3Dv4 which although is not the same as the one I had in v3 would still be present with all scenery/graphics turned down. Quite obvious whilst taxiing in circles on the apron of an airport. Going through the same procedure fixed the issue again for me & I actually just did this earlier last week however WIN10 did an update just the other day & reintroduced the stutter again. I tried just a reinstall of the driver (clean install) but unfortunately this didn't fix it. 

Have just done a safe mode uninstall & have a smooth sim again!

Could be worth trying if you have exhausted everything else.

Share this post


Link to post

I have been having the same problem i7 8700k and gtx 1070 ti windows 10 pro build 1803

looked on the net and found this

go to start click on run type in chkdsk / R  C : let it run after reboot

took about 2 hours when finished everything was smooth as silk no more lag spikes or stutters

hopes this will help others

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now