Ray Proudfoot

P3D v4.3 crashes with MyTraffic6 addon

Recommended Posts

I've installed P3D v4.3 on the PC in my sig and have come across a serious problem which has baffled me.

I am still adding airports and at present only have the FSDT and FB airports plus GSX, Ultimate Terrain X Europe, USA and TAC. Orbx FTX Global is also installed.

I have installed MyTraffic6 and then after P3D problems removed it and copied the version I had on my previous computer running P3D v3.4. That version of MyTraffic was stable and I rarely had ntdll.dll crashes.

I have conducted a series of tests this morning with and without the MyTraffic6 addon. Here are the results:-

On 5 out of 8 instances P3D crashed before the free flight screen was displayed when MyTraffic6 was enabled. Event Viewer shows the issue to be ntdll.dll.

On 5 out of 5 occasions when MyTraffic6 was removed P3D displayed the free flight screen.

The problem appears to be linked with MyTraffic6 but since this was stable with P3D v3.4 then logically it should be stable with v4.3. But it isn't.

The time taken to display the free flight screen varies from 11 secs without MyTraffic6 enabled up to 1m 20s with it enabled. It clearly has a significant impact on P3D v4.

If anyone who has MyTraffic6 working well with v4.3 can offer any assistance I would be very grateful. I have done the usual of disabling the military jet option (MyTrafficMil.bgl) and also disabling trafficAircraft.bgl in scenery\world\scenery.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Ray,

I had this same problem with a new build. As per the AVSIM CTD guide, I got Driver Booster, ran it and despite a new build and everything according to Windows 10 was up to date, I had something like 23 out of date drivers. I ran Driver Booster, let it update everything, and I have not had a CTD since.

MT6 maybe just the program that is tipping the system over the edge. It runs fine on my system when I have it enabled (I usually use another AI program as I mainly fly in Australia).

Kind Regards,

Mark

Share this post


Link to post
Share on other sites

Thanks Mark. I'll bear that option in mind. Was one of those drivers related to ntdll.dll as that is the file causing the crashes on every occasion.

And given the problem doesn't exist with MyTraffic disabled it still points to MT6 being the problem rather than the core P3D. Maybe a corrupt file but this is a direct copy of what I had in v3.4.

Share this post


Link to post
Share on other sites

Hi Ray,

Yes it was NTDLL.DLL. Over and over again!

Cheers,

Mark

Share this post


Link to post
Share on other sites

But this is a new PC professionally built. Windows 10 Pro was installed just 10 days ago. Is it really going to have so many drivers that need updating? I could understand if a user was slow in running updates but that doesn't apply in this situation.

MT6 is a popular addon so hopefully I'll get other replies. Maybe a pattern with appear.

Share this post


Link to post
Share on other sites

I have removed the aircraft sub-folder from the MT6 parent and P3D has successfully loaded the free flight window on 5 out of 5 occasions.

That removes the MT6\scenery contents as being suspect. I'm going to perform a binary chop on the aircraft folder. It will take several passes before a possible culprit aircraft is found.

More later...

Share this post


Link to post
Share on other sites

Hi Ray,

Download the freeware version and run it. If it says that you have no out of date drivers, then I have given duff gen.

I persisted for months in the belief that my professionally built and o/c’d system that cost more than my first car could not be an issue.

It was Jim who put me straight so reach out to him if NTDLL.DLL continues.

I bet your looking forward to your 64 bit Concorde now!

Cheers,

Mark

 

Share this post


Link to post
Share on other sites

There are some a/c (mainly military) which are not FSX/P3D compatible and they cause P3D to crash under certain situations. Ther was a list of these a/c here on avsim.

Share this post


Link to post
Share on other sites

Hi Mark,

I'm not discounting trying DriveBooster but I want to add aircraft section by section until I hit a problem. So far A-B were fine, C-E were fine but F-L had one crash in three attempts.

Yes, Concorde 64-bit would be wonderful.

Share this post


Link to post
Share on other sites
2 minutes ago, Nemo said:

There are some a/c (mainly military) which are not FSX/P3D compatible and they cause P3D to crash under certain situations. Ther was a list of these a/c here on avsim.

I've disabled the military jet BGL in MT6. Is that what you're referring to?

Share this post


Link to post
Share on other sites
1 minute ago, Ray Proudfoot said:

I've disabled the military jet BGL in MT6. Is that what you're referring to?

Yes, but if I remember correctly, there was aso a small number of commercial a/c which were not compatible.

Share this post


Link to post
Share on other sites

A-E aircraft previously loaded okay. But after adding F-L and getting crashes I removed F-L leaving A-E. Now getting crashes with A-E so this doesn't appear to be a good test.

Now trying DriveBooster.

Share this post


Link to post
Share on other sites

DriveBooster v5.1 (free) is reporting 14 outdated device drivers and 2 outdated game components.

However, I can't see a way of allowing it to update drivers without having to  buy the software.

Share this post


Link to post
Share on other sites
9 minutes ago, Nemo said:

Yes, but if I remember correctly, there was aso a small number of commercial a/c which were not compatible.

Knowing the filenames would be helpful.

Share this post


Link to post
Share on other sites
46 minutes ago, mwa05 said:

NTDLL.DLL.

Ray, I share your issues. Am awaiting to re-install my MT6a too in 4.3. This NTDLL.dll caused a brief CTD yesterday while loading simWimgs Mega Airport Madrid yesterday, but on a re-start it disappeared. It is so, so annoying that here we are, garlanded with an MS dll, that I have lost count of, which CTDs sims, be it FSX,-SE, or P3D varieties, that in the 1st quarter of the 21st century, this legacy dll has not been nailed once and for all

Share this post


Link to post
Share on other sites

I share your frustration Rick. It would help if P3D created a log as it loaded and then wrote what the problem was to it. If Pete Dowson can do it for FSUIPC surely L-M can for their product?

Now running DB Free and it's found 6 outdated drivers. I'm allowing it to update but not hopeful it will fix the problem.

Share this post


Link to post
Share on other sites
Just now, Ray Proudfoot said:

If Pete Dowson can do it for FSUIPC

Bang on the mark, Ray.

Share this post


Link to post
Share on other sites
2 minutes ago, Ray Proudfoot said:

DB Free

Never placed much confidence in these so-called 'driver' fixes. I am running an older Nvidia driver, i.e. 388 for my 970GTX, and am still getting smooth flights in top-end aircraft

Edited by vc10man

Share this post


Link to post
Share on other sites

DB has buggered up my USB driver. Keyboard and mouse U/S. Not impressed.

Share this post


Link to post
Share on other sites

Now you know, Ray, why I subscribe to that old adage......'better the devil.....'.

That's why I never go anywhere near these so-called 'tools/fixes/etc, etc'!

  • Upvote 1

Share this post


Link to post
Share on other sites

Do others hear windows default sound during the P3D loading process prior to free flight being displayed.

Just had another crash after DB updated some drivers. That program has been uninstalled.

Anyone out there running MT6 with P3D v4.3 without issues?

Share this post


Link to post
Share on other sites

Apologies Ray, that was not my experience. Quite the opposite. I had done everything but a Driver Booster check to rid myself of that dll crash (as I had no faith in such tools either) but Jim urged me to do so, and what can I say, I have never had a CTD since. And it has been months, whereas I was having the issue every second flight.

I hope you get it sorted.

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites

Ray,

Have you tried UTL? Had MT6 for a while but ran into issues and CTD's once Prepar V4 got released. UTL seems to be working great so far.

Share this post


Link to post
Share on other sites

Thanks Mark. Given that install of MT6 was okay with P3D v3.4 then it has to be an issue with v4.3. I think I’ll raise a ticket with LM in their forum given MT6 is now unsupported.

Michael, not going to consider an alternative at this stage. I want to ensure MT6 is incompatible with v4.3 first.

Were your crashes before the free flight window was displayed or during flight?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now