Pete Dowson

DXGI_ERROR_DEVICE_HUNG error: Is there a solution?

Recommended Posts

Only recently (since P3D4.3, and still with P3D4.4) I started to get these DXGI device has hung messages. Originally, when they started, they only occurred at dusk or at night. But I've just tried re-enabling my FTX England scenery to see what it looks like in version 4.4.

Now the crash occurs in the daytime, 100% consistently, within a couple of minutes of the scenario starting up (my default, at UK2000's EGCC).

The GPUs (I have 3 x 1080Ti's in SLI formation) are never loaded to more than 45% (according to Task Manager), so I don't understand what is going on. Is this a P3D problem, or an nVidia driver problem? The error report appears to be from P3D. I have tried various nVidia drivers, Currently I'm on 416.94.

My installation is pretty well loaded up with addons as well as Orbx, but I tried with the FTC OpenLC Europe disabled, and with all my UTX layers disabled too, to no avail. With no FTX Europe regions enabled all is well -- for daytime flying. I can't use it at night because of the same errors.

I'll ask on the P3D forum too. I need a solution, or my Orbx purchases are useless (I have all of the FTX Europe country regions and was looking forward to trying them, but I can't get passed the first couple of minutes after loading).

Whilst awaiting answers I'll continue experimenting. Things to try:

1. Disabling SLI
2. Changing drivers yet again (go for the latest first ...
3. ... er: there is no 3 ... yet.

Thanks,
Pete

 

Edited by Pete Dowson

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

There is a lot of discussion pinned in the AVSIM CTD Forum.  The error is all over the Internet and the most likely fix is not trying to overclock your video card.

Share this post


Link to post
6 minutes ago, Jim Young said:

the most likely fix is not trying to overclock your video card.

It isn't overclocked. It is one which comes ready set with a higher than default nVidia performance, but I haven't touched it.

I'll checkout the CTD forum -- I didn't even realise there was one. Of course, this error isn't a CTD. P3D is still running, and you can continue and it will contune, operating as if nothing was wrong as far as I can tell from myconnected utilities. but the display is blank and doesn't return even with a scenerio re-load.

Pete

 

Share this post


Link to post

I saw posts where someone clocked down (!) his 1080ti and got rid of the device_hung errors. At least the max. power consumption to 80% if i recall correctly.

Share this post


Link to post
3 minutes ago, JoeFackel said:

I saw posts where someone clocked down (!) his 1080ti and got rid of the device_hung errors. At least the max. power consumption to 80% if i recall correctly.

Okay. So that's item 3. to try.  May yet need a #4 though! 😉  

Thanks,
Pete

 

Share this post


Link to post

Hi Pete,

Another thing to test is maybe doing SLI with only 2 cards?

S.

Share this post


Link to post
33 minutes ago, Pete Dowson said:

Okay. So that's item 3. to try.  May yet need a #4 though! 😉  

Thanks,
Pete

 

Have that always when testing max  OC in P3D( GPU OC ), one notch down is ok , if you have a heavy OC the CPU weaker card like 1070 with factory oc can give it. or BAD GPU

tested my 2x 1080 ti SLI in P3Dv4.4 max clock 2126mhz Dxgi at 2138 after 2-5min  2150 when load P3DV4

You can test to downclock the cards in Afterburner -150 to -250 in the bar  or disable one card at a time ( if you hav a mobo with dip switches for pcie slots) easy way to find a bad gpu.

Edited by westman
  • Like 1

Share this post


Link to post

Hi Pete-

As Westman notes above, it was a bad GPU in my Titan Black. Replaced with a 1080ti a few months ago and haven't had a problem since. You can read about it here.

Good luck,

Mark

Share this post


Link to post

Since you stated that the error started to pop up recently, can you think of or remember anything that changed in your system before the errors occurred?

Share this post


Link to post

I had one of these for the first time ever Monday morning. By chance, I read this (page 2 here) and did what Dave said. 3 flights later not seen it again. 

 

Share this post


Link to post
29 minutes ago, westman said:

You can test to downclock the cards in Afterburner -150 to -250 in the bar  or disable one card at a time ( if you hav a mobo with dip switches for pcie slots) easy way to find a bad gpu.

 

22 minutes ago, newtie said:

As Westman notes above, it was a bad GPU in my Titan Black. Replaced with a 1080ti a few months ago and haven't had a problem since. You can read about it here.

Success with my step #1 (disable SLI)! I get no DXGI errors if I disable SLI. So it's either a problematic 3-way SLI, or, as suggested, one of the GPUs is not so healthy.

I'm not sure how to disable just one in a 3-way connection. I don't think there are switches on the mobo.  What about just disabling them in the Device Manager? Won't that work? Mind you, identifying which is which in there will be trial and error as far as I can see!

10 minutes ago, Afterburner said:

Since you stated that the error started to pop up recently, can you think of or remember anything that changed in your system before the errors occurred?

P3D4.3 and 4.4.  Nothing else really.

Thanks all! I'll keep at it. If it's an SLI problem it looks like I'll have 2 x 1080Ti's for sale, only 16 months old, one good owner! 😉

Pete

 

Share this post


Link to post
8 minutes ago, Nyxx said:

I had one of these for the first time ever Monday morning. By chance, I read this (page 2 here) and did what Dave said. 3 flights later not seen it again. 

Thanks. Another thing to try. I usually do the nVidia "clean install", but i assume DDU does a better job.

Pete

 

Share this post


Link to post

I was getting this error quite a bit several months ago after an Nvidia driver update (can't recall which one).  I stopped using Nvidia Inspector and that fixed it for me.  Not sure if you have a P3D profile set up in NI or not.

Share this post


Link to post
Just now, Flic1 said:

Not sure if you have a P3D profile set up in NI or not.

No, I'm not using NVI. Never saw a need for it, and originally folks said it didn't do anything for you in P3Dv4. What does it do for you?

Pete

 

Share this post


Link to post
3 minutes ago, Pete Dowson said:

No, I'm not using NVI. Never saw a need for it, and originally folks said it didn't do anything for you in P3Dv4. What does it do for you?

Pete

 

I was using it as an external FPS limiter instead of the internal which hit my frames too much.  It 'seemed' to work well at the time as it did keep my frames at 30 but to be honest after not using it for a while I really can't tell any difference.  I think I saw a post from Rob A. that said the external limiting really doesn't help P3D and I tend to agree now after not using it.  I also never saw much need for any of the other NVI settings.

Share this post


Link to post
21 minutes ago, Pete Dowson said:

Thanks. Another thing to try. I usually do the nVidia "clean install", but i assume DDU does a better job.

Pete

 

Can be as simple that 4.4 not like 3way, i had problem to find a god driver on saturday when installed V4.4

i have 2 sim pc with 2x 1080ti SLI , testet the pc with Win10 1809  tricky one get  to work properly, the one with 1803 was no problem at all , but P3DV4.3 vs V4.4 dont react the same way on SLI ( subjetive personal feeling)

Edited by westman

Share this post


Link to post
3 minutes ago, Flic1 said:

I was using it as an external FPS limiter instead of the internal which hit my frames too much.  It 'seemed' to work well at the time as it did keep my frames at 30 but to be honest after not using it for a while I really can't tell any difference.  I think I saw a post from Rob A. that said the external limiting really doesn't help P3D and I tend to agree now after not using it.  I also never saw much need for any of the other NVI settings.

Right. I set unlimited in P3D and enable VSync. My 3 projectors are all running at 30Hz, so that's just right for me.

Pete

 

 

Share this post


Link to post
1 minute ago, westman said:

Can be as simple that 4.4 not like 3way

That may be so. That will be my next test, whether by disabling one of the GPUs or removing its SLI link. Or, thinking on how they are linked, sort of circularly, I may have to find that 2-way link I think I had.

One result so far from my testing. Now that DXGI crashes don't occur I've been testing further. First with the time set for night. And it works fine -- but with abysmal frames rates (14-17 at EGLL), and then in the day also at EGLL -- the same! So I think Orbx FTX England (and the others I'd hoped to enjoy) are not viable with my setup. 😞

I think without the FTX stuff I should be okay at night though, without fear of DXGI crashes at last!

Pete

 

Share this post


Link to post
1 hour ago, Pete Dowson said:

Only recently (since P3D4.3, and still with P3D4.4) I started to get these DXGI device has hung messages. Originally, when they started, they only occurred at dusk or at night. But I've just tried re-enabling my FTX England scenery to see what it looks like in version 4.4.

Now the crash occurs in the daytime, 100% consistently, within a couple of minutes of the scenario starting up (my default, at UK2000's EGCC).

The GPUs (I have 3 x 1080Ti's in SLI formation) are never loaded to more than 45% (according to Task Manager), so I don't understand what is going on. Is this a P3D problem, or an nVidia driver problem? The error report appears to be from P3D. I have tried various nVidia drivers, Currently I'm on 416.94.

My installation is pretty well loaded up with addons as well as Orbx, but I tried with the FTC OpenLC Europe disabled, and with all my UTX layers disabled too, to no avail. With no FTX Europe regions enabled all is well -- for daytime flying. I can't use it at night because of the same errors.

I'll ask on the P3D forum too. I need a solution, or my Orbx purchases are useless (I have all of the FTX Europe country regions and was looking forward to trying them, but I can't get passed the first couple of minutes after loading).

Whilst awaiting answers I'll continue experimenting. Things to try:

1. Disabling SLI
2. Changing drivers yet again (go for the latest first ...
3. ... er: there is no 3 ... yet.

Thanks,
Pete

 

Pete

I know of 3 friends with 1080ti cards that all had this problem and we tried everything, in all cases the cards went bad and after changing out cards with new cards the problem disappeared. We first swapped out the cards with other cards that didn’t have the issue and after that remedied the problem they returned their cards under warranty for new ones.

I’m not saying this is the problem for everyone but I’ve seen it be the cause 3 times. If it’s possible for you to swap a card at a time that may identify if you have a card going bad.

As a note there seems to be more quality issues with the 1080ti cards then the previous generations from what I’ve seen. Additionally a friend of mine just had a 2080ti completely fail after 2 weeks. 

Joe

 

Share this post


Link to post
42 minutes ago, Pete Dowson said:

Thanks. Another thing to try. I usually do the nVidia "clean install", but i assume DDU does a better job.

Pete

 

Yes, it does you have to start PC in safe mode before you use it.

Share this post


Link to post
29 minutes ago, Pete Dowson said:

I set unlimited in P3D and enable VSync.

I think there is something amiss with Vsync - several gamers and simmers have turned off Vsync altogether and DXGI never came back.

If you have not tried this possible solution, its worth a shot to just leave Vsync off and lock FPS to 30 within P3D.

Edited by pracines

Share this post


Link to post
44 minutes ago, Pete Dowson said:

That may be so. That will be my next test, whether by disabling one of the GPUs or removing its SLI link. Or, thinking on how they are linked, sort of circularly, I may have to find that 2-way link I think I had.

One result so far from my testing. Now that DXGI crashes don't occur I've been testing further. First with the time set for night. And it works fine -- but with abysmal frames rates (14-17 at EGLL), and then in the day also at EGLL -- the same! So I think Orbx FTX England (and the others I'd hoped to enjoy) are not viable with my setup. 😞

I think without the FTX stuff I should be okay at night though, without fear of DXGI crashes at last!

Pete

 

Pete,

Rob M. just replied to your post on the LM forums, he said 3 way SLI is not native supported.. so I think 2 way SLI will be the way for you.

Regards,
S.

Share this post


Link to post
10 minutes ago, simbol said:

Rob M. just replied to your post on the LM forums, he said 3 way SLI is not native supported.. so I think 2 way SLI will be the way for you.

I see. Ok. Thanks. I think that probably accounts for the fact that one of the GPUs was hardly used, but maybe not for the DXGI crashes. Because they started occurring so consistently after I added FTX Europe I feel it's more to do with P3D loading.

Pete

 

Edited by Pete Dowson

Share this post


Link to post

Hi Pete,

I also had the same problem with my nvidia 1080Ti and the newer drivers since 4/2018 until I used this fix:


The problem: a thing called TDR checker monitors the computer’s hardware, particularly the GPU. When the GPU stops responding with the computer for 2 seconds TDR checker restarts the driver. The TDR checker was good on paper but did not work in the real world as a GPU can stop responding when it is working hard.

Here is the solution that worked for me, it requires an extra sub key entry into the Windows registry, so please only implement if you feel OK with editing your registry!

- Exit all Windows based programs,
- Click on the Windows Start button, type regedit in the Search box,double-click regedit.exe from the results above.
If you are prompted for an administrator password or confirmation, type the password or provide confirmation,
- Browse to and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers
- On the Edit menu, click New, and select the QWORD (64-bit) value from the drop-down menu,
- Type ‘TdrLevel’ as the Name and click Enter,
- Double-click TdrLevel and set the value as 0 (it is set to that by default, but double check) and click OK,
- Close the registry editor and restart your computer for the changes to take effect!

I saw this fix mentioned earlier in this thread, but make sure you create a Qword (64bit) key for Windows 64 bit OS and NOT a Bword (32 bit) key because that wil not give the right result.

If you encounter a DXGI hung/removed error again please make sure that this key still exists in your registry!
It happened to me once that the key vanished after a Windows Update, resulting in the dreadful DXGI hung error once again.

 

after using this fix I never had an "dgxi error device removed" again

greetings

Dirk

Share this post


Link to post
39 minutes ago, redchiefnr1 said:

I saw this fix mentioned earlier in this thread, but make sure you create a Qword (64bit) key for Windows 64 bit OS and NOT a Bword (32 bit) key because that wil not give the right result.

Ah, thanks! I had already tried that, but it was set as a DWORD! I've changed it now, and will re-test tomorrow with SLI re-enabled.

None of the 3 GPU's are heavily loaded (45% max in Task Manager), but i'm wondering if the problem is the lack of any real work done by one of them. Only two are used.

L-M say 3-way SLI isn't supported, so that may explain this. But if so, I'll end up removing a card and going 2-way after all.

BTW, with only one card in use I'm seeing it loaded up to 90% in heavy situations. With the "3-way" SLI they wre max 45, 8 and 45. So I think i need some sort of SLI to give me some headroom! But 2-way would obviously suffice.

Thanks again,
Pete

 

Edited by Pete Dowson

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now