Jump to content

Sign in to follow this  
Guest

Severe ghosting in P3D 4.4

Recommended Posts

Guest

Reinstalled Windows 10 and then installed the latest version of P3D. Latest drivers for everything. Didn't change any hardware. P3D 4.4 has severe ghosting. I noticed it as soon as I started the sim for the first time and used ChasePlane to change views. TrackIR also shows severe ghosting. It's as if the image is lagging and doubled whenever you look around. Very tiring for the eyes. (Specially if you can get migraine easily due to computer graphics like I do.) Things also look a bit sluggish. I never ever had this before and I reinstalled Windows and P3D numerous times (a few times a year) using the exact same settings for everything.

Any idea what might cause this and how to get rid of it? Aerofly FS 2 has no gosthing at ALL so that is why I am thinking it must be something with P3D 4.4. As it is now I don't like flying in P3D at ALL...

EDIT
Never mind... P3D 4.4 locked up on me just as 4.3 used to do. This is with a complete fresh install of everything. In the middle of a flight is simply locks up completely, without an error message or anything. I know this must be a problem on my side because no one else seems to have this problem but this is killing, of course. I think I am done with P3D for now.

Edited by Guest

Share this post


Link to post
1 minute ago, J van E said:

Reinstalled Windows 10 and then installed the latest version of P3D. Latest drivers for everything. Didn't change any hardware. P3D 4.4 has severe ghosting. I noticed it as soon as I started the sim for the first time and used ChasePlane to change views. TrackIR also shows severe ghosting. It's as if the image is lagging and doubled whenever you look around. Very tiring for the eyes. (Specially if you can get migraine easily due to computer graphics like I do.) Things also look a bit sluggish. I never ever had this before and I reinstalled Windows and P3D numerous times (a few times a year) using the exact same settings for everything.

Any idea what might cause this and how to get rid of it? Aerofly FS 2 has no gosthing at ALL so that is why I am thinking it must be something with P3D 4.4. As it is now I don't like flying in P3D at ALL...

Hi Jeroen, sounds very odd. What about updating MB drivers bios etc? Is there any chance you can grab an HD screen video and upload?


Howard
P3Dv4, Asus Z170-A MB, i7-6700 Skylake @ 4.5ghz, Asus GTX1080ti 11Gb GPU, 16gb RAM@3200Mhz, SSD/1Tb+P3D.v4.4, SSD/500Gb+OS, Western Digital 1Tb HD + Storage, Ocz 750 PSU, Philips BDM4350UC 43" 4K IPS, 2 x 17" Dell @ 1920x1200. PFC Yoke, Warthog throttle system, Saitek combat pedals, Saitek switch and radio panels, VRinsight Boeing 2 MCP.



Banner_FS2Crew_Supporter.jpg

Share this post


Link to post

Sounds very similar to the earlier thread we commented on...?


Kevin Firth - i7-8700K @5.0; Asus Maximus X Hero; 32Gb Cas14 3200 DDR4; RTX2080Ti

Share this post


Link to post
13 minutes ago, kevinfirth said:

Sounds very similar to the earlier thread we commented on...?

It does Kevin. I always find these issues difficult without actually seeing the problem.


Howard
P3Dv4, Asus Z170-A MB, i7-6700 Skylake @ 4.5ghz, Asus GTX1080ti 11Gb GPU, 16gb RAM@3200Mhz, SSD/1Tb+P3D.v4.4, SSD/500Gb+OS, Western Digital 1Tb HD + Storage, Ocz 750 PSU, Philips BDM4350UC 43" 4K IPS, 2 x 17" Dell @ 1920x1200. PFC Yoke, Warthog throttle system, Saitek combat pedals, Saitek switch and radio panels, VRinsight Boeing 2 MCP.



Banner_FS2Crew_Supporter.jpg

Share this post


Link to post
20 minutes ago, J van E said:

I think I am done with P3D for now.

😞


Howard
P3Dv4, Asus Z170-A MB, i7-6700 Skylake @ 4.5ghz, Asus GTX1080ti 11Gb GPU, 16gb RAM@3200Mhz, SSD/1Tb+P3D.v4.4, SSD/500Gb+OS, Western Digital 1Tb HD + Storage, Ocz 750 PSU, Philips BDM4350UC 43" 4K IPS, 2 x 17" Dell @ 1920x1200. PFC Yoke, Warthog throttle system, Saitek combat pedals, Saitek switch and radio panels, VRinsight Boeing 2 MCP.



Banner_FS2Crew_Supporter.jpg

Share this post


Link to post
2 hours ago, J van E said:

P3D 4.4 has severe ghosting

First time in my life I hear that. There´s always a first time for everything I guess.

Cheers, Ed


Ed Patino

P3Dv4.5 hf2 - Win 7 Ultimate SP1 x64 // Rig: Corsair 600T Graphite - ASUS MBoard X99 Deluxe - CPU Intel i7-5820k 6-cores - 32GB RAM - MSI Nvidia GeForce GTX1080Ti 11GB - 3 x SSD x 1TB Samsung/Crucial + 1 HDD Seagate 2TB + 1 HDD External Seagate 2TB - Monitor LG 29UC97C UWHD Curved - PSU Corsair RM1000W - VR Oculus Rift // P3Dv4.5 hf2 & Aerofly FS 2 - Gaming Laptop ASUS Strix - CPU Intel i7-8750H - 32GB RAM - Nvidia RTX 2070 - 2TB SSD - 2TB HDD // Thrustmaster FCS & MS XBOX Controllers

Share this post


Link to post

a default install of win10 will benefit immensely from some optimization:
complete all OS updates
exclude all FS folders from AV scanning
disable all notifications
disable background creation of (hidden) thumbs.db and esp. that photos app scanning everything.

there's probably a relevant optimization guide somewhere here (idk... new here myself)

however ghosting sounds more hardware (or drivers) than software hence the regulars are a bit perplexed.

Edited by jpf

Share this post


Link to post

I had exactly the same issue a few days ago. A clean new OS Win10-1809 incl all updates and a fresh P3D V4.4 installation.
P3D in full screen, ChasePlane showed ghosting/tearing views.
Searching and reading a lot of postings here and at other sites. The following worked for me:

  • Right-click your P3D.exe
  • Properties / Compatibility 
  • Check: 'Disable Fullscreen Optimizations'

Location: Vleuten, The Netherlands, 15.7dme EHAM
System: P3D V4 - 80386 DX2 - 4MB RAM - 3dfx Voodoo5 - Windows 3.11

Share this post


Link to post
On 12/28/2018 at 11:42 AM, J van E said:

Reinstalled Windows 10 and then installed the latest version of P3D. Latest drivers for everything. Didn't change any hardware. P3D 4.4 has severe ghosting. I noticed it as soon as I started the sim for the first time and used ChasePlane to change views. TrackIR also shows severe ghosting. It's as if the image is lagging and doubled whenever you look around. Very tiring for the eyes. (Specially if you can get migraine easily due to computer graphics like I do.) Things also look a bit sluggish. I never ever had this before and I reinstalled Windows and P3D numerous times (a few times a year) using the exact same settings for everything.

Any idea what might cause this and how to get rid of it? Aerofly FS 2 has no gosthing at ALL so that is why I am thinking it must be something with P3D 4.4. As it is now I don't like flying in P3D at ALL...

EDIT
Never mind... P3D 4.4 locked up on me just as 4.3 used to do. This is with a complete fresh install of everything. In the middle of a flight is simply locks up completely, without an error message or anything. I know this must be a problem on my side because no one else seems to have this problem but this is killing, of course. I think I am done with P3D for now.

What monitor and GPU do you have? 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
×
×
  • Create New...