Recommended Posts

Hi Everyone.

I have a problem with my sim.I get 40 to 30 fps with stutters. My fps doesn't change i can lower it all to the minimum and it won't go up.Also, I have a high-end system.Ryzen 7 2700x 24gb ddr4 Ram Rtx 2070 8GB Card.I need help with the stutters 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Easy explanation: if you can change settings, especially those related to graphics, and you do not see any FPS increase, this means you are in a CPU limit. Means: your CPU is not capable of providing more FPS than you have now, irrespective of the graphic settings.

Try once with a FPS limit inside P3D of about 30FPS and see if this helps with the stutters. As a start, try 30FPS, VSYNC on but Triple Buffering off inside P3D. If this does not help, we can start thinking about adding an Affinity Mask to your prepar3d.cfg. Are you aware about tweaking prepar3d.cfg? Or is this something completely new to you?

I am pretty sure that with some effort, you will be able to have a very smooth experience of P3D on your rig, it simply takes some time to configure P3D correctly.

Share this post


Link to post

If you use NI, try deleting any P3D profiles that you may have created. If that doesn't help, try using DDU to remove your nVidia drivers and then re-installing them using the "clean install" option.

The last time I had a situation exactly like you described, it was an NI profile created under an older nVidia driver causing the problem. Fortunately, the stutters showed up right after I upgraded my video driver, so I knew P3D wasn't the issue. I deleted the NI P3D profile and P3D ran fine after that. I've found that I do not need to do anything in NI for P3D, so I no longer use it.

Edited by MDFlier

Share this post


Link to post

Ok Thanks Ive done every single tweak on the cfg also nvidia inspector and it didnt change. I will get back to you asap after i try these tweaks I also have hyperthreading disabled 

Edited by shantm11

Share this post


Link to post

Also can you recomend me good settings for prepar3d v4.4 with my specs

Share this post


Link to post

My first recommendation would be to stop thinking in terms of FPS with P3D. High FPS with stuttering is useless. Look for the LOWEST FPS setting you can that will stay smooth. Each system is different - on mine I run locked at 20fps with most sliders at or near max. I occasionally get a stutter but nothing really noticeable.

No one can really give you "settings" that will work on your system - it's your eyes and you will see what you like. Just take it slow and think in terms of lowering your FPS and being smooth not raising it and being stuttery.

Look for things that have a big effect on the CPU like shadows, high texture resolutions, high AA, etc.  You need to get the right balance for your system - trial and error is the best way to go.

 

Vic

  • Like 1

Share this post


Link to post
55 minutes ago, vgbaron said:

My first recommendation would be to stop thinking in terms of FPS with P3D. High FPS with stuttering is useless. Look for the LOWEST FPS setting you can that will stay smooth.

On Point!

Thanks Vic!

Edited by rafikihd

Share this post


Link to post

Ive tried but i cant get it to work can you recomend me settings MY specs Ryzen 7 2700x 3.7ghz 24 GB ram Rtx 2070

Share this post


Link to post
22 minutes ago, shantm11 said:

Ive tried but i cant get it to work can you recomend me settings MY specs Ryzen 7 2700x 3.7ghz 24 GB ram Rtx 2070

I'm not that familiar with Ryzen cpu's, but I can recommend some things I do for testing Intel rigs:

in-sim framelock at 30, vsync on.  Delete/remove NI.  Disable/remove Process Lasso if you use it.  Remove any AffinityMask tweak if you use it.  Ensure shaders are ok, and vidcard driver is ok.   Autogen Buildings Sparse, Autogen Veg Normal.  Autogen radius to a low level.  Both Special Effects sliders OFF/zero. All AI sliders to zero.   Set AA in-sim to 4xMSAA.  Dynamic lighting off.  Everything else -- be reasonable. The idea is to set low settings, then gradually work your way up.

Now use Task Manager or similar to monitor P3D's main thread.  You want to establish low settings where Core0 is NOT being maxxed out at 100%.  Only then will you not have sim-induced stutters, at least on an Intel cpu.  Then you start gradually moving settings/sliders up, until you max out P3D's primary thread.  At that point you will know your cpu/settings limits at a given location.  

I'm really curious about your Ryzen cpu in P3D though.  Please let me know what results you get doing the above as a test, to at least see if you get a baseline of *smoothness* going.

Share this post


Link to post

Ok Sure will definitly update you in about a hour

Share this post


Link to post

im getting around 35 fps with small microstutters thanks but i have a problem when i try to limit to 30 i get 25 to 24 fps cpu utilization around 35 to 50%

Edited by shantm11

Share this post


Link to post
1 hour ago, shantm11 said:

im getting around 35 fps with small microstutters thanks but i have a problem when i try to limit to 30 i get 25 to 24 fps cpu utilization around 35 to 50%

Make sure you're measuring cpu utilization on ONLY the main thread (Core0).  That cpu utilization sounds like you're measuring all cores together.  Then again it could be something specific to the Ryzen doing that, that I do not know about.

Share this post


Link to post

3.7ghz is really stretching it. Not to discourage you though, it IS doable. If you can possiblly get that cpu to 4ghz it will make a huge difference. LM has offloaded several processes to the GPU which helps but autogen LOD Radius etc stress the cpu.

Once you get in the ballpark area - fly with it for a week or so and see how much you notice stutters etc. Then make small changes and repeat. You'll have to sneak up on it but cut out all the eye candy until you get a stable smooth fps.

Vic

Share this post


Link to post

ok thanks if i over clock to 4.2 ghz with a h100i v2 cooler will that work also its boost clock to 4.2 ghz

Edited by shantm11

Share this post


Link to post
5 hours ago, shantm11 said:

how do you check with task manager

 

right click on the taskbar and select "Task Manager", then go to the Performance tab.  Make sure you select "CPU", by clicking on "cpu" on the left side of the dialog.  Alternatively, Windows key+R, then enter taskmgr in the blank and press enter. 

Share this post


Link to post
13 hours ago, shantm11 said:

ok thanks if i over clock to 4.2 ghz with a h100i v2 cooler will that work also its boost clock to 4.2 ghz

That would be good and a big help.

 

 

Vic

Share this post


Link to post

For the ultimate P3D experience, run your sim at 5 FPS locked. 

  • Like 1

Share this post


Link to post
1 minute ago, Chapstick said:

For the ultimate P3D experience, run your sim at 5 FPS locked. 

Quit trollololing the guy man.  Come on.

Share this post


Link to post

lmaoo well i think you got the wrong forum thats for fsx 

Share this post


Link to post
6 minutes ago, shantm11 said:

lmaoo well i think you got the wrong forum thats for fsx 

:biggrin: Nicely done - now let's all stay on topic.

 

Vic

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now