jeypee

ORBX double airports within regions

Recommended Posts

Hi there,

never had this issue in the past. Now with 4.4 i have some problems with FTX Airports within FTX regions.

So far i spottet EGHI within FTX England and EGPB within FTX Scottland.

The order of the sceneries in the scenery biblio seems ok.

ORBX libs
ORBX airport
ORBX region

My FTX Central 3, Library and all FTX stuff are up to date.

I also tried to uninstall / reinstall the airports / verifying the files without success

I tried to disabling the airport BGLs within the FTX region Scenery folder. Also without success.

 

Some Pictures:

EGHI

EGPB

 

Any ideas??

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Looks like another airport file is active somewhere...MyTraffic X, for example, is a common source of ADE conflicts, as it contains a large number of airport files worldwide that do just this sort of thing if left active with another airport add-on.

ScruffyDuck's Airport Scanner is a good tool to help find duplicates.

Regards

Share this post


Link to post

Thx for the tip but i only use Traffic Global. I deinstalled it and deactivated all scenery entries, but same as before.

I also tried to uninstall FTX EGPB -> still broken

+ uninstall FTX Scottland - > EGPB still broken

Vector Elevation correction also no success. Looks like Vector screwed up everything in the area….

This is how it Looks just with Global, EU LC and Vector left: 

EGPB "default"

 

PS: i use also Freemesh X, but i got the same error with or without it.....

Edited by jeypee

Share this post


Link to post

 TG also comes with it's own airport files and need to be disabled either as a whole or airport by airport depending on what addons you have. Vector, when configured properly is going to work fine, it's more commonly screwed up by the users who mess around over their ability level.

 EGPB for instance, if you have FTX Scotland has it's own EGPB airport files, then there is the EGPB addon as well as TG's version, they are going to all conflict, it's up to you to set it up and disable those that you aren't using. From there you can run or set vector.

  • Like 2
  • Upvote 1

Share this post


Link to post

Anything that has CAD bgls must be correctly installed to maintain the scenery hierarchy OBBX below addon airports, and if you have TG, then the TG Airport Facilities folder this must be placed under ORBX and just above the base scenery folders, and lorbys Addon Organizer can do this for you. 

Share this post


Link to post
17 minutes ago, rjfry said:

Anything that has CAD bgls must be correctly installed to maintain the scenery hierarchy OBBX below addon airports, and if you have TG, then the TG Airport Facilities folder this must be placed under ORBX and just above the base scenery folders, and lorbys Addon Organizer can do this for you. 

This often isn't enough, however, because excludes stacked atop one another in the scenery hierarchy do not always behave as you'd think they should.  Often, an exclude in an airport file at a lower level can impact scenery placed above it.  If you really know what you're doing you can nest airport files at different scenery levels, as ORBX does with their add-on airports sitting atop the enhanced airports they place in their full-fat regions--but in that case they have control over what's in both scenery packages and can deconflict the two levels where necessary.

So with that said, making sure that there are not multiple ADE/AFCAD files active for a particular airport is a generally good rule to follow.

I'll reiterate my recommendation for use of ScruffyDuck's Simple Airport Scanner as a good tool to identify airports with multiple active airport files.  It's spotted conflicts for me that I would never have thought to look for.

Regards

Share this post


Link to post
1 hour ago, w6kd said:

I'll reiterate my recommendation for use of ScruffyDuck's Simple Airport Scanner as a good tool to identify airports with multiple active airport files.

I did not realize SAS was available for P3D v4  --- or more specifically, for users that only have V4 installed. 

Share this post


Link to post
57 minutes ago, pracines said:

I did not realize SAS was available for P3D v4  --- or more specifically, for users that only have V4 installed. 

It's not. There was a beta version which was withdrawn because it couldn't handle the add-on.xml installation method. A new beta is forthcoming.

  • Like 1

Share this post


Link to post

I use ADE to scan airport`s bgls and have not had a problem, even though I have found 4 CAD files for an airport ,Base, TG , ORBX , Addon.

But what I do is copy my addon CAD file for my addons into the TG folder then there can be no conflict. 

PS on the subject of EGPB you can delete that from TG Airport Facilities folder not needed, it`s not an airport that has scheduled traffic.

Edited by rjfry

Share this post


Link to post
16 hours ago, pracines said:

I did not realize SAS was available for P3D v4  --- or more specifically, for users that only have V4 installed. 

Simple Airport Scanner (SAS) can still be used with P3Dv4 in conjunction with Lorby-SI's P3D Addon Manager...there is a feature in Addon Manager that temporarily consolidates all of the xml-based sceneries to the scenery.cfg for use with older non xml-aware utilities that need visibility on everything such as Pete Dowson's MakeRwys utility that creates airport and runway databases for programs like Radar Contact, PF3 etc.

Regards

 

Share this post


Link to post

That used to work with the beta that has been withdrawn. The version of SAS available for download on Scruffyduck's website  only works with FSX, as it doesn't find the registry settings for any P3d version, at least not for me. The withdrawn beta version can still be found here:

https://www.fsdeveloper.com/forum/threads/simple-airport-scanner-1-70-beta.440300/

if one want's to try Bob's workaround.

Share this post


Link to post

Thx for all replies.

Problem should be solved … i hope.

Deinstall and reinstall of Vector does the Job for EGHI. EGPB still broken, even after deinstalling : no Default came back.

I reinstalled EGBP and unticked the sloped runway Option. After that the Airport was displayed correctly, even i ticked the sloped runway Option afterwards.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now