Recommended Posts

Posted (edited)

Hi to everyone,

Some of you know as we talked on other topics about the ATR by Carenado that I have started a bug list and I have reported since then many anomalies of this product. The respective topics are:

 AND 

 If an admin would consider it more appropriate, I would like also to move all three topics in a single one, to have it more clear for everyone what we have discussed during the time.

In the following, I will present an updated list with all the bugs that I've discovered on the ATR 42 and everyone is invited to comment about this post and to add if they found anything else.

Today a version 1.1 of the ATR has been released and even if I've written in the past what bugs I've found and sent the list to the Carenado team, for some reason, they didn't replied to my email and some of the bugs are still present. I tried to contact them via other channels, as you may know this already and they said that they have received my emails, but they hesitate to tell me if the manager of the team accepts to join the team and to offer them my help, knowledge and materials, for free, to build a patch for this aircraft, to simulate it as real possible, to solve all the bugs and to make it for real the most ambitious and biggest project.

The first thing I would like to say about the ATR is:

Congratulations for the external model, the PBR looks stunning!

            The propeller brake is correctly simulated, as well as Power Management (PWR MGT) settings, power ratio, fuel flow and flight performance. There are many other things looking good or correctly simulated, but lets concentrate about what's wrong. So, below is the list of what I've found so far:

PART A

- The status of  the systems, button and switches is not correct in "Cold & Dark" mode. (see Cold & Dark status below, part b.)

- When the battery is switched to ON position, MFC test is not performing. In fact, when selecting the "Cold & Dark" option, the MFCs are selected OFF, which is incorrect. When the MFCs are performing the self-test, MFC 1A & 2A should flash 3 times, then 1B & 2B. After that, DC power will be available to the aircraft.

- External power not modelled correct, or not fully available. It appears as AVAIL both on DC and ACW a short time after switching battery on, but after a short while, DC EXT PWR goes off - it is the main EXT PWR in real life, not the AC one. When the DC EXT PWR AVAIL light goes off, the ACW remains on, but has no effect on electrical system. If possible, would be nice to add a power cart like the one from the S550 Citation..

- ENG OIL alarm at startup, for both engine. It shouldn't come on as modelled in the sim.

- "ON"/"FAULT"/"OFF" lights for the pushbuttons do not lit according to the status. They don't work at all if loading the sim with the ATR from the start, you have to load the sim with another aircraft and after that load the ATR.

- Big issues with the hydraulics. With the Condition Levers on FTR position, "OVHT", "LO LVL" and "LO PR" are all lit, which is incorrect.

- NP values are too high for the FTR and AUTO positions of the Condition Levers. In FTR detent, the NP should be around 15%, and in AUTO detent, the NP should be stabilized at 71%.

- LO PITCH is illuminated when the engines are off. LO PITCH lights illuminate after 15 seconds from unfeathering to low pitch (moving condition levers from FTR to AUTO).

- When engaging IAS mode, the minimum speed on the ADU is "0 (kts)", which in fact should be "80 (kts)".

- Electrical "OVRD" (override) and "UNDV" (undervoltage) lights are always on.

- Recirculation fans are FAULT if no engine started and ON with engines started. The recirculation fans can operate independent of the engines, they just recirculate the air inside the cabin.

- In HOTEL MODE operations: Recirc Fan 1 fault, Pack Valve 1 Fault, OVHT & Leak on Bleed 1. In hotel mode, only Bleed 1 should be fault, because the engine is not providing air. Pack valve is operative via ground crossfeed valve (GND XFEED VLV) from bleed no.2. OVHT & Leak should be off (extinguished).

- Nav waypoints are always ON on the EHSI display and all of the nav waypoints near the aircraft are displayed. This is incorrect, because in real life, only the waypoints from the GNSS flightplan are displayed and maximum 5 waypoints at a time.

- ATPCS test is not modelled.

- "INST" (instruments) rotary buttons controls all the lights inside the aircraft, including the cabin lightning - it should control only instruments lightning.

- "LT FLOOD" is not modelled. In fact, INST button is controlling the flood light also (yellowish light beneath the AFCS panel).

- Storm light is not modelled - it is a powerful neon light beneath the AFCS panel.

- NAV BRG selectors: on NAV 2 selector (ADF/VOR/NAV), if you click on the side of the selector, it changes NAV 2 selection. If you click on the upper side of the selector (white line), it changes NAV 1 selection. This bug is only valid for the NAV 2. NAV1 BRG selector works correct.

- No RDR/TERR mode available.

- RCL/CLR/TO INHI modes are not modelled, as well as GPWS test.

- If you press a button, it remains on. For example, if you press once HYD AUX PUMP button, to engage the prop brake, the READY light will be always on, until if you press again the pump button. In real life, it is on for only 30 seconds.

- No ALT Alert during climb or descend, when 1000 ft apart from selected altitude.

- If you press HDG bug, it syncronizes the HDG. For CRS, it shows a direct to value. This is not correct for the real aircraft.

- You cannot intercept a VOR radial or the ILS if you are in the FMS mode and showing the map, you have to be in NAV mode and full rose mode or arc. In the sim, you can intercept the ILS while in FMS or FMS map displayed.

- With CL in FTR, ACW GEN FAULT, BLUE and GREEN hydraulic main pumps LO PR. This is correct. AUX PUMP LO PR, OVHT, LO LVL lights should be off.

- SVCE UNLK does not come on when the service door is open.

- Some sounds should be changed, because there are no vocal aural alerts, as for example "Altitude Select" or "No takeoff".

- If a pushbutton is in OFF position, no "FAULT" light should be illuminated.

- When engaging the autopilot, if Yaw Damper has not been previously engaged, it engages automatically when pressing the AP button on the AFCS.

- Fuel crossfeed not working properly - still taking fuel from both tanks.

- The last two indicators of the engine parameters (Fuel Flow / Fuel Used) are two separate gauges. The analog one, the needle, shows the Fuel Flow, which is the current fuel flow per hour, and the digital one shows the fuel used, how much fuel we have burnt so far. In the sim, the both of them are showing the fuel flow, but no fuel used.

- When APP mode armed, the glideslope can be captured before the localizer.

- The sounds of the AFCS (autopilot) are not accurate, because the knobs don't have steps, so they do not "click" when turning left or right (heading, course, altitude selector, pitch wheel)

- As a suggestion, if possible, main entry door, cargo door and service door to be opened separately via windows manager.

 

In the version 1.1 I've discovered the following bugs:

- When pressing on the "OVHT" annunciator light, the PACK Valves comes ON or OFF, depending on the status (if ON, they will switch to OFF and vice versa).

- When performing an Annunciator Light Test - the master warning sound is triggered and it shouldn't.

- "EMER DOOR UNLK" on the overhead panel is ON when the doors are open, but this is incorrect, the emergency door is in the cockpit ceiling.

 

PART B

Cold and Dark status:

NOTE:

1. Here is included only what should be changed, what is correct is not mentioned below.

2. This list was created for version 1.0, but some bugs are still present in the version 1.1.

 

1. OVERHEAD PANEL:

·         LOOP A & B (both engines) pushbuttons - ON

·         MFC pushbuttons  - ALL ON.

NOTE: When battery is switched ON, MFC should perform an autotest as described above.

·         Fuel Pumps - OFF

·         Electrical "OVRD" & "UNDV" - OFF (extinguished)

·         DC BUS 1 & 2 EMER BAT CHG pushbuttons - ON

·         DC GEN 1 & 2 pushbuttons - ON (engine being shutoff, FAULT light illuminated)

·         PROP BRK - ON or OFF (depending on the operator)

·         HYD Blue & Green Main Pumps pushbuttons - ON (due to lack of ACW Generators, FAULT light illuminated)

·         HYD AUX Pump pushbuttons - ON

·         HYD XFEED pushbutton - OFF

·         ACW Generators 1& 2 pushbuttons - ON (FAULT light illuminated, no propeller spinning)

·         AFR AIR BLEED pushbutton - ON

·         Oxygen pushbutton - OFF

·         Exhaust Mode - ON (NORM) - no light -

·         RECIRC FANs, PACKS, BLEEDS pushbuttons - OFF (correctly shown in sim.). OVHT, LEAK and FAULT lights should be OFF (extinguished).

·         ATTND CALL: "EMER" and "CALL" annunciators are separate, depending on what button the flight attendant is pressing to call the cockpit.

2.  MAIN PANEL:

·         CRTs - OFF

·         Red flags on RMI - OFF (Flags on RMI indicates the AHRSs are not aligned properly, not that there is no signal from the ground station, as simulated now).

·         Takeoff bugs (white triangles) - 90%

·         Captain left side - TERR - ON

3. Pedestal:

·         Gust lock - ON

·         Radio stations  - OFF

·         Transponder should have also an OFF position. Radio COM stations cannot be switched off in sim, altough there is an "OFF" position.

 

Wish you all the best,

Alex

Edited by 46Pilot
  • Like 5

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Excellent report!. Very helpful.

Cheers, Ed

 

Share this post


Link to post
Share on other sites

hola yo tengo un problema con la fmc no puedo actualizar su airac y ya tengo la version 1905 como puedo solucionar eso 

Share this post


Link to post
Share on other sites

Question on this as I am unable to locate the update to the AT42. I have had it for 2 days I believe it is still the 1.0 as the file itself says AT100 vs something like AT110. Can someone point me in the right direction or did I miss something?

Thank you,

Jason

Share this post


Link to post
Share on other sites
7 hours ago, 46Pilot said:

- When APP mode armed, the glideslope can be captured before the localizer.

Not sure if this is a bug. On e.g. the 767 this is a customer option.

Share this post


Link to post
Share on other sites
Posted (edited)

@FDEdev oh, ok... as far as I know, it's not allowed to start the final descend until established on the localizer..

Edited by 46Pilot

Share this post


Link to post
Share on other sites
Posted (edited)

@Fresjay76 you have to uninstall the existing version, go to into your carenado account and download the installer again.

Edited by 46Pilot

Share this post


Link to post
Share on other sites
Posted (edited)
56 minutes ago, 46Pilot said:

it's not allowed to start the final descend until not enstablished on the localizer..

I assume that you mean until established. This feature is very convenient if you are e.g. still above the cleared altitude and you are about to capture, or just have captured the LLZ.

Edited by FDEdev

Share this post


Link to post
Share on other sites

FYi, it still says not established, 😉 this was what I was referring to, not the typo.

Share this post


Link to post
Share on other sites
11 hours ago, Fresjay76 said:

Question on this as I am unable to locate the update to the AT42. I have had it for 2 days I believe it is still the 1.0 as the file itself says AT100 vs something like AT110. Can someone point me in the right direction or did I miss something?

Thank you,

Jason

Download it again, most probably v1.1 is inside the zip file now.

Cheers, Ed

Share this post


Link to post
Share on other sites

46Pilot and Edpatino, Thank you for your reply's. Got the patch installed and was pleasantly surprised to see my FPS issue resolved but the VAS usage not so much. But since my switch from FSX:SE to P3D is imminent I am not overly worried about it. The big reason I bought the plane was it cross compatibility between the 2. I have many a payware that will not do this, at least not to any version above V4.3. I plan on going to V4.5 so having this as a good option is very nice. 

I also want to thank 46Pilot for his insight into the operations of the CL, PL, and Power MGT switch in other threads. Has made my controlling of the aircraft more understandable and enjoyable. I also have the Majestic Dash-8 so this is now my easier go to for short commuter flights. Especially while flying around in Europe.

Thanks again,

Jason

Share this post


Link to post
Share on other sites

So did 1.1 actually fix anything of consequence? Seems like it's still pretty buggy.

Share this post


Link to post
Share on other sites
Posted (edited)

The patch fixed a few things. I just did a full flight with the aircraft. Still can't get the plane to establish on ILS or glideslope not that it is hard to land but the glide slope did show up on the FD. Issues still persist in the form of FMS not proceeding through the flight plan and now a GSX issue. I have no baggage loaders, or correct number of passengers. I loaded and unloaded a whole 2. GSX says it uses the aircrafts config file to judge all this but the cfg's look fine to me. So not sure what I am missing. All in all was still a fun plane to fly and will fly and do what you tell it for the most part. Just immersion type issues still persist. Also did a Hotel start for the first time, that was pretty slick using the procedures @46Pilot put out in another thread. Sadly GSX would not work in this state because it thinks a engine is spooled up. Live and learn. Really hope they iron out more of these bugs.

Jason

Edited by Fresjay76

Share this post


Link to post
Share on other sites

@46Pilot

Thanks for this extensive bug list, I’m going through and fixing this aircraft to the best of my abilities, we had a bug list we built with the assistance of an ATR captain, I have worked around ATRs for years so have found lots to fix!

So far I have corrected:

- Incorrect Tank Capacities 

- Leading zero on AFCS Alt select e.g. 05000

- Added CPL lights to AFCS and click spot

- Modified Fuel flow gauges to show fuel burn per engine (in kgs not lbs) and increase the digital readout to four digits.

I’ll add your bug list to mine and see what I can fix, a few interesting ones to add are that the Prop Brake logic is broken to the point where it functions perfectly fine without any hydraulic pressure, you can taxi up to 26kts single engine taxi in hotel or feather 😂

Share this post


Link to post
Share on other sites
1 hour ago, dannyridz91 said:

So far I have corrected:

- Incorrect Tank Capacities 

- Leading zero on AFCS Alt select e.g. 05000

- Added CPL lights to AFCS and click spot

- Modified Fuel flow gauges to show fuel burn per engine (in kgs not lbs) and increase the digital readout to four digits.

I didn't see any problem with tank capacities, I will check again. Should be 4500 kg in total.

On AFCS the altitude below 10000 does not have a leading 0.

CPL light with clickspot, yes, it should be.

 

If you consider that we can do a patch without legal problems from the carenado, and your think I can help you, send a PM to me. Carenado team members don't reply to my emails so I took it as a "No", they don't need my help.

Share this post


Link to post
Share on other sites

 - The beacon light does not seem to work when starting from cold and dark, and until the engines are running. Even with Engine #2 already in hotel mode, the beacon did not flash at all. When #1 was started, then, and only then, the beacon started working.

- When #2 is in hotel mode and you start #1, the propellers immediately start spinning at full speed! When you do not use hotel mode, they are fine, gradually start speeding up their rotation. However, when #2 is in hotel mode, even #1, which is the opposite engine, starts with no gradual "speed up", but as soon as you move the CL to Feather, the propeller immediately turns at full speed...

- Sometimes the white "up and down" arrows on the EFIS control panel that manipulate the MAP range, as well as the text on the other EFIS buttons simply do not show, leaving blank, empty buttons.

- Shutting down the engines, with the CL in shutoff position, the #1 propeller never stops spinning.
https://drive.google.com/file/d/1M1ixUT85kc0yupYVof-D3ZQupkvPTEkT/view?usp=sharing

- Often there is a weird 3D cube seen from within the VC, looking out on the right flight deck window back toward the wing. What the heck, really?
https://imgur.com/Qu5EKzA

This product is a joke. My first and possibly last Carenado purchase.

Share this post


Link to post
Share on other sites
Posted (edited)

I don't know, I don't have the beacon light issue... Have you installed the version 1.1? Maybe a bug in V1.0, but I cannot check it as I have installed V1.1 ...

Edited by 46Pilot

Share this post


Link to post
Share on other sites

The beacon issue is with 1.1. I tested this yesterday and noticed that it won't flash unless the engines are both turning when coming out of hotel.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now