Jump to content

gionnim

FS9 on Windows 7 starts only on the second attempt!

Recommended Posts

Hi everyone.
I expose my problem, which appeared in these days after months of perfect functioning:

I try to launch FS9, as usual administrator, etc., so I confirm with YES and .... nothing happens anymore; a few seconds of the blue circle that turns and then stops; raise a second time, I confirm and, this time, fs9 starts immediately !!

The problem appeared both on a pc with win7 32 and on one with win7 64. I tried to remove the KB3086255 update as suggested on the internet (but for the total failure to start FS9) but nothing. XP mode does not solve. Reinstalling FS9 is useless, as you don't need to delete FS9.cfg and have it re-created. Also tried the Registry repair that found the path regularly.
I already have the 9.1 version with the NO CD patch, now as before, when it worked at the first launch, both on one PC and on the other!
Besides giving my head in the wall, you have some suggestions for me! (! _!) Thank you and thank you in advance.☹️
Ah, ps: all this at the first start of the PC day; for the rest of the day FS9 continues to start normally at the first click.

Share this post


Link to post
Share on other sites

Yes - I had the same problem recently, and I found a solution after a lot of searching:

http://ubeogesh-things.blogspot.com/2012/08/resolve-it-finally-game-explorer-aka.html

This article explains the issue, and also contains a link to a simply batch file which you should download and run as administrator.

This will automatically rename the correct file (depending on either 32bitor 64 bit system). It worked for me and now FS9 starts up first time.

  • Like 2

Graeme Butler

Share this post


Link to post
Share on other sites

No worries Ed - I only experienced this recently, so suspected some nasty MS windows update caused it. Anyway - all good on my system now!

 


Graeme Butler

Share this post


Link to post
Share on other sites

Oh great!! Thanks for this. I spent the last week doing some tweaks to FS9 and managed to get it running better than it has been fro a long time, then just last week I could only start FS9 on the second attempt, I thought I had broke it ! gotta love windows updates 🤣

Share this post


Link to post
Share on other sites
Posted (edited)

Great greameb! Solved! Very good! Now I can sleep quite finally!😂👍

Thank you very much!

 

Edited by gionnim

Share this post


Link to post
Share on other sites

Well guys the issue is back again for me on win7 64. Using the batch file doesn't seem to work anymore for me. 

Is anyone else having the issue again?

EDIT: ok seems the batch file was not doing what it should so I manually changed the file name and it works. Looks like steam was blocking the rename. So now I might make a small batch file myself that just renames the file incase it comes back. 

Edited by domvc10
Found solution to my question

Share this post


Link to post
Share on other sites

Go over to FlightSim.com and search for my forum post named: "FS9 needs a second startup". The end solution is a rather simple registry edit.

Good luck.

Hans

Share this post


Link to post
Share on other sites
On 6/17/2019 at 5:39 AM, gionnim said:

Great greameb! Solved! Very good! Now I can sleep quite finally!😂👍

Thank you very much!

 

 

I'll add to this topic in saying 'rundll32.exe *32' service is a serious problem on a couple of fronts with FS9.  I found running FS9 with this service running causes performance issues in FS9.  Not knowing what's going on you'll have double instances of FS9 running in the background because this service is screwing things up.  This must have started like stated above with some patch from Microsoft. As I have unneeded startup services shut down in 'MSCONFIG' by default, this service auto starts when FS9 is initiated. If left unchecked you'll find FS9 never loads up and you have to launch it again to get FS9 to load.  In reality like I just said you'll have two instances of FS9 running causing further performance issues let alone 'rundll32.exe *32' being a performance hog itself when running along side FS9.  

What I do when launching FS9:

1. Load up Windows Task Manager to see the services running.  I found 'rundll32.exe *32' not running initially.

2. Run FS9 and notice it never starts but 'rundll32.exe *32' appears with FS9.exe showing up but never actually running.

3. I delete the FS9.exe instance but leave 'rundll32.exe *32' running as FS9 needs this service to kick off FS9.

4. I load up FS9.exe again and found it loads up. At the FS9 splash screen I remove 'rundll32.exe *32' in Task Manager.  FS9 continues to load.

5. Once loaded up I found FS9 to run better than it ever has before, 'rundll32.exe *32' actually stifles performance of FS9 and doesn't need to run when FS9 is running.  Again FS9 seems to need it to initially load up.

 

Not sure when this started but 'rundll32.exe *32' is an issue these days.  Never use FS9 with this service running.  Do the steps above and you'll notice an improvement in in sim performance from FS9.

Edited by Dillon

PREPAR3D v4/FS9.75

Share this post


Link to post
Share on other sites
20 hours ago, Dillon said:

Not knowing what's going on you'll have double instances of FS9 running in the background because this service is screwing things up.  

So if you use the fixes above this will stop, you will not have two instances of fs9 running.

It's interesting what you say about shutting down the rundll32 service though, I do not seem to have any performance issues now I have applied the fixes however I will shut down the rundll32 service like you to just to test. Always happy to try any new tricks!

Share this post


Link to post
Share on other sites
3 hours ago, domvc10 said:

I will shut down the rundll32 service like you to just to test. Always happy to try any new tricks!

 

Let me know. 


PREPAR3D v4/FS9.75

Share this post


Link to post
Share on other sites

No difference. Loaded up once my normal way and then once with stopping rundll. Exactly the same flight and nothing noticeable frame rates the same. 

 

EDIT: Just to add the rundll32* was showing 00% in the task manager too.

Edited by domvc10
extra info

Share this post


Link to post
Share on other sites
9 hours ago, domvc10 said:

No difference. Loaded up once my normal way and then once with stopping rundll. Exactly the same flight and nothing noticeable frame rates the same. 

 

EDIT: Just to add the rundll32* was showing 00% in the task manager too.

 

Interesting... Very different on my end especially when coming or going out of NY.


PREPAR3D v4/FS9.75

Share this post


Link to post
Share on other sites

Have you by any chance applied the other fixes in this thread. Before I did I had to start FS9 2 times and if I recall rundll32 was also running 2 instances. After almost 20 years now simming and reading all sorts of fixes, what works on one persons machine has no affect on anthers quite often, the massive possibel variations between PC set ups is just so huge. The good thing though is you have a performance boost 😃 maybe it will help someone else too. Thanks for the tip anyway.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...