Jump to content

Recommended Posts

Hello and Thanks in advance...   As I always try to keep the most updated Computer system Windows 10... always updated  and so forth, i have now run into the following conundrum.

Before I  start  Prepar3d 4.4  i activate my VR Samsung Odyssey set it aside  then open Spadnext is next and then RAA  (run as admin)  Prepar3d let it start up... pick parameters of flight and press FLY.  Prepar3d will load and the plane is on tarmac and ready to go.  everything is good so far

I then start up Virtual Reality SteamVR and put on headset and the aircraft sits 5 to 6 feet beneath me... which in the past i just went to pull down menu and reset the viewpoint but now that just briefly works and then resets itself to 6 foot above the cockpit  external and wont let me inside the airplane itself... what the....   Has any seen this  and know what setting i am forgetting.  I've uninstaller the VR unit and then reinstalled   i've uninstalled EZDOK and updated that but no luck.

 

Know it is something simple...  everything is run as administrator

Thanks Steve

Share this post


Link to post
Share on other sites
Posted (edited)

It is always that way, just center the HMD. You can set the desired key in the control settings. Sometimes it jumps back, but not more than once.

Edited by Chandler

Intel Core i9-9900K - ASUS ROG Maximus XI Formula | Intel Z390 - 32GB Corsair Vengeance RGB Pro DDR4-3200 - GTX 1080  -1TB Samsung 970 PRO - 1000W - Corsair HXi Platinum Series - ASUS Xonar DGX - Corsair H150i Pro RGB - Samsung Odyssey Plus

Share this post


Link to post
Share on other sites

I use a Rift S with ChasePlane and you just select the view inside or outside  and recenter HMD while in VR which is assigned to a key. I actually reassign that key command to a button on my Virpil throttle using Linda or assign to a VoiceAttack command using VoiceAttack as I do with dozens of commands making VR flying much easier, but that’s not your question.

Bottom line recentering the VR headset while in VR looking forward using assigned key command works.

Joe


I9-9900KS @5.1Ghz/ Corsair H115i / Gigabyte A-390 Master / EVGA RTX 2080 Ti FTW3 Hybrid w 11Gb / Trident 32Gb DDR4-3200 C14 / Evo 970 2Tb M.2 / Samsung 40inch TV 40ku6300 3840x2160 res @30 hz  / Corsair AX850 PS / VKB Gunfighter Pro / Virpil MongoosT-50 Throttle / MFG Crosswind Pedals /   LINDA, VoiceAttack, ChasePlane, FFTF, Pilot2ATC, Oculus Rift-S VR 

Share this post


Link to post
Share on other sites

It's just one of those problems that seem to persist.

For whatever reason sometimes the goggles revert to the default setting and not the one you are currently sitting in.

I noticed this on the Rift S because my roomscale setup was defaulting to a forward direction away from my computer (because I want the cables at my back all the time).

But my desk on which I fly on is facing the other direction. So whenever I was flying in P3D sometimes the viewpoint would suddenly revert 180° and outside the aircraft, because that is what my guardian setup was defaulting to.

If I use a default guardian setup in the exact seating position I will be simming in I don't have that problem.

Share this post


Link to post
Share on other sites
19 hours ago, sluihn said:

Hello and Thanks in advance...   As I always try to keep the most updated Computer system Windows 10... always updated  and so forth, i have now run into the following conundrum.

Before I  start  Prepar3d 4.4  i activate my VR Samsung Odyssey set it aside  then open Spadnext is next and then RAA  (run as admin)  Prepar3d let it start up... pick parameters of flight and press FLY.  Prepar3d will load and the plane is on tarmac and ready to go.  everything is good so far

I then start up Virtual Reality SteamVR and put on headset and the aircraft sits 5 to 6 feet beneath me... which in the past i just went to pull down menu and reset the viewpoint but now that just briefly works and then resets itself to 6 foot above the cockpit  external and wont let me inside the airplane itself... what the....   Has any seen this  and know what setting i am forgetting.  I've uninstaller the VR unit and then reinstalled   i've uninstalled EZDOK and updated that but no luck.

 

Know it is something simple...  everything is run as administrator

Thanks Steve

Check steam settings (within VR) for resetting seated position and/or adjusting it.

To set or reset the seated position while in VR, do the following:
  1. Press the System button to bring up the System Dashboard.
  2. Select > General.
  3. Select Reset seated position, and then follow the prompts to complete the process.

Orbx Beta Tester
Just Flight Beta Tester
 
We are all connected..... To each other, biologically...... To the Earth, chemically...... To the rest of the Universe atomically.
 
Devons rig
Intel Core i7 8700K @ 5.0GHz / 32.0GB G.SKILL TridentZ Series Dual-Channel Ram / ZOTAC GAMING GeForce® RTX 2080 Ti Triple Fan / Sound Blaster Z / Oculus Rift VR Headset / Klipsch® Promedia 2.1 Computer Speakers / ASUS ROG SWIFT PG279Q ‑ 27" IPS LED Monitor ‑ QHD / 2x Samsung SSD 850 EVO 500GB / Windows 10 Pro 64-bit / Gigabyte Z370 AORUS Gaming 5 Motherboard

Share this post


Link to post
Share on other sites

Thanks to Everyone whom responded to the situation at hand and sorry its taken so long to respond.  I have literately spent every night since posting trying to track down an answer to this and just when i get one good flight in proper position as soon as i hit recenter button the whole configuration goes bonkers and right back where i started..  There is a configuration somewhere on this computer that thinks i am 9 ft tall.   Its to bad airplanes dont have sunroofs i probably could have gotten by.  Just for Sticks and Giggles, i install aerofly fs just to see. Lord and be hold i wish their airplanes had sunroofs also the very same problem.  So i think that will rule out flight sims as a root to this problem.  What i am using is the samsung Odysessy and steamvr somewhere between the two is a bad configuration....  Thanks for all the leads...  

Thanks again

Steve 

Share this post


Link to post
Share on other sites
Posted (edited)

If you have the addon AdvancedSettings installed - uninstall it.

Edited by whitav8

PC=9700K@5Ghz+RTX2070  VR=HP Reverb|   Software = Windows 10 | Flight SIms = P3D, CAP2, DCS World, IL-2,  Aerofly FS2

Share this post


Link to post
Share on other sites

Hello....  Thanks for the advice.  When i log on tomorrow i will make sure that is not installed, I actually went the whole nine yards and uninstalled steamvr steam reset WMD environment.... then reinstalled  and as for Aerofly FS2  (amazing btw in VR... most things scaled very well)  worked with a little scare at the begininng  you see before and after when i started AF2 and Prepar3d the vr would not reset to cockpit pilot view in Prepar3d the pilot view was 8ft above the airplane and any attempt to reset view inside cockpit would just flash at you and return to 8 ft above airplane,  when i would start AF2 the opposite happened went i put on VR Google the Game would sit in a blue screen 8ft below i could almost touch it with the Paddles    just weird...   uninstalled and reinstalled at least got me a wonderful flight from RDU to TMB tonight and i'll take that for the win.  Going to start a new adventure when the Brunner Yoke and Rudder system arrives.... Oh cant wait.

Thanks again

Steve

Share this post


Link to post
Share on other sites

So to continue with discovery....  started up P3Dv4.4 like mentioned in previous thread... ezdok might have been my nemesis.  Sitting on tarmac 6 to 8 ft above aircraft looking down on the hood... for some reason I  hit the numbers 2 key and it allowed me to lower prospective into cockpit pressed  numbers 2 again and I saved the position and evidently that's the part of equation I missed for 4 weeks.   I just naturally pressed numbers 2 on keyboard repostioned  pressed numbers 2 again and saved .    I knew the pilot view could be manipulated this way,  did not realize it would solve my conundrum. 

Share this post


Link to post
Share on other sites

P3D also has a default Virtual Reality view preset in which you can't pan or move around with normal controls, only with the headset.

I use that to avoid accidentaly paning down with my controller.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...