Jump to content

Sign in to follow this  
awash2002

no import flight plan (resolved)

Recommended Posts

Just now, fppilot said:

Uhhh.  I did not say anything about a "-"
 

Then what pray tell is your issue now?

I explained this in detail that this happen on fresh setup every time.  If you are not an official RXP representative then please them handle this. 


Check out review of new scenery Airport Enhancement Package (AEP) https://www.youtube.com/watch?v=8ppgiJYzpmE

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Sims Smith said:

If you are not an official RXP representative then please them handle this. 

I responded only because you quoted me and then in the writing of your message clearly appeared to relate the "-" sign to something I wrote. The reason for my second comment is that you appear to have found a solution, but continue to harp.  Just cannot understand.  I am perhaps the most experienced user around here at dissecting the Garmin .gfp import syntax so just trying to understand your continued issue.  If you would like I can point you to the Garmin publication.  Or you may look through previous topics here about importing .gfp files.  I have posted the link in several of them over the past two years.

I see that RXP has posted a pair of recommended posts that deal directly with the minus sign...

Edited by fppilot

Frank Patton
MSI Z490 WiFi MOB;  i7 10700 3.8 Ghz CPU; Ripjaws 32 gb DDR4 3600; ASUS GTX 1070 TI Turbo 8GB; MasterCase H500M; Corsair H100i Pro cooler; Corsair RMX850X PSU; ASUS VG289 4K 27"; Former USAF meteorologist & ground weather school instructor; AOPA Member #07379126 
                        There is no limit to what a man can do or where he can go if he doesn’t mind who gets the credit! - Benjamin Jowett

 

Share this post


Link to post
Share on other sites
On 6/27/2020 at 1:21 PM, fppilot said:

RXP must be correct.  I tried to duplicate the issue you identified and I failed.  I replaced underscore characters with dashes.  The result is in the image below.  It is the import screen and take a look at the top flight plan in the listing.  Dashes.....

image.png.f1ae942eb7777e3e2b7f510e0635f22a.png

This is the GNS that you can still have the "-" instead of a "_"......Hmmm do you have the GTN in the sim and can try the same thing?  That might again open up more information as to what is going on?

If you don't I can always try to do something....I just can't get onto the sim till later .... watching the 2.5 year old currently 🙂 so only able to sit on my MacBook and visit the forums 🙂


Les O'Reilly

Share this post


Link to post
Share on other sites
17 hours ago, Sims Smith said:

What is more strange is once "import button shows up" subsequent files can than have "-" and it doesn't hide the Import button any more.  

Hi,

Thank you for your astute research with this.

I'm not sure what you mean with 'subsequent files' though.

Do you mean (NB: all this with only 1 file in the folder):

  1. You only have 1 .gfp file there with a hyphen and it doesn't work.
  2. You rename this single file with an underscore and it works.
  3. You rename the very same file again back with a hyphen and it keeps working even if the file name is back to the one not working in the first place?

Then what about this:

  1. Take the file with a hyphen straight from the flight planner.
  2. Manually delete the hypen and type a hyphen again with your keyboard.
  3. Launch the GTN and see whether it activates the Import button.

@fppilot You are right it is custom Garmin code inside the trainer which is in charge of detecting the FPLN folder and importing the files. However we do have some influence on this feature for example in augmenting it with folder indirection via shortcuts. We can also influence some of the trainer 'file detection' code which in this case is using really standard Windows API to 'search' the folder. This could let us augment the implementation to some degree and this is worth exploring what is the trouble with some customers reporting having an issue listing the files.


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
1 hour ago, Sims Smith said:

I explained this in detail that this happen on fresh setup every time.  If you are not an official RXP representative then please them handle this. 

No need to be harsh with any forum member asking questions in order to help you. Whether it is wrongly said, or wrongly read, you also have to take in account frustration is a powerful filter which is lowering one's ability to comprehend situations.

I do understand the frustration and I do want to get to the bottom of this issue you're experiencing and reporting. Please understand there is no magical known formula to solve it otherwise we'll publish it instead of asking questions which might not seem of any help to you directly, but are helping us a lot indirectly in formulating hypothesis toward finding the solution.


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

I have no problem member asking clarification to solve the issue but constantly being dismissive, and sarcastic words like "pray", insulting word like "harping" are not helpful and doesn't belong in tech support forum.  I am a developer myself.  While it is true i eventually I solved the issue but fixing the root cause is important to reduce initial support and goes long way on good customer initial experience. This is not harping but helping RXP!

Back to the topic: 

Steps to reproduce  

Fresh X-Plane Install

Fresh GTN 750 install

An empty directory with no file C:\ProgramData\Garmin\Trainers\Databases\FPLN

Create a valid gfp file but name it ICAO-ICAO.gfp

In X-Plane Plugin->Reality XP GTN->GTN 2->GTN 725 2

In GTN touch click 

In GTN touch Flight Plan -> Menu -> Catalog -> Menu -> In the "Flight Plan Catalog" Menu no button called "Import" . It only has "Delete All"

* I did regular install all using default choices.  I am NOT running X-Plane as administrator. .

The fix I found.

Shutdown X-Plane.

Go to C:\ProgramData\Garmin\Trainers\Databases\FPLN

Rename the file from ICAO-ICAO.gfp to ICAO_ICAO.gfp

Start X-Plane

Do all the process above and now I can see the import button.

tPhzJCt.png

This maybe one of those bugs that may have other variables in play. Could be super rare and hard to reproduce.  I experienced it twice with the same fix procedure.  You mileage may vary.

I don't have the technical spec to confirm that file naming convention with "-" is invalid. All tools that creates .gfp needs to comply.  If this is the case, my feeling is other tool developers probably doesn't know this and it could be an education process and maybe something worth highlighting in the manual. 

Let me know how else I can be of help. 


Check out review of new scenery Airport Enhancement Package (AEP) https://www.youtube.com/watch?v=8ppgiJYzpmE

Share this post


Link to post
Share on other sites
7 minutes ago, Sims Smith said:

Let me know how else I can be of help. 

Already written above (you've just re-answered points 1 and 2 below, but what about the rest of the troubleshooting suggestions?)

Do you mean (NB: all this with only 1 file in the folder):

  1. You only have 1 .gfp file there with a hyphen and it doesn't work.
  2. You rename this single file with an underscore and it works.
  3. You rename the very same file again back with a hyphen and it keeps working even if the file name is back to the one not working in the first place?

Then what about this:

  1. Take the file with a hyphen straight from the flight planner.
  2. Manually delete the hypen and type a hyphen again with your keyboard.
  3. Launch the GTN and see whether it activates the Import button.

Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
3 minutes ago, RXP said:

Already written above (you've just re-answered points 1 and 2 below, but what about the rest of the troubleshooting suggestions?)

Do you mean (NB: all this with only 1 file in the folder):

  1. You only have 1 .gfp file there with a hyphen and it doesn't work.
  2. You rename this single file with an underscore and it works.
  3. You rename the very same file again back with a hyphen and it keeps working even if the file name is back to the one not working in the first place?

Then what about this:

  1. Take the file with a hyphen straight from the flight planner.
  2. Manually delete the hypen and type a hyphen again with your keyboard.
  3. Launch the GTN and see whether it activates the Import button.

My experience is once the import button show up after a  fix the button will remain visible even if new or existing files or existing file has '-'. 

Therefore doing the 3 "what about this" is something I did yesterday. It will activate import button.  Formatting my HD and start everything from scratch is one way I had this bug reproduced. . 

My guess is there must be a one time/initialization code in GTN import screen that control the current/future visibility of that button. 


Check out review of new scenery Airport Enhancement Package (AEP) https://www.youtube.com/watch?v=8ppgiJYzpmE

Share this post


Link to post
Share on other sites

Your report from yesterday was unclear to me because you were using the sentence "subsequent files".

I'd like you to confirm all this sequence of actions with 1 and the same file only (no other files but 1 in the FPLN folder).

Can you still confirm today the sole file which was not working, then working in replacing the hyphen with an underscore, keeps working once changing the underscore back to a hyphen?

The second series of test is to asses something else with the file name. Please make sure to remove the sole flight plan file in the FPLN leaving it empty, then do 1)2)3), then put the file you've done 1)2)3) on into the FPLN folder.


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
2 hours ago, Sims Smith said:

Fresh X-Plane Install

Jean-Luc. Perhaps move this to the X-Plane GTN forum.  Had no idea this was not FSX/P3D.  Perhaps another X-Plane user can chip in...


Frank Patton
MSI Z490 WiFi MOB;  i7 10700 3.8 Ghz CPU; Ripjaws 32 gb DDR4 3600; ASUS GTX 1070 TI Turbo 8GB; MasterCase H500M; Corsair H100i Pro cooler; Corsair RMX850X PSU; ASUS VG289 4K 27"; Former USAF meteorologist & ground weather school instructor; AOPA Member #07379126 
                        There is no limit to what a man can do or where he can go if he doesn’t mind who gets the credit! - Benjamin Jowett

 

Share this post


Link to post
Share on other sites

@fppilot you are right and I didn't notice either @Sims Smith is running XPlane but has posted in the FltSim forum. There shouldn't be any difference though between the two simulators regarding this feature which is solely GTN trainer related.

  • Like 1

Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
9 hours ago, RXP said:

I'd like you to confirm all this sequence of actions with 1 and the same file only (no other files but 1 in the FPLN folder).

Can you still confirm today the sole file which was not working, then working in replacing the hyphen with an underscore, keeps working once changing the underscore back to a hyphen?

The second series of test is to asses something else with the file name. Please make sure to remove the sole flight plan file in the FPLN leaving it empty, then do 1)2)3), then put the file you've done 1)2)3) on into the FPLN folder.

This is X-Plane. I apologize as I google and it brought me here directly and didn't realize there is a separate dedicated X-Plane forum.  I conducted the series of test and I will message you the finding.  I don't want to confuse the "FltSim " user with XP noise. 


Check out review of new scenery Airport Enhancement Package (AEP) https://www.youtube.com/watch?v=8ppgiJYzpmE

Share this post


Link to post
Share on other sites

Looking forward to the results. You're not confusing anything anyhow because this specific topic is simulator agnostic and depends only on the trainer.

The purpose of the 2nd series of tests is to asses whether the 'hypen' character automatically generated when saving the flight plan from the planner is a 'valid' character for the GTN trainer (there are different hyphen characters all looking the same but different nonetheless for the computer). Manually replacing the hyphen with one you'd type with your keyboard should ensure it is a 'valid' one.

This might seem unnecessary but:
"Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth."


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, RXP said:

(there are different hyphen characters all looking the same but different nonetheless for the computer)

I recall running into this in the past with both software programs and web sites, but not in recent years.  The + and - on the top row of the keyboard were treated differently than the + and - on the numpad.  If I recall accurately I had to resort to using those on the top row.  Never knew if it were the programs and web sites, or perhaps the way the manufacturer coded the keyboard.  Makes me wonder if at one time the ASCII for a hyphen was different from the ASCII for a minus sign, and how software developers and website designers addressed that.  Wonder what character Simbrief is using when writing the file.

Ummm.  Here is an interesting page:

https://en.wikipedia.org/wiki/Wikipedia:Hyphens_and_dashes

Edited by fppilot
  • Like 1

Frank Patton
MSI Z490 WiFi MOB;  i7 10700 3.8 Ghz CPU; Ripjaws 32 gb DDR4 3600; ASUS GTX 1070 TI Turbo 8GB; MasterCase H500M; Corsair H100i Pro cooler; Corsair RMX850X PSU; ASUS VG289 4K 27"; Former USAF meteorologist & ground weather school instructor; AOPA Member #07379126 
                        There is no limit to what a man can do or where he can go if he doesn’t mind who gets the credit! - Benjamin Jowett

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,170.00 of $25,000.00 Donate Now
×
×
  • Create New...