Sign in to follow this  
Guest jbrians

PoolSize: Frame Rate Tweak

Recommended Posts

Last week I suggested that turning Fiber Frame down to a very small value instantly upped the frame rate by a large amount. For some people this caused blurred scenery.I've been fiddling with PoolSize and again setting the value to very small amounts returns a staggering improvement in frame rates. You can try this straight away: Open you FSX cfg and set PoolSize to a large value, say 20 million. Now start FSX and watch it crawl.Now try reducing PoolSixe to a small value, say ten thousand. Look at the difference.Setting BOTH params to a low number will no doubt increase your blurries, but it occured to me that reducing PoolSize can then enable you to set FIBER FRAME to sensible levels (maybe 1.5 to 2.5) but you should still see a benefit from the reduced PoolSize. In short, a combination of the two params, getting them as small as possible but still avoiding blurred textures, is a goal I am looking for.One caveat: If you suffer from stutters, radically reducing the value of PoolSize might make this worse, so beware. Luckily I have rarely seen any stutters in FSX which allows me a lot more leeway.With the above tweaks and Mat Fox and co's invaluable tweaks already discussed I have moved from a lousy 8 fps post-release to around 55 fps with modest scenery/detail sliders and 28 fps with dense settings and a few AI aircraft. I really don't enjoy flying below 28 fps and below 25 the aircraft (especially GA types) are for me not much fun to fly.Kind Regards,Rob Young

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Rob your find on the fiber tweak was amazinf for my computer. I have mine set on .25 now and gained about 10FPS every where even in the big traffic areas.What I like about your tweak is there is nothing I can mess up that can't be fixed just by entering another number or taking it out of my CFG file thanks will now try this one 2.:)

Share this post


Link to post
Share on other sites

>>Setting BOTH params to a low number will no doubt increase>your blurries, but it occured to me that reducing PoolSize can>then enable you to set FIBER FRAME to sensible levels (maybe>1.5 to 2.5) but you should still see a benefit from the>reduced PoolSize. In short, a combination of the two params,>getting them as small as possible but still avoiding blurred>textures, is a goal I am looking for.>Rob nice thread but if I might make one correction:Useable FIBER_FRAME values are between .01 and 1,or thereabouts.RhettAMD 3700+ (@2.5 ghz), eVGA 7800GT 256 (94.47), ASUS A8N-E, PC Power 510 SLI, 2 GB Corsair XMS 3-3-3-8, WD 250 gig 7200 rpm SATA2, CoolerMaster Praetorian

Share this post


Link to post
Share on other sites

Hi Rhett,I don't think there is a definitive setting. I use as low as 000.1 if I use low res textures or low amounts of autogen. If I want more scenery I raise it to stop the blurries.Rob

Share this post


Link to post
Share on other sites

>IIRC ROb, the PoolSize mod was related to stutters while>panning rather than straight framerate.>>Vic>>>Visit the Virtual Pilot's Center>www.flightadventures.com>>http://www.hifisim.com/>Active Sky V6 Proud Supporter>Radar Contact Supporter: http://www.jdtllc.com/Your correct, because it prevents 99% of my stuttering.

Share this post


Link to post
Share on other sites

>Hi Rhett,>>I don't think there is a definitive setting. I use as low as>000.1 if I use low res textures or low amounts of autogen. If>I want more scenery I raise it to stop the blurries.>>RobThat's right, there is no definitive setting. But, Microsoft said FIBER_FRAME was interpreted by the sim as a percentage value, therefore that means anything over 1.00 won't do anything.1.00 would mean 100% of loop time going to scenery rendering. Or was it texture throughput. I can't remember which is which. :)RhettAMD 3700+ (@2.5 ghz), eVGA 7800GT 256 (94.47), ASUS A8N-E, PC Power 510 SLI, 2 GB Corsair XMS 3-3-3-8, WD 250 gig 7200 rpm SATA2, CoolerMaster Praetorian

Share this post


Link to post
Share on other sites

Setting the value at 5 million brought my system to a crawl and froze it. Not right away but after 2 flights of about 20 minutes and after reaching the same area: colorado springs. Most likely due to the amount of objects it had to draw. I did take this parameter out of the cfg, but now maybe I'll lower it less than the default and see what happens. This goes in the terrain section correct?Ian.

Share this post


Link to post
Share on other sites

at the end of the cfg..{BufferPools} << replace with squared bracketsPoolSize=xxxxxxxxxxx

Share this post


Link to post
Share on other sites

poolsize=10,000???from everywhere else i've heard 1mil was default and increasing poolsize decreases stutters...... But then perhaps I just have been misunderstanding all this time, is it less poolsize = less stutters? I have had mine set at 5mil, 10mil, and even tried 20mil, never noticed a difference...

Share this post


Link to post
Share on other sites

No luck. I decreased Poolsize to 10000 and FiberFrame to 1.5 and I easily dropped 8 or more FPS.I think a lot of my problems are stemming from my CPU and memory. I currently am running an AMD 3500+ with 1 gig DDR RAM, however I have a Radeon 1900XTX 512mb video RAM. It is interesting because most of the texture stuff I can near max out and am getting little to no decrease in FPS, however certain things like water detail are kicking my butt.At any rate I am getting 10-15 FPS at Seattle with autogen at normal, water at 1.x low among other things. Interesting concept but I think I have finally tweaked out FSX at this point as much as it will go.Thanks for the help, your original FiberFrame setting of .10 has me running very well.Regards,-Cody

Share this post


Link to post
Share on other sites

Poolsize controlls the amount of video memory devoted to vertex and index buffers (and therefore not to textures). Generally the reason you'd want to tweak this is to increase the value if you are getting stutters. If you aren't seeing stutters it's best to leave it as the default. It's possible that by decreasing the value you free up some video memory to be used for textures, which if you were completely filling your video card before that would increase framerate. But the default is only 1 meg, which means 2 megs of video memory are devoted to buffers, so it shouldn't make much difference.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this