Jump to content

Sign in to follow this  
earthdog

Addon Orginizer for MSFS Prototype

Recommended Posts

Hi!

I am trying out the Addon Organizer and i am receiving the following error message.

I am on Store version, and i can open and edit the content.xml normally.

Also i am running the addon organizer as admin.

Any ideas?

Snipaste-2021-01-04-20-53-21.png


__________________________________________________________________________________________
Elias Stassinos - Author of PTTBuddy - Automatic volume control while you fly / play /stream
My FS Photos - My MSFS Settings

image.png

 

Share this post


Link to post
Share on other sites
2 hours ago, earthdog said:

i can open and edit the content.xml normally.

The error message is misleading. The file and op that it shows are what has last been read. And I can see that it processed the Official folder alright, so the problem is not the content.xml. That was just the last file that has been read before, and the app didn't get a chance to read others..

Something is wrong in the Community folder. All files that MSAO wants to read are checked for existence first, so that can't be it. Maybe a broken junction or symlink (=reparse point)?

Please consider sending me an email. I need to add more error processing around this, but I have no way of knowing what is actually going wrong.


LORBY-SI

Share this post


Link to post
Share on other sites

Same problem here with both latest versions 108 and 109.

Disabled all my Comunity addons but no joy

 


Pierre

Share this post


Link to post
Share on other sites

I will try and catch those file system errors, but it is hard to do that in the blind. If any of you could send me an email I will create a debug version so we can pinpoint the cause. 

Did you use any other tool before, do you have Orbx stuff and/or did you create symlinks manually?


LORBY-SI

Share this post


Link to post
Share on other sites

In the morning i will contact you and we can debug this together. I have orbx , i havemt created symlinks manually but i am using the addon manager which does create symlinks.


__________________________________________________________________________________________
Elias Stassinos - Author of PTTBuddy - Automatic volume control while you fly / play /stream
My FS Photos - My MSFS Settings

image.png

 

Share this post


Link to post
Share on other sites

So i got past the error after your explanation. It was indeed misleading. The problem for me was a symlink that was not correct. It was pointing to a non-existent directory.

It loaded up just fine.

I am using a lot the "Export to Google" feature and i tried it.

I got an error that illegal characters exist in the file.

The strange thing is that after i opened the file the airports i saw where relevant to my old P3D installation. I dont have P3d anymore installed in my drives nor i have sceneries installed. I searched in the KLM an di found no reference to MSFS airports. Is this feature under construction?


__________________________________________________________________________________________
Elias Stassinos - Author of PTTBuddy - Automatic volume control while you fly / play /stream
My FS Photos - My MSFS Settings

image.png

 

Share this post


Link to post
Share on other sites
57 minutes ago, earthdog said:

The problem for me was a symlink that was not correct. It was pointing to a non-existent directory.

OK, I can catch that.

57 minutes ago, earthdog said:

The strange thing is that after i opened the file the airports i saw where relevant to my old P3D installation

Maybe it is an old KMZ file? Were you using the Lorby P4AO back in the day?

Can you please post the error message or send it to my via PM? At the rate that new sceneries are released, there's bound to be many "odd things" along the way, and new errors will have to be caught all the time.


LORBY-SI

Share this post


Link to post
Share on other sites

Ok i will...But i dont have an error message. I will run the google exporter and will send you the info i have

Yes i have used it before for P3D but now everything is wiped. Very strange. Stand by for info.


__________________________________________________________________________________________
Elias Stassinos - Author of PTTBuddy - Automatic volume control while you fly / play /stream
My FS Photos - My MSFS Settings

image.png

 

Share this post


Link to post
Share on other sites
1 hour ago, earthdog said:

now everything is wiped

Everything P3D maybe. But the P4AO KMZ file probably wasn't, by default it is in \Documents


LORBY-SI

Share this post


Link to post
Share on other sites
49 minutes ago, Lorby_SI said:

Everything P3D maybe. But the P4AO KMZ file probably wasn't, by default it is in \Documents

Check your PMs.


__________________________________________________________________________________________
Elias Stassinos - Author of PTTBuddy - Automatic volume control while you fly / play /stream
My FS Photos - My MSFS Settings

image.png

 

Share this post


Link to post
Share on other sites

Hello @ll,

as for the problem described in the OP, version 1.00 b11 takes care of that. It is already available for download.

Best regards


LORBY-SI

Share this post


Link to post
Share on other sites

I am getting a virus alert when I go to download the MSFS addon organizer and the download is prohibited.  I am using W10 Defender.  Am I to assume this a a false alert?

Danny


Danny

Share this post


Link to post
Share on other sites
18 hours ago, DannyR said:

I am getting a virus alert when I go to download the MSFS addon organizer and the download is prohibited.  I am using W10 Defender.  Am I to assume this a a false alert?

Danny

I have the same problem with version msfs_addonorganizer_1_00_b17.zip


Panos Georgotas

Share this post


Link to post
Share on other sites

I too have the b17 and every other before but no errors... I am using ESET Antivirus. In any case i think that it is a false positive.


__________________________________________________________________________________________
Elias Stassinos - Author of PTTBuddy - Automatic volume control while you fly / play /stream
My FS Photos - My MSFS Settings

image.png

 

Share this post


Link to post
Share on other sites
19 hours ago, DannyR said:

I am getting a virus alert when I go to download the MSFS addon organizer and the download is prohibited.  I am using W10 Defender.  Am I to assume this a a false alert?

Danny

Please note the bold red text at the top of the downloads page.

All downloads are constantly screened for malware. Unfortunately there are people who don't consider the Lorby products as helpful and prefer to flag them as malware to SmartScreen.

  • Like 1

LORBY-SI

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    48%
    $12,180.00 of $25,000.00 Donate Now
×
×
  • Create New...