Jump to content

Sign in to follow this  
Stranga

Unable to get G2 started in MSFS 2020

Recommended Posts

I recently got a Reverb G2 and it works fine with everything except MSFS, which is of course the main reason I got it.

The gear I'm running isn't top of the line but should run the game without issues, at least at lower settings;

AMD Ryzen 7 3700X
Asus Prime X570
Asus GForce RTX 2070 Super ROG
SSD Hard Drive

Basically, I start the sim and everything is fine until I am in the cockpit, but when I then go to activate VR, everything goes crazy. 

I do get the VR view on my monitor but it is like it is trying to start but cannot, so it starts/stops every second. This goes on for a minute and eventually it crashes to the desktop. At the same time, inside the headset it keep doing a dissolve from the standard environment as though it is about to start the game in VR, but always resolves back into the environment, never actually showing the cockpit at all. 

I have tried starting the game in our of WMR, SteamXR, or starting VR out of the game. No matter what I do, the exact same problem remains.

I have read through countless posts and watched numerous videos, but I cannot find a solution to my problem, and I could not find anyone having quite the same issue as me. I did try various things, including rolled back drivers, updated drivers, OpenXR, SteamXR, unticking theaters, different settings, low to high graphics settings, re-downloading and installing MSFS. I am a wits end, as they say.

Hope someone can help because I am extremely keen on finally going VR in MSFS.

Thanks !!!
Danilo 

 

 

 

 

 

 

 

Share this post


Link to post

Is wmr open before you start msfs? When you say “starts and stops inside the environment” you mean that inside the headset you see three dots moving around the screens as loading? Steamvr is not open and stays closed right? What settings have you messed with in openxr, etc? Is HAGS on or off? The headset is running at 90hz not 60? There are lots of potential causes unfortunately so going to need a bit more info. 

Share this post


Link to post

Thanks for the reply.

Yes, I have had WMR open before starting MSFS, but I have also tried in other ways.

Basically, when the simulator starts and I get into the cockpit and activate VR, the Headset is actually in the house on the cliffs. When I activate VR it does the sort of dissolve to start the game but then is back in the house. And that repeats numerous times until MSFS gives up and crashes. It's almost like it's trying to fire up but keeps failing to make it happen.

The problem is that if there is a setting somewhere, I have probably messed with it at some point, figuring I'm down to trial and error essentially. I know this doesn't help, but I have been trying various things for 20 solid hours now, so I have tried anything I could think off, and all with ZERO effect on the problem. 

I really dont know what HAGS is, so I cannot say whether it's on or off. OpenXR doesnt seem to have too many settings, butI have tried various ways and am back to basically default. 

 

 

 

 

Share this post


Link to post

Also, I have tried both 60hz & 90hz. 

Honestly, I feel like I have tried every conceivable variation of pressing various buttons, but nothing does anything at all.

I was hoping that maybe someone might recognize the odd behavior with the game seemingly starting VR but then failing at the last moment, and repeating this until it crashes. 

 

 

 

Share this post


Link to post

Try starting your flight a remote airstrip with a simple aircraft (Eg. C172)

I have this problem since the performance hot fix.

Starting the way I suggest is the only way I can use Vr since the update.

PS. I use the G2 as well.

Curious; what is HAGS I see some referring to.?

 

 

 


Robin

Share this post


Link to post
Posted (edited)
47 minutes ago, Romeo_Tango said:

what is HAGS I see some referring to.?

Hardware-Accelerated GPU Scheduling, available under Win10 Graphics settings.

Edited by SierraDelta

Cheers, Søren Dissing

CPU: Intel i9-10900KF @5.1Ghz HT off | Cooler: ASUS ROG Ryujin 360 | GPU: ASUS Strix RTX3090 OC | MoBo: ASUS Maximus XII Hero | RAM: 64Gb DDR4 @3600 | SSDs: 1Tb Samsung M.2 970EVO Plus (Win10), 1Tb Samsung M.2 970EVO Plus (P3D), 1Tb Samsung 860EVO (MSFS) | Monitors: HP Reverb G2, 28" ASUS PB287Q 4K | Additional Hardware: Logitech Extreme 3D Pro | OS: Win 10 Pro 64 | Sim: MSFS & P3D v5.1 Professional | FTX Global, OpenLC EU and NA | Wx: ASP3D & EA | Chaseplane | BA Virtual

 

 

Share this post


Link to post
2 hours ago, SierraDelta said:

Hardware-Accelerated GPU Scheduling, available under Win10 Graphics settings.

K, thanks for that info.


Robin

Share this post


Link to post

I have Hardware-Accelerated GPU Scheduling set to High performance and don't have any issues. When I hit CTRL-TAB the house goes away and the aircraft shows.

You might want to reinstall WMM and SteamVR. Since, the game plays on the monitor, it seems to me that the issue is with the VR interface.

You might also try setting your MSFS graphics at minimums, just in case it is an overloading of memory issue. If that works, increase.

 

Good luck! issues like these can be a PITA.


John
My first SIM was a Link Trainer. My last was a T-6 II
 

Share this post


Link to post
10 hours ago, SierraDelta said:

Hardware-Accelerated GPU Scheduling, available under Win10 Graphics settings.

This and its a newer addition to Windows 10 (within a year). Its giving some folks VR performance issues and others has caused crashes. I can't tell a difference personally with it on or office, but its a setting worth checking.

Share this post


Link to post
21 hours ago, Stranga said:

I recently got a Reverb G2 and it works fine with everything except MSFS, which is of course the main reason I got it.

The gear I'm running isn't top of the line but should run the game without issues, at least at lower settings;

AMD Ryzen 7 3700X

The Reverb G2 has a lot of issues with AMD systems, make sure you have the latest AGESA installed. It was supposed to contain a fix for the USB ports power.

If you search on Reddit you can find many discussions on the topic.


i9 10850K / 64 GB 2933 MHz CL14 / RTX 3090 / HP Reverb G2

Share this post


Link to post

Well, I tried all the suggestions and whatever else I've come across, but nothing seems to fix the issue.

Interestingly enough, I noticed just now that my GPU goes completely nuts when I try to enter VR mode, even at low settings. Under Performance in Task Manager, the GPU is going between 80% to 99% utilisation, which surely isn't normal, even for a graphics heavy game like MSFS. I know people with lesser spec'd PC who are able to run VR in MSFS, so that doesnt make sense to me. 

Also, turning on the VR headset causes some buzzing which gets quite intense at times when going into MSFS, not that I can be sure that's related. I would certainly be happy to live with the buzzing if the VR worked.

But anyway, I appreciate all the helpful advice. I'll just have to keep experimenting. 

 

 

 

Share this post


Link to post
3 hours ago, Stranga said:

Well, I tried all the suggestions and whatever else I've come across, but nothing seems to fix the issue.

Interestingly enough, I noticed just now that my GPU goes completely nuts when I try to enter VR mode, even at low settings. Under Performance in Task Manager, the GPU is going between 80% to 99% utilisation, which surely isn't normal, even for a graphics heavy game like MSFS. I know people with lesser spec'd PC who are able to run VR in MSFS, so that doesnt make sense to me. 

Also, turning on the VR headset causes some buzzing which gets quite intense at times when going into MSFS, not that I can be sure that's related. I would certainly be happy to live with the buzzing if the VR worked.

But anyway, I appreciate all the helpful advice. I'll just have to keep experimenting. 

 

The 99% occupation is normal, the Reverb G2 has a crazy resolution and I can assure you that it puts my RTX 3090 to its knees as well.

As for the noise, it may be coil whining. Your system evidently does not tolerate the G2 much... 😞


i9 10850K / 64 GB 2933 MHz CL14 / RTX 3090 / HP Reverb G2

Share this post


Link to post

Hey, I just wanted to let everyone know that I finally got it working.

I finally came across another person who had the same problem and the fix is so simple that it's downright stupid.

Seems like MSFS was attempting to start a new window (i.e. a Map or ATC), so I all have to do it is turn those on and off, and everything works fine now.

Now to resolve the bigger problem of spending ridiculous amounts of money for some next get rig to get the graphics to more acceptable levels, because clearly my 2070 just isn't up to the task, haha. 

Thanks to all who tried to help. 

 

  • Like 1

Share this post


Link to post

This is why our suggestions were all over the map and/or a shoulder shrug. Unfortunately, this sim has so many random settings that can cause things to go astray that it’s anyone’s guess as to what the problem might be. 
 

Next time trying turning the menu fauna to 45 while simultaneously holding down the right rudder above 60% but below 70% with the left toe brake pressed. 
 

I’m only half joking. 

Share this post


Link to post

The buzzing can likely be attributed to your controllers. 


5950X, RTX3090, 32GB@3600, Samsung Evo NVME 1TB, Warthog HOTAS, MFG Crosswinds, Reverb G2.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    45%
    $11,465.00 of $25,000.00 Donate Now
×
×
  • Create New...