Jump to content
Sign in to follow this  
Sesquashtoo

Hybrid v5.2.22 and v5.3 'version'...

Recommended Posts

I have gone back at present to a full re-install of v5.2.22.  I'm wondering if one can have the CLIENT at (for me..) installed at v5.2.22 but...sneak in both Content and Scenery from v5.3?   I wonder if that would work...

Has anybody ever tried to keep a current Client, but then 'sneak in' the next version of both Content and Scenery?  If so...did it work...could they even be installed without a warning 'cut off' that this version could not blah, blah...

If you did do so...did you find any visuals better, or did you find worse performance because of the hybrid content.  I'd love to know...as I might try this, for you know what and giggles...but don't want to bother, and disturb my present installation (pure v5.2.22) if it will BORK things.

Ses

Share this post


Link to post

I think on another thread I just responded to, somebody (I think ) has v5.3 Content and Scenery installed but reverted back to the v5.2.22 Client...and he says he is running that way, I think...   I hope he comes onto this thread to clarify...

He stated: "Is anyone like me also struggling with more microstuttering in 5.3? (traffic disabled, same settings as in v5)

So far, my start with 5.3 is a bit rough and I have reverted to the 5.2 client for the moment, which at least cured the microstuttering." 

Edited by Sesquashtoo

Share this post


Link to post

He does. 😉

Yes, the combination does work. That's also the reason why LM just issues legacy client installer and not fully installers for previous versions. Just uninstall the client from "programs and features", delete your P3D.cfg and the shaders, and install the legacy 5.2 client. Et voilà...you're set.

I do this frequently in the early stages after a release just to isolate such issue. Thus, I am liking going to repeat the process a few times until I find the reason for the microstutters. 

  • Upvote 1

Best,
Christoph

Display resolution: 1920x1080 (8xSSAA)    GPU: 1080TI     CPU: i7-7700K (5.0 OC)    RAM: 16GB     SSD: Samsung 850Evo     Monitor: 27K

FSBetaTesters3.png

Share this post


Link to post
21 minutes ago, Wolkenschreck said:

He does. 😉

Yes, the combination does work. That's also the reason why LM just issues legacy client installer and not fully installers for previous versions. Just uninstall the client from "programs and features", delete your P3D.cfg and the shaders, and install the legacy 5.2 client. Et voilà...you're set.

I do this frequently in the early stages after a release just to isolate such issue. Thus, I am liking going to repeat the process a few times until I find the reason for the microstutters. 

Ok...and thanks!   I wonder...how does it look, or act different with your Client as v5.2.22, and your Content and Scenery with all the difference PBR stuff...and, I right now have no micro stutter or pause with a pure v5.2.22 install. Do you still have any 'left over' this or that problems from v5.3 in having your Content and Scenery for that version installed?  I also wonder if I might once more go back to a nominal 17-22 FPS, and if I use the Traffic slider from the v5.2.22 Client...will that act as it is now...wonderfully at 32 FPS (roads populated) or will I wonder..I will see borking again, if I use the Traffic Slider...which would imply that whatever is in the Content or Scenery of v5.3 might have some inclusion to this problem.   So, how is your Traffic let's say set to 20 percent?  Could you do that for me...and tell me if you see a whopping reduction in FPS BECAUSE you moved the slider from 0 to any figure. Thanks..will wait for your response.... for if I had (in a pure 5.3 install) the slider off, I would have around 28 FPS. The minute even 1 percent was selected...and only on Freeways, I dropped to 12/15 and 17/22 no matter what the setting was...

Post Edit: ..bottom line, Wolken...do you see any difference (better, not so) with using the Scenery and Content of v5.3 now with the Client of v5.2.22?  Is it in your opinion, even worth the trouble?  Thanks!

Edited by Sesquashtoo

Share this post


Link to post

I had to go back to 5.2 because while re-installing 5.3 twice only the apt scenarios were O.K. while I had a very bad view of the textures of the scenario beyond to remain much darker than 5.2, in the far part of the scenario they were not loaded leaving beige colored plains or mountains without considering that it was impossible to fly for the stutters if I entered the road traffic.

Before reinstalling P3D 5.2 I did this test:

uninstalled Client 5.3 with deactivation NO, installed Client 5.2 then I uninstalled Content.msi  5.3 and installed Content  5.2 leaving only Scenery 5.3.

The result is that now all the Textures are displayed with the right brightness and for the whole scenario and they seem to me even better than those 5.2 with a mixture of the Textures of
P3D 5.3 and those of Orbx Global Pack.

Share this post


Link to post
1 hour ago, Sesquashtoo said:

"Is anyone like me also struggling with more microstuttering in 5.3? (traffic disabled, same settings as in v5)

What is the definition of microstuttering ?

What I’m seeing in VR despite having  very high FPS with VR active of 50-100 is if I look out the side window while low at an object like a house or tree is appears to be moving in series of small jerks rather than a smooth constant motion , is that microstuttering ?

If it is I have it. What ever the behaviour is called I’d like to get rid of it somehow.


787 captain.  

Previously 24 years on 747-400.Technical advisor on PMDG 747 legacy versions QOTS 1 , FS9 and Aerowinx PS1. 

Share this post


Link to post

Hi Jon, small jerks i what I have also. That is new.

5.2hf1 did not have that.

Presently working on the Job Scheduler trying to get rid of that problem.

Have had some success in reducing it.

Need further testing.

They broke or change VSync so we are left with small jerks just as you described it : look out the side window........

Cheers,

 


Pierre

Share this post


Link to post
1 hour ago, RobPol471 said:

I had to go back to 5.2 because while re-installing 5.3 twice only the apt scenarios were O.K. while I had a very bad view of the textures of the scenario beyond to remain much darker than 5.2, in the far part of the scenario they were not loaded leaving beige colored plains or mountains without considering that it was impossible to fly for the stutters if I entered the road traffic.

Before reinstalling P3D 5.2 I did this test:

uninstalled Client 5.3 with deactivation NO, installed Client 5.2 then I uninstalled Content.msi  5.3 and installed Content  5.2 leaving only Scenery 5.3.

The result is that now all the Textures are displayed with the right brightness and for the whole scenario and they seem to me even better than those 5.2 with a mixture of the Textures of
P3D 5.3 and those of Orbx Global Pack.

Really?  Ok...so it's worth experimenting and messing around with this...thanks muchly for your input.  I was hoping that I could get 'some' benefit of any updates, but...still go back to pretty rock on steady v5.2.22. So, you did uninstall the v5.3 Content, but ONLY left v5.3 Scenery....I will do that now...and see what that gives.  So I guess that it is the Content of v5.3 that gets called by the Client of v5.3, that can not truly be mixed and matched. Seems by your advice, that the Scenery can be 'updated' to v5.3 and work with Client and Content of v5.2! 🙂

Edited by Sesquashtoo

Share this post


Link to post

If anything else, this is fun...

Here's what I am going to do right now.

I have v5.2.22 Client installed

-----------------------------------------------------

I am going to delete the v5.2.22 Scenery first, and then apply the Scenery v5.3.0

I will run the sim and see if it comes up...and no BORKS or weird stuff/artifacts.

If that will behave, I then will:

Delete v5.2.22 Content, and apply v5.3.0 Content and try to run the sim

If all runs and no CTD, texture weirdness/ and/or artifacts, I will stay with the above hybrid mix.  So wish me luck, and let's see where this goes...I don't need traffic on all roads, so..if I get all the visual benefits out of the v5.3.0 Scenery and Contents, and run them both under v5.2.22 Client...then I will have the most up-to-date P3D 'whatever' for my particular system and specs...so...HERE GOES Nuttin'...

Ses

Share this post


Link to post
2 hours ago, ppo said:

Hi Jon, small jerks i what I have also. That is new.

Hi Pierre,

 I’m sorry to hear you have the same problem, though I’m relieved it’s not just me.

I have just set up new hardware and fresh installs of everything so thought I might have something not set up correctly.

XP11 is super smooth in VR with even with Max world objects in orbx TE so I was scratching my head is to why P3D was so jerky.

I remember P3D was smooth with my old less powerful system.

I await your findings with interest, good luck 


787 captain.  

Previously 24 years on 747-400.Technical advisor on PMDG 747 legacy versions QOTS 1 , FS9 and Aerowinx PS1. 

Share this post


Link to post

Hi Ses,

Since P3D 4.4 (or 4.5?) was P3D capable to render PBR content. Thus, any PBR object will load regardless of the sim version (well, some changes exist between P3Dv 4.x and 5.x). With 5.3, LM merely added PBR to content that was not yet upgraded to PBR (e.g., road vehicles, autogen buildings, default airport buildings). Same like FSL or PMDG did for their existing aircraft when they added PBR.

Think of it that way:
Client is similar to your OS (i.e. MS Windows). The client has all the processes and programs necessary to run the sim.
Content = Simobjects (aircraft, vehicle). They will load in any sim version.
Scenery = Airports, roads, waterbodies, etc. All are the usual BGL files and texture files that contain a compiled scenery. They will also work in any sim version.

There are of course always exceptions and this is simplified. But the gist is: The client is what determines the sim.

Hope this helps a bit.

Christoph

  • Upvote 1

Best,
Christoph

Display resolution: 1920x1080 (8xSSAA)    GPU: 1080TI     CPU: i7-7700K (5.0 OC)    RAM: 16GB     SSD: Samsung 850Evo     Monitor: 27K

FSBetaTesters3.png

Share this post


Link to post

Preliminary results:

I could reduce the small jerks quite a bit by selecting <variable refresh rate> in the menu. I do not have a variable refresh rate monitor: dell 32in 4k monitor x3.

Do not ask me why? I dunno....

Tried different settings in the <Jog Scheduler> for mi I7 9700k running at 5.0 with 8 cores no HT per LM suggestions in their forum. Results: not good. No difference as far as I can tell.

I have the task manager opened and noticed that the cpu load is heavy on my test flights compared to the previous versions of p3d. I will come back to that.

Test is with the R22 at KSEA with DD scenery, adding or reducing autogen or traffic does not change the problem.

Video card is 3090.

There is nothing like a comparison to show differences: I uninstalled the 5.3 client and installed the 5.2hf1 client. Only one word: no jerks, butter smooth.

Until someone comes up with a better suggestion with the jobscheduler settings, I will keep it at that.

Time to take a walk anayways,

Cheers


Pierre

Share this post


Link to post
40 minutes ago, Wolkenschreck said:

Hi Ses,

Since P3D 4.4 (or 4.5?) was P3D capable to render PBR content. Thus, any PBR object will load regardless of the sim version (well, some changes exist between P3Dv 4.x and 5.x). With 5.3, LM merely added PBR to content that was not yet upgraded to PBR (e.g., road vehicles, autogen buildings, default airport buildings). Same like FSL or PMDG did for their existing aircraft when they added PBR.

Think of it that way:
Client is similar to your OS (i.e. MS Windows). The client has all the processes and programs necessary to run the sim.
Content = Simobjects (aircraft, vehicle). They will load in any sim version.
Scenery = Airports, roads, waterbodies, etc. All are the usual BGL files and texture files that contain a compiled scenery. They will also work in any sim version.

There are of course always exceptions and this is simplified. But the gist is: The client is what determines the sim.

Hope this helps a bit.

Christoph

Great post..and am just running P3D after I put back in both P3D v5.2 Scenery and Content, under P3D v5.2.22 Client.  It's just building all the scenery files as I type.  So...hope this all works...can enjoy the added PBR stuff, and that my FPS are no longer borked when having run the v5.3.0 Client...and I guess I'm about to find out in a few minutes! 🙂

Share this post


Link to post
4 minutes ago, ppo said:

Preliminary results:

I could reduce the small jerks quite a bit by selecting <variable refresh rate> in the menu. I do not have a variable refresh rate monitor: dell 32in 4k monitor x3.

Do not ask me why? I dunno....

Tried different settings in the <Jog Scheduler> for mi I7 9700k running at 5.0 with 8 cores no HT per LM suggestions in their forum. Results: not good. No difference as far as I can tell.

I have the task manager opened and noticed that the cpu load is heavy on my test flights compared to the previous versions of p3d. I will come back to that.

Test is with the R22 at KSEA with DD scenery, adding or reducing autogen or traffic does not change the problem.

Video card is 3090.

There is nothing like a comparison to show differences: I uninstalled the 5.3 client and installed the 5.2hf1 client. Only one word: no jerks, butter smooth.

Until someone comes up with a better suggestion with the jobscheduler settings, I will keep it at that.

Time to take a walk anayways,

Cheers

So you are running

Client: v5.2.22

Both Content and Scnery at v5.3.0, and all runs!

GOOD STUFF!   I'll be right along there with ya, in a few moments!

Ses

Share this post


Link to post

We're done!   Looks and runs great!

P3D v5.2.22  (Client)

P3D v5.3.0  Content and Scenery

Looks great, runs great...all is good!

...a keeper...and back to the flight on pause...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...