Sign in to follow this  
MM

Anti-aliasing?

Recommended Posts

Has anyone gotten anti-aliasing working in Acceleration in DX-10 Preview mode with a Nvidia card? Have tried all kinds of drivers because in a post by Phil i think he stated the Devs we're using pre 16x.xx drivers. I can't believe this got by the Devs or the beta testers. There has to be a solution.Intel E6700 @ 3.8ghz4 gig Corsair Pc2-8500 @ 1066mhzEvga 680i nVidia motherboardXFX 8800GTS 640 mb o/c @ 675/2100 163.44 Drivers2 74gig WD 10,000 rpm Raptors Raid 0Thermaltake 750watt Toughpower PsuAcer 22" Widescreen LCD

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

>Has anyone gotten anti-aliasing working in Acceleration in>DX-10 Preview mode with a Nvidia card? Have tried all kinds of>drivers because in a post by Phil i think he stated the Devs>we're using pre 16x.xx drivers. I can't believe this got by>the Devs or the beta testers. There has to be a solution.>>>>Intel E6700 @ 3.8ghz>4 gig Corsair Pc2-8500 @ 1066mhz>Evga 680i nVidia motherboard>XFX 8800GTS 640 mb o/c @ 675/2100 163.44 Drivers>2 74gig WD 10,000 rpm Raptors Raid 0>Thermaltake 750watt Toughpower Psu>Acer 22" Widescreen LCDYour assumption is that the flaw is in their code and not the drivers. ;)I have an 8800 GTX and have issues with AA in FS9.

Share this post


Link to post
Share on other sites

ED, is that a yes or no. I would like to know too? Why respond if you can't answer the question?

Share this post


Link to post
Share on other sites

Ed...if i'm not mistaken the problem with FS9 and AA is with the built-in profiles that are in the Nvidia drivers. If you use Nhancer to delete the FS9 profile an create a new one with enhance application AA setting...AA works fine. This doesn't work with Acceleration and DX-10. Intel E6700 @ 3.8ghz4 gig Corsair Pc2-8500 @ 1066mhzEvga 680i nVidia motherboardXFX 8800GTS 640 mb o/c @ 675/2100 163.44 Drivers2 74gig WD 10,000 rpm Raptors Raid 0Thermaltake 750watt Toughpower PsuAcer 22" Widescreen LCD

Share this post


Link to post
Share on other sites

>ED, is that a yes or no. I would like to know too? Why>respond if you can't answer the question? His reply was clear enough. If you can't understand the answer how is that his problem?DX10 anti-aliasing does not work in the preview window of the UI. All of the in-game UI is also not anti-aliased. If you're unhappy with the look of anti-aliasing, there are some configuration file tweaks you can use to control it.In the Graphics section, the "MultiSamplesPerPixel" settings specify how many samples per pixel we use in rendering to render targets. The higher you turn up this number, the more memory you gobble up and the slower the performance. Different cards support different amounts here. The amounts are in powers of two. The default value is 4. The highest my 8800 can support is 8.Also in the Graphics section is the "MultiSampleQuality" setting. This controls the quality setting of the anti-aliasing algorithm. Numbers here are manufacturer dependent. Higher numbers result in better looking pictures but have lower performance. The default value here is 1.If you set the MultiSamplesPerPixel value to 1 and the MultiSampleQuality to zero, you've effectively disabled anti-aliasing. Furthermore, turning off anti-aliasing via the UI settings forces these values to 1 and 0 regardless of what you have in the config file. If you put values that are too high for your graphics card, the application will fall back to using 4 and 1.Aside from the above, there are quite a few reports that the current nVidea drivers are not quite up to the task yet.

Share this post


Link to post
Share on other sites

The newest version of NHancer will not allow the deletion of profiles with NVidia drivers 163+I copy >> "Since NVidia changed the way predefined profiles are handled with Forceware 163.x, it's no longer possible to delete them.":-sword ? I use 163.69, maybe I could regress the Foreware?Older versions of NHancer are available as well.I am however playing with enhancing the AA performance of the profile already there for MS Simulator XAnd now that I have the entries I want, how do I activate this new profile? Do I just close NHancer?? Not sure hereallen

Share this post


Link to post
Share on other sites

I've not read of any reports of DX10 mode working as expected from nVidia or ATI users. Maybe Phil or someone from ACES could respond what working DX10 video card and driver combo they used, and suggested settings ?On the other hand DX9 mode is great, I'm not missing DX10 at all.Framerate is up in DX9, I can turn water levels to high 2.x, the new planes are just great. Best $29 I spent in a long time.The only promised benefit I'm missing is bloom, bloom in DX9 mode still kills framerate, but I dont miss it.

Share this post


Link to post
Share on other sites

The P-51 alone is worth the 30$ I spentI dont see much candy in DX10 right now anyway, and that is what it would be all aboutallen

Share this post


Link to post
Share on other sites

I got AA working in DX10 with my hardware specs. Don't ask me how, but I remember noticing that the AA button "unchecked" itself and with a series of "re-checking" the AA button and with a "Anisotropic" setting and FSX restarts AA within FSX suddenly worked with DX10. However, the cockpit shadows were still jaggy.Edit: This is with the latest beta drivers: ForceWare release 169.01Pat

Share this post


Link to post
Share on other sites

>The newest version of NHancer will not allow the deletion of>profiles with NVidia drivers 163+>>I copy >> "Since NVidia changed the way predefined profiles>are handled with Forceware 163.x, it's no longer possible to>delete them.">>>:-sword ? I use 163.69, maybe I could regress the Foreware?>Older versions of NHancer are available as well.>>I am however playing with enhancing the AA performance of the>profile already there for MS Simulator X>>And now that I have the entries I want, how do I activate this>new profile? Do I just close NHancer?? Not sure here>allenCorrect you cannot delete profiles with 163+ drivers. However, utilizing nHancer v2.3.1, you can disable the default FSX profile (you must disable it as you cannot make changes to the default profile) that ships with the driver package and make a new profile and tweak to your hearts content.

Share this post


Link to post
Share on other sites

It does work, but at a reduced level. It would be nice to be able to crank the levels up a bit to smooth out the jaggies.Hopefully, nvidia will address the issue as Phil Taylor has been in contact with them.Regards,Jim Karn

Share this post


Link to post
Share on other sites

Guys...Bill's suggestion works perfectly! Thanks's Bill!!!!Just add the 2 entries into your .cfg file under the (Graphics) header. I added them with a value of 8 and 2 and it works perfectly. But as Bill said the ui (or aircraft preview window) doesn't show it but you can definately notice it in game.Intel E6700 @ 3.8ghz2 gig Corsair Pc2-8500 @ 1066mhzEvga 680i nVidia motherboardXFX 8800GTS 640 mb o/c @675/2100 163.44 Drivers2 74gig WD 10,000 rpm Raptors Raid 0Thermaltake 750watt Toughpower PsuAcer 22" Widescreen LCD

Share this post


Link to post
Share on other sites

>Guys...Bill's suggestion works perfectly! Thanks's Bill!!!!>Just add the 2 entries into your .cfg file under the>(Graphics) header. I added them with a value of 8 and 2 and it>works perfectly....Just to be clear is that the fsx.cfg file ?Do you have AA checked in FSX?What about the 8800 settings, do you have application control?What 8800 drivers are you using?Thanks would like to try to get DX10 working.

Share this post


Link to post
Share on other sites

>ED, is that a yes or no. I would like to know too? Why>respond if you can't answer the question? I can not get the current drivers for the nVidia cards to correctly support AA. Period.

Share this post


Link to post
Share on other sites

>Ed...if i'm not mistaken the problem with FS9 and AA is with>the built-in profiles that are in the Nvidia drivers. If you>use Nhancer to delete the FS9 profile an create a new one with>enhance application AA setting...AA works fine. This doesn't>work with Acceleration and DX-10. >>>>Intel E6700 @ 3.8ghz>4 gig Corsair Pc2-8500 @ 1066mhz>Evga 680i nVidia motherboard>XFX 8800GTS 640 mb o/c @ 675/2100 163.44 Drivers>2 74gig WD 10,000 rpm Raptors Raid 0>Thermaltake 750watt Toughpower Psu>Acer 22" Widescreen LCDNo... it did not correct AA on my system. In windowed mode AA is working great... if I switch to full screen... *poof* AA is gone.

Share this post


Link to post
Share on other sites

>ED, is that a yes or no. I would like to know too? Why>respond if you can't answer the question? Funny. I don't see your answer to the problem here. Maybe you should follow your own advice.Great info here guys thanks :)

Share this post


Link to post
Share on other sites

>>Guys...Bill's suggestion works perfectly! Thanks's Bill!!!!>>Just add the 2 entries into your .cfg file under the>>(Graphics) header. I added them with a value of 8 and 2 and>it>>works perfectly....>>Just to be clear is that the fsx.cfg file ?>>Do you have AA checked in FSX?>>What about the 8800 settings, do you have application>control?>>What 8800 drivers are you using?>>>Thanks would like to try to get DX10 working.>>>Yes...it is the fsx.cfg file.Yes AA is checked in FSX.I have the Nvidia control panel set to enhance the application 8x supersampling.I'm using the 169.01 beta drivers.Intel E6700 @ 3.8ghz4 gig Corsair Pc2-8500 @ 1066mhzEvga 680i nVidia motherboardXFX 8800GTS 640 mb o/c @675/2100 169.01 Beta Drivers2 74gig WD 10,000 rpm Raptors Raid 0Thermaltake 750watt Toughpower PsuAcer 22" Widescreen LCD

Share this post


Link to post
Share on other sites

You'll know. Aircraft surfaces, among other things, will look jagged and rough.Regards,Jim Karn

Share this post


Link to post
Share on other sites

>Correct you cannot delete profiles with 163+ drivers. >However, utilizing nHancer v2.3.1, you can disable the default>FSX profile (you must disable it as you cannot make changes to>the default profile) that ships with the driver package and>make a new profile and tweak to your hearts content.How do you disable the profileI fail to see any related buttons...allen

Share this post


Link to post
Share on other sites

I tried DX10 and changing settings and ended up with half the frame rates in DX9!Solved it by removing nHancer and in FSX set:AA onFiltering to AnsioAt least in DX9 that give a decent image with excellent frame rates.I'll pass on DX10 for now.

Share this post


Link to post
Share on other sites

>You'll know. Aircraft surfaces, among other things, will>look jagged and rough.>>Regards,>Jim KarnI don't have the driver information in front of me, but everything looks fine on my PC.However, I just finished a flight, and after turning off the runway and opening the ATC window, everything went black. The sim was still running, as I could hear throttle response, a plane taking off behind me, and was able to respond to ATC, but there was nothing on the screen. I alt+tabbed, alt+entered and couldn't get it back at all. :(

Share this post


Link to post
Share on other sites

>It does work, but at a reduced level. It would be nice to be>able to crank the levels up a bit to smooth out the jaggies.>>Hopefully, nvidia will address the issue as Phil Taylor has>been in contact with them.>>Regards,>Jim KarnI can confirm that as well. My specs:Abit I35 Pro MBE6600 Core Duo CPU (oc 3 GHz)2 GB Crucial Ballistix PC2 8500EVGA GeForce 8800 GTX (stock speeds)Corsair 620HX PSU1 WD Raptor X 150 GB SATA HDD2 Seagate 320 GB SATA HDDsSoundBlaster X-Fi XtremeGamer Fatal1ty ProPioneer DVR-111D DVD-RW PATALite-On LH-20A1S DVD-RW SATANEC MultiSync 90GX 19" LCDWin Vista 32-bit Home PremiumForceware 163.69 video driverI use nHancer and have FSX set with AA checked and Aniso filtering, DX10 preview, light bloom are checked. I've tweaked nHancer as per this post by Nick N at Simviation:http://www.simviation.com/cgi-bin/yabb2/Ya...um=1183998514/0I do get AA in the game (full screen mode) but not in the UI aircraft preview window. Frame rates are pretty good, with a limit set at 30 fps. I like the expansion pack and its impact on the game, its eye candy, and my frame rates.

Share this post


Link to post
Share on other sites

>>You'll know. Aircraft surfaces, among other things, will>>look jagged and rough.>>>>Regards,>>Jim Karn>>I don't have the driver information in front of me, but>everything looks fine on my PC.>>However, I just finished a flight, and after turning off the>runway and opening the ATC window, everything went black. The>sim was still running, as I could hear throttle response, a>plane taking off behind me, and was able to respond to ATC,>but there was nothing on the screen. I alt+tabbed,>alt+entered and couldn't get it back at all. :(This has happened to me a couple of times as well. I was using the Nvidia beta driver.

Share this post


Link to post
Share on other sites

Ed,If you're having troubles with FS9 and AA/AF with your nVidia card and the new drivers, you might want to revisit this thread:http://forums.nvidia.com/index.php?showtopic=38921Note that the system for using nHancer with the newer drivers has necessarily changed. Note as well that you need not only duplicate the FS2004 driver but then delete it and create a new one. (And turn off AA in FS9.) Again, Ryan's suggestions for fixing the new drivers are interspersed through that thread.(I apologize for noting this FS9 fix in the FSX forum...but others might find this helpful.)Good luck,Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this