Sign in to follow this  
Bert Pieke

2D Cockpit View Bug in SP1 ( Fixed or Not?)

Recommended Posts

This question was originally in topic number 398076. It is locked from further posts.Pressing the "W" key removes the aircraft panels, but when looking in other views (quarter, side), the panels are still in view. I still have this problem with SP2 installed. My question is, do others still have the problem or did I miss something? Did MS forget to fix this?Richard

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Care to explain what you just wrote Jim?Phil Taylor confirmed it was a bug introduced by SP1. Richard

Share this post


Link to post
Share on other sites

Jim,First, let me say thank you for the information.Secondly, I'm not trying to start anything here, but as long as I abide by the Avsim forum rules, I believe I am intitled to ask whatever question I choose. If you have no constructive reply, why reply at all.Your first reply said nothing. Your second reply appears to have answered my question. Maybe that should have been you first reply.Regards,Richard

Share this post


Link to post
Share on other sites

>Jim,>>First, let me say thank you for the information.>>Secondly, I'm not trying to start anything here, but as long>as I abide by the Avsim forum rules, I believe I am intitled>to ask whatever question I choose. If you have no>constructive reply, why reply at all.>>Your first reply said nothing. Your second reply appears to>have answered my question. Maybe that should have been you>first reply.>>Regards,>>Richard>>'W' works for me using SP1

Share this post


Link to post
Share on other sites

Yes, the "W" key does remove the front instrument panels. However, if you then look at the front quarter or side views (probably all around the a/c), you still see the inside of the aircraft.In the referenced post, SP1 caused this problem. In previous versions of FS, the "W" key removed all panels/grephics thereby allowing you to see an unobstructed view outside the aircraft. From what I recall reading in that post, you could delete the VC cockpit views to fix the problem. At least that is what I recall reading.Regards,Richard

Share this post


Link to post
Share on other sites

>Your first reply said nothing. Your second reply appears to>have answered my question. Maybe that should have been you>first reply.His first reply said precisely the same as his second, only using fewer words.Perhaps it was not his reply that is the problem?

Share this post


Link to post
Share on other sites

Thanks Bill. That also was very helpful. Maybe I should post here more often with nonsensical replies to boost my post rating. I see that after 5+ years I only have 438 posts. I understand Phil. I missed that note in SP2. Was just checking to make sure I was not overlooking a the fix.Regards,Richard

Share this post


Link to post
Share on other sites

I think you may have misunderstood his response and I don't believe it was meant to be derogatory, just a short, quick answer to your question.

Share this post


Link to post
Share on other sites

>Thanks Bill. That also was very helpful. Maybe I should>post here more often with nonsensical replies to boost my post>rating. I see that after 5+ years I only have 438 posts. I was suggesting that perhaps you'd communicate in a more positive manner if you first put the 'tude in your desk drawer.As for my number of posts, well over 4.3k of them are -in fact- support replies and mini-tutorials in other fora here at AVSIM, where the signal-to-noise ratio is much lower, as is the level of hostility and bad manners.

Share this post


Link to post
Share on other sites

I HAVE found a partial work-around. I'm using SP2 on FSX under Win XP.First, this fix WON'T work on 1 or 2 of the default aircraft that can't meet the panel configuration option I'm going to mention below.And while my description sounds complex, it's really only 2 keypresses and use of the hat switch (set to Pan View mode, I think). After practising a few times, I could do it in less than 2 seconds.On to the work-around, and forgive the detail but I think it's necessary:It only seems to work on those aircraft which, once you've selected a minimal (but not "blank") front-panel view with the "W" key (such as the 5 gauges on the bottom, or the 2-3 along the edge) you can then ALSO press Shift-2 or Shift-3 to get the "stand-alone" autopilot or the "lesser" GPS (sorry I cant remember model names of the devices) onscreen at the same time. NOTE: you CANNOT be in the "no-panel" front view (no gauges at all) as this just doesn't produce what you want. It has to be the view with at least SOME gauges on itNow, once you have the minimal gauge view, AND the autopilot or GPS onscreen with the minimal gauges, use the Look command (however you do it. In my case, the hat switch on my CH yoke is set to look and I press it any direction off-center) to look somewhere OTHER than Front. The panel and the AP/GPS should still be onscreen, HOWEVER, the aircraft body parts should now be GONE!You then use Shift-2 or Shift-3 to REMOVE the AP/GPS from onscreen, and then Look back to front (in my case, I just let go of of the hat switch). Once you do that, look any of the 7 directions other than front. The view SHOULD be the "correct" one that we were used to before they broke it with SP1.So, once I have the Panel view correct, for me it's: Shift-2, hat-switch any direction but front or center and hold it there, Shift-2 again, let go of hat switch. 2 seconds, tops. Then I can use the hat to look any of 8 directions and NOT have the aircraft body in view. The only problem with this is that you have to do it EVERY time you switch your view "away" from this screen (with one interesting exception, see below). SO, if you press "W" (or however you do it) to cycle through Panel views and come BACK to this screen, you have to repeat the above. But like I said, 2 seconds tops.ANOTHER odd thing I noticed! Once you've done the above and have the desired view, choose an EXTERNAL view like Spot, Fixed Spot, etc, then go directly BACK to the minimal panel view. (In my case, its the two red buttons on the top left handle of my yoke, which I have set to cycle Main(?) view forward/back.)Now the screen is BLANK (no gauges)! And you can look (hatswitch) any of the 8 directions and THEY'RE blank (no gauges) too!But change away from this panel screen in any way but the above, and for me it changes back to what we're complaining about: plane body panels blocking view.Hope that long-winded explanation helps someone. ;)

Share this post


Link to post
Share on other sites

Jim's first reply was correct and politely phrased. His second post gave more detailed information and was politely phrased.

Share this post


Link to post
Share on other sites

Hey, Sidewinder! That is great! Finally a good, easy workaround to get the unobstructed view back. Thanks a lot! I just tried it with the default Cessna 172 and it works like a charm.I was really disappointed that this wasn't fixed in SP2, but now it's back.Thanks again.Carey

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this