Sign in to follow this  
Mace

Ai Traffic Bgl file

Recommended Posts

Hey there to allI have a huge favor to ask of all of u. I am in despirate need of help from all of u.Alright, i sure that some of u have had this problem, and i am not sure if u ever got it solved or not but i have not yet. My problem is that when i go to certain airports (foreign, outside us)at certain times of the day. the fs will just quit. I dont know why it quits, but really i do, i just cant figure out where in the traffic bgl it has a problem.Then when selecting an airport lets say cyyz cause that is the one that i am having trouble with right now. I go there and randomly select a time of day and start the flight, it will get to about 90% loaded and then it will quit. SO what i did to troubleshoot is update all of the canadian flightplans. so i did that, and it still doesnt work. I dont know why. I have used the aichck progam in the avsim libary, and used the fs9 flightplans to fsx format and still no luck. i know it is not the simulator cause i turned off the ai traffic and it works great. i dont know what to doi have fsx sp1vista home premiumif someone could please help that would be greatthanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

remove all your traffic...bgl files and put them back one by one to isolate the problem.

Share this post


Link to post
Share on other sites

I've encountered that problem occasionally, usually when I try to start at a new location with traffic at MAX. When I have my wits about me, I reduce traffic before I go to a new location, then ease it back up 20% at a time. I use all my unaltered FS9 traffic: UT, custom, Ultimate GA, and assorted military. Maximum seen near LA was (I think) 701 flights listed in the Traffictoolbox. And the system did crash when I attempted to move to a new airport!Sometimes I forget things...Loyd

Share this post


Link to post
Share on other sites

Have you by any chance changed the default FSX "free flight" from the ultralight over Friday Harbor to something else or is it still the same?I always start with the default flight then change aircraft, time of day, season, location etc. once the default flight is up and running. Not sure if things have changed since SP2 but my system had a hick-up when I made the aircraft and airport selection on the free flight page.You may want to try running your traffic at 60% and see how things are as well.Good luck.

Share this post


Link to post
Share on other sites

thanks for the help. Yes i have changed the default location and plane to my hometown.Its intresting that u recommend gradually increase the traffic as u wait.but i posted the same topic over at WOA, and one of the replies that i got was that it could possible be a corrupted "repaint" on one of my ai planes. What do u guys think about that? Or how could i go about finding and repairing my repaint file if it is indeed the case?

Share this post


Link to post
Share on other sites

Yes it could be corrupt so to speak. Installing a new file does not always go as smoothly as one might think. You could try reinstalling the offending file which may remedy the situation.See my earlier post and try rebuilding your FSX.cfg

Share this post


Link to post
Share on other sites

>>but i posted the same topic over at WOA, and one of the>replies that i got was that it could possible be a corrupted>"repaint" on one of my ai planes. What do u guys think about>that? Or how could i go about finding and repairing my repaint>file if it is indeed the case?A corrupt repaint is possible, but not very likely.I think your problem is with one or more traffic bgl files. I have seen them cause an instant crash of FSX. My best advice is what Marten said: remove all traffic bgl's and re-add them one at a time to see which one is at fault.Traffic bgl files compiled to FSX SDK specs WILL NEVER crash the sim. It is always with aftermarket compilers where I have seen the problem, and I have done extensive testing (I've experienced the exact error you are seeing, several times).RhettAMD 3700+ (@2585 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2gb Corsair XMS 3-3-3-8 (1T), WD 150 gig 10000rpm Raptor, WD 250gig 7200rpm SATA2, Seagate 120gb 5400 rpm external HD, CoolerMaster Praetorian

Share this post


Link to post
Share on other sites

Hi there, A corrupt aircraft.cfg can trigger this too. It's not easy to isolate, but if you can reproduce it: Try to pause the sim just before it would happen and start cycling through the AI aircraft (with 'A'). If it is a broken aircraft.cfg, FSX will CTD immediately as soon as you want to display that aircraft. Good luck and kind regards Jaap

Share this post


Link to post
Share on other sites

"A corrupt aircraft.cfg can trigger this too. It's not easy to isolate, but if you can reproduce it: Try to pause the sim just before it would happen and start cycling through the AI aircraft (with 'A'). If it is a broken aircraft.cfg, FSX will CTD immediately as soon as you want to display that aircraft. "Thanks for all of the great suggestions i am now home from school and will try them. As for the one that i quoted, i would do that but 98% of the time idk when it is going to happen. it usually crashes when loading a new airport.

Share this post


Link to post
Share on other sites

Good luck! If you have multiple traffic.bgls, say 20, I'd suggest dividing them into 4 groups instead of going one by one. Once you can isolate a group, split that group two-way, etc. Like this max 4-5 tries should be necessary to isolate a bad traffic.bgl. Kind regards Jaap

Share this post


Link to post
Share on other sites

>As for the one that i quoted, i>would do that but 98% of the time idk when it is going to>happen. it usually crashes when loading a new airport.That is exactly where it crashed when I had bad .bgl's. It was always when the traffic bgl's are loaded, i.e. 90%-99% on the load bar.RhettAMD 3700+ (@2585 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2gb Corsair XMS 3-3-3-8 (1T), WD 150 gig 10000rpm Raptor, WD 250gig 7200rpm SATA2, Seagate 120gb 5400 rpm external HD, CoolerMaster Praetorian

Share this post


Link to post
Share on other sites

I've been doing this for many years and I have yet to find a flight plan (*.bgl) that caused FS to crash. On the other hand, I've had many crashes as a result of bad AI aircraft. I use a technique I call "halves."I take out half of my aircraft folders and re-run FS. If it crashes, I take out the active half and put back in the first half I removed. If FS crashes you have a bigger problem. However, I have found that the halving process works pretty well.Anyway, whichever half you find in the first round that does not cause FS to crash you keep. Then half the next set and restart FS. Keep doing this until you find the problem. This methodology saves time and it works like a champ.fb

Share this post


Link to post
Share on other sites

It was a no go, on the rebuild of the FSX cfg and i found out which bgl file it was. I knew it was that one to begin with. so what should i do to go about fixing it? Can i perhaps send it to someone to analize it?thanks again for the help u guys!

Share this post


Link to post
Share on other sites

When I installed FSX I got help from a professional. He told me NEVER change the default flight. KEEP the ultralight and Friday Harbor otherwise I could get into trouble. This seems to confirm what he told me. Roger

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this