Sign in to follow this  
Alvega

FSX Acceleration - Graphics problem

Recommended Posts

I have just installed the FSX Acceleration Pack and I am now having graphics problems that I do not have running FSX + SP1. The main problem is most notable when panning ( using Track IR or Hatswitch) in the 3D cockpit view. There are horizontal jagged type lines across the centre of the screen both on the cockpit window frames and also on the distant scenery. If I uninstall the Acceleration Pack, I have no graphic problems and all panning views are very stable. I'm using Vista and Nvidia 8800 GTX graphics card. Anyone out there with similar problems or any ideas please ??

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I get the "spikes" across my screen occasionally. It's an indication my system is running out of memory. The only way I have solved it is by turning down my FSX display sliders. I don't believe it's Track IR causing the problem as this occurs to me even without Track IR running. I found turning down my sliders has not only made my FSX experiences more enjoyable but the scenery is much more crisp and clear.Best regards,Jim

Share this post


Link to post
Share on other sites

Thanks for the reply Jim. I have 2Gb of ram and the 8800GTX card is the 768Mb version. I have no graphics problems when reverting to FSX + SP1. Did your graphic problems start after installing the Acceleration Pack? I'll give your suggestion of turning down the display sliders a try - did you turn down any particular display slider/s or just 'play' with them all? Thanks and regards,Peter

Share this post


Link to post
Share on other sites

One more thing to try, if it only appears when panning or banking..SP2 defaults to vsynch=off whereas vsynch=on is the better setting.See if you can change this in the display properties applet.Made a big difference on my system.

Share this post


Link to post
Share on other sites

"Thanks for the reply Jim. I have 2Gb of ram and the 8800GTX card is the 768Mb version. I have no graphics problems when reverting to FSX + SP1. Did your graphic problems start after installing the Acceleration Pack? I'll give your suggestion of turning down the display sliders a try - did you turn down any particular display slider/s or just 'play' with them all?"Peter,To me, that's strange you have no graphics problems reverting from SP2 to SP1. SP2 provided a new FSX.exe but that only was modified to tell FSX "App can handle> 2gb adressess". I can't see what's in SP2 that causes you a graphics problem but I have read others have problems with SP2 too. I guess I'm one of the fortunate ones. SP2 adds more aircraft/textures so make sure you do a defrag of your hard drive after installing SP2. I have a very powerful system, the Dell XPS 720H2C w/DuoCore Extreme X6800 CPU and 2 8800GTX's w/768mb in SLI mode, 4 GB DDR2 memory and the Vista Premium SP1 (Final Version) operating system. Oh, I have a 30" monitor too set at 2560x1600x32 resolution. Yet my system goes to a crawl if I set the Scenery sliders to max and AI higher than the default. This happened when I just had SP1 installed too. I had my scenery sliders reduced but tried to turn my Aircraft AI up to 70%. It worked great for a few sessions and as long as I used the default aircraft. But running the PMDG 747 or the LevelD 767 (for examples) created the spikes (lines shooting up in the air). Sometimes it would recover and I could fly but mostly I had to close down the sim or watch it slowly crash. I brought the AI back to the default of 10% and that stopped the spikes. My Scenery sliders are set to the following and, as I stated before, I get extremely crisp and clear textures and, when away from major airports like LAX, get consistent FPS at 24 FPS (target frame rate - 24):LOD: MediumComplexity: 50Mesh Resolution: 38mTexture resolution: 1MWater: High 2.xLand detail texturesComplexity: Very denseAutogen: DenseNo ground shadows andSpecial effects: HighI also have anisotropic and AA filtering; global textures resolution set to very high; and Preview DX10 and Advanced animations checked. I use no FSX.cfg "tweaks" except that one for autogen. Traffic is set to the Default.Lastly, when I first got FSX I began my "tweaking" of the sliders by following the recommendations of the Nvidia Tech Team who provided suggested settings based on my video card and their expertise - http://www.nzone.com/object/nzone_fsx_techtips.html. I then started moving sliders up and down from there to find the holy grail for my system. I found the Level of Detail slider was the hardest on my system (other than AI). Setting it to the max always caused problems and/or lowered my FPS drastically. Medium works best for me and my system. Hope this helps and good luck getting your system set up to work the best for you.Best regards,Jim

Share this post


Link to post
Share on other sites

Jim,Thanks for the comprehensive the reply. I will use your setup info as a start point and tweak from there. Having tweaked FSX+SP1 to be very stable on my system with crisp and clear textures, running at an average of 30 fps, I'm a bit reluctant to start again, but I suppose this seems to be the name of the game in our flight sim world !?!?!Regards, Peter

Share this post


Link to post
Share on other sites

Bert,Thanks for the suggestion, sounds well worth a try, especially if SP1 defaults to vsync=on ? In my Nvidia graphics card control panel the vsynch is set to "as required by application" so I assume the SP2 default would turn it off. Could you just explain which setting/s you changed to over- ride the SP2 default please.Thanks.Peter

Share this post


Link to post
Share on other sites

>Bert,>Thanks for the suggestion, sounds well worth a try, especially>if SP1 defaults to vsync=on ? >In my Nvidia graphics card control panel the vsynch is set to>"as required by application" so I assume the SP2 default would>turn it off. Could you just explain which setting/s you>changed to over- ride the SP2 default please.>Thanks.>PeterI use FSAA at 4x and AF at 8x. Within FSX enable FSAA and TriLinear.I have not blurries either.

Share this post


Link to post
Share on other sites

Thanks for the additional info that I can try on my system - I hope to get a reply from Bert about what settings he changed in FSX to get the SP2 vsynch default setting from 'off' to 'on'. Did you change your SP2 default vsynch setting as well ?Thanks, Peter

Share this post


Link to post
Share on other sites

Hi,Same problem. My solution was to use nHancer http://www.nhancer.com/ and enable vsync. Enabling vsync in the 169.25 drivers did not work. Only a problem with SP2 and Acceleration. I got an annoying horizontal tearing effect. Gone now.Hope this helps you.Geoff6850 Vista 32 2G 8800GTXPS Why just some of us? ? just 8800 users

Share this post


Link to post
Share on other sites

Does anybody have any idea on how to fix this with an ATI card? I have 'wait vor vertical refresh' set to 'always on' in Catalyst Control Center. I still get the lines though, as if the screen gets split up horizontally...

Share this post


Link to post
Share on other sites

HiThanks for the nhancer suggestion. I had tried changing the globlal vsync setting in the Nvidia Control Panel to "force on" as suggested by Bert in another reply but unfortunately this did not stop the horizontal tearing effect when panning.I have now downloaded and installed nhancer to give this a try. Did you select the Vertical Sync 'on' option in the global settings or use the MS Flight Simulator X Profile in some way ? I am still using the 163.75 driver in the 8800GTX as 169.25 was not as crisp using photoscenery. Which driver were you using when the tearing problem was solved? Any further tips on how you used nhancer would be appreciated.Thanks Peter

Share this post


Link to post
Share on other sites

I'm using the 167.26 driver and solved the problem by enabling vsync in nHancer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this